LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-16-2012, 04:05 AM   #1
brezer
LQ Newbie
 
Registered: Dec 2012
Posts: 4

Rep: Reputation: Disabled
Internet problems


I have completed fresh installs multiple times and i was not getting any internet connection so i downloaded a full install of Debian 6.0.0 amd64. Its up and running now but i dont have any internet access. I have been looking on the web for hours and have had no luck figuring this out. Its been a looong time since i messed with linux, so let me tell you what i have done so far.

When i looked at the network icon in the top right corner it showed no connection so i edited the NetworkManager.conf in etc/networkmanager it originally looked like


[main]
plugins=ifdown,keyfile

no-auto-default=00:1b:fc:09:29:df,

[ifdown]
managed=false


I changed managed=false to managed=true and that showed me a connection at the icon, and that didnt work so next i edited resolv.conf, it showed


# Generated by NetworkManager


So then i added nameserver 8.8.8.8 and still no net.

So next i ran
CODE: SELECT ALL
lspci | grep Network
lspci | grep Ethernet


I get back

00:11.0 Bridge: nVidia Coporation MCP55 Ethernet (rev a2)
00:11.0 Bridge: nVidia Coporation MCP55 Ethernet (rev a2)


ifconfig i get back


eth0 Link encap:Ethernet HWaddr 00:1b:fc:09:1d:5b
inet addr:192.168.1.18 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::21b:fcff:fe09:1d5b/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:2976 (2.9 KiB)
interrupt:33 Base address:0x2000

eth1 Link encap:Ethernet HWaddr 00:1b:fc:09:29:df
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 KiB)
interrupt:34 Base address:0x4000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:16204 (15.8 KiB) Tx bytes:16204 (15.8 KiB)


I am at a loss right now so any help you could give me i would apperciate it.

thanks

I am also not able to ping my gateway.
 
Old 12-16-2012, 05:57 AM   #2
malekmustaq
Senior Member
 
Registered: Dec 2008
Location: root
Distribution: Slackware & BSD
Posts: 1,661

Rep: Reputation: 485Reputation: 485Reputation: 485Reputation: 485Reputation: 485
Quote:
I am also not able to ping my gateway.
Probably your device and host is not routed properly. This question (post) should have included what returns to query: ---# route -n but since it is not there let me only assume many important things and recommend the basic remedy as follows, to wit:

Set all interface down:

Code:
~# ifconfig lo down
~# ifconfig eth0 down
Set your host to the loop device:

Code:
/sbin/route add -net 127.0.0.0 netmask 255.0.0.0 lo
Set your loop (host) and the IP of your device:

Code:
/sbin/ifconfig lo 127.0.0.1
/sbin/ifconfig eth0 192.168.1.18 broadcast 192.168.1.255 netmask 255.255.255.0
Then set device to route to your your network (I am not sure whither comes your IP but I only assume that your ethernet router acting as DHCP served it to you ) so do this:

Code:
/sbin/route add -net 192.168.1.0 netmask 255.255.255.0 eth0
You can also fix this from the configuration file to be served by a DHCP=yes.

And route your network to the gateway:

Code:
/sbin/route add -net 192.168.1.0 netmask 255.255.255.0 gw 192.168.1.1 eth0
Then set the gateway to be your default:

Code:
/sbin/route add default gw 192.168.1.1 eth0
Ask (call) your internet provider what is your DNServer IP, if they don't give you there is another way to uncover it but that should not apply since they (ISP) are bound by contract to set it or to declare it to you.

Then add that DNS server IP number to your configuration, for example:

Code:
~# echo "xxx.xxx.xxx.xxx. myinternet.provider.com" >> /etc/resolv.conf
That's it. Launch Firefox and you should be surfing over the internet.

Hope that helps.

Good luck.

Last edited by malekmustaq; 12-16-2012 at 06:00 AM.
 
Old 12-16-2012, 10:12 AM   #3
brezer
LQ Newbie
 
Registered: Dec 2012
Posts: 4

Original Poster
Rep: Reputation: Disabled
All the above didnt change anything. Iam still not able to ping my gateway, 192.168.1.1

Also i pulled the dns server from the router but i wasnt really sure what to put in the yellow part so i left it as you put it.

~# echo "xxx.xxx.xxx.xxx. myinternet.provider.com" >> /etc/resolv.conf

I apperciate the help on this.
 
Old 12-16-2012, 11:39 PM   #4
malekmustaq
Senior Member
 
Registered: Dec 2008
Location: root
Distribution: Slackware & BSD
Posts: 1,661

Rep: Reputation: 485Reputation: 485Reputation: 485Reputation: 485Reputation: 485
Quote:
Originally Posted by brezer View Post
All the above didnt change anything. Iam still not able to ping my gateway, 192.168.1.1

Also i pulled the dns server from the router but i wasnt really sure what to put in the yellow part so i left it as you put it.

~# echo "xxx.xxx.xxx.xxx. myinternet.provider.com" >> /etc/resolv.conf

I apperciate the help on this.
Okay let us make it simple:

Quote:
echo "xxx.xxx.xxx.xxx. nameserver" >> /etc/resolv.conf
echo "nameserver xxx.xxx.xxx.xxx" >> /etc/resolv.conf
echo "search xxx.xxx.xxx.xxx" >> /etc/resov.conf
The xxx.xxx.xxx.xxx put there what is the IP number of your ISP's DNS; and "search xxxxxxxxx" also put there other name resolvers of your ISP, you will get it from them; else we will get it from traceroute as given below.

There are things to consider:

1. You must configure your /etc/resolv.conf file correctly or you won't be able to browse into the internet;

2. Did you call/ask from your ISP what is their dedicated DN server? You should get the IP from them and use it into the /etc/resolv.conf as suggested above.

3. Maybe something I did now about this case.

Can you trace up a node outside? Post us what this returns, say

Code:
~$ traceroute google.com
~$ traceroute yahoo.com
Also post here what this gives:

Code:
~# /sbin/route -n
~# /sbin/ifconfig -a
~# cat /etc/resolv.conf
Please post back what they returned.

Last edited by malekmustaq; 12-16-2012 at 11:53 PM.
 
Old 12-17-2012, 01:19 AM   #5
jmc1987
Member
 
Registered: Sep 2009
Location: Oklahoma
Distribution: Debian, CentOS, windows 7/10
Posts: 879

Rep: Reputation: 113Reputation: 113
If your not able to ping your gateway 192.168.1.1 its sounds like your on a home gateway/modem/router ie. Lynksys. Check your connections and besure you power cycle your router>computer. Most home routers have DHCP server built into. So just enable DHCP client on your computer. Do you have anyother computers hooked up to the network that connects to the internet through the same gateway/modem/router?

Also state your distro.
 
Old 12-17-2012, 11:19 PM   #6
brezer
LQ Newbie
 
Registered: Dec 2012
Posts: 4

Original Poster
Rep: Reputation: Disabled
I had ran into this a few years back and i ended up installing a new nic, which i had one laying around from like 07 still in the box and gave it a try. Did a fresh install and debian picked the new nic up with no problems.

Thanks for all the help though guys
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with internet Hondro Slackware 9 01-29-2009 12:56 AM
Internet problems UmneyDurak Ubuntu 13 02-22-2007 02:59 AM
Internet Problems sparton SUSE / openSUSE 2 03-09-2006 02:37 PM
Kppp problems/Internet Problems Lineux Linux - Newbie 2 09-29-2004 03:58 PM
internet problems with mandrake 10, eth problems rApT0r Linux - Newbie 10 04-11-2004 06:44 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 12:15 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration