LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-15-2007, 02:53 PM   #16
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled

Learn to be patient and don't double post.
 
Old 09-15-2007, 03:16 PM   #17
Controlpanel
Member
 
Registered: Sep 2007
Distribution: openSUSE 10.2
Posts: 48

Original Poster
Rep: Reputation: 15
Ok, but no one seems to be able to help me.
 
Old 09-15-2007, 03:32 PM   #18
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,275

Rep: Reputation: 370Reputation: 370Reputation: 370Reputation: 370
Based on your previous posts, it sounds like you have a DSL modem and it sounds like your computer connects directly to the modem without a router in between -- is that right? In that case you need to set up PPPoE. There is a piece of software called rp-pppoe that I believe is bundled with SuSE that has an easy setup for this. If you can't install it via YaST from your CDs you can download it at http://www.roaringpenguin.com/en/pen...oducts/rpPppoe but installation will probably be easier for you if you find it off your SuSE CDs.

If you connect through some other mechanism (e.g. a router, cable modem, or DSL that doesn't use PPPoE) please let us know -- this advice is only applicable to DSL over PPPoE/

Also, as a friendly hint, the more information you post about a problem and your set-up, the more help you are likely to receive.
 
Old 09-15-2007, 07:08 PM   #19
Controlpanel
Member
 
Registered: Sep 2007
Distribution: openSUSE 10.2
Posts: 48

Original Poster
Rep: Reputation: 15
No I have router in between and I am using a wireless connection, although I have tried connecting to the modem directly but that didn't work either.
 
Old 09-16-2007, 12:38 AM   #20
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,275

Rep: Reputation: 370Reputation: 370Reputation: 370Reputation: 370
Have you tried just plugging into one of the ports on the router? It looks like your Ethernet card (eth0) is detected but does not get an IP address. Try plugging in via a wired connection to the router and typing the command "dhclient eth0" (if you get "command not found" try the "dhcpcd" command -- I'm not sure which one SuSE uses).

If you can get this working then you can move on to the wireless card. Some Broadcom wireless chipsets can be painful to get going, though.
 
Old 09-16-2007, 01:15 AM   #21
Controlpanel
Member
 
Registered: Sep 2007
Distribution: openSUSE 10.2
Posts: 48

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by btmiller View Post
Have you tried just plugging into one of the ports on the router? It looks like your Ethernet card (eth0) is detected but does not get an IP address. Try plugging in via a wired connection to the router and typing the command "dhclient eth0" (if you get "command not found" try the "dhcpcd" command -- I'm not sure which one SuSE uses).

If you can get this working then you can move on to the wireless card. Some Broadcom wireless chipsets can be painful to get going, though.
Ok thanks I will try that.
 
Old 09-16-2007, 04:28 AM   #22
khinch
Member
 
Registered: Apr 2007
Location: Carlisle, UK
Distribution: Debian
Posts: 73

Rep: Reputation: 18
I recommend connecting directly to the router and setting it up that way before attempting the wireless connection, it could save you a lot of headaches. What kind of router do you have? Have you connected to it before using other operating systems?

Once you know whether you are using DHCP or not, and you know the IP address of the router, go into YaST (in KDE go KMENU -> System -> YaST) then click "Network Devices" on the left panel, and then "network card" in the right panel.

In the screen "Network Setup Method", I recommend choosing "Traditional Method with ifup". Click next. Then click your network card in the list and choose "edit".

In the "Network Address Screen" choose the "Address" tab and then if your router uses DHCP check this button, if not enter your IP manually (something like 192.168.0.2 and subnet mask 255.255.255.0).

Under "detailed settings" click "hostname and name server" and enter your desired computer name together with domain/workgroup if you want something different from the default. Under "name server1" add the IP address of your router, then click OK.

Click "routing" and in the "default gateway" box add the IP address of your router once more, and click OK.

After clicking on the "advanced" button there should be four options. It's likely you don't have to do anything in any of these, but I make a habit of clicking on each one in turn, and OKing the default settings. I started doing this a while back when I had similar connection problems to your own, and I honestly think it helped once.

Back in the "Network Address Setup" screen click next, and then in the next screen click finish.

Now try ifconfig again.
 
Old 09-17-2007, 11:28 AM   #23
Controlpanel
Member
 
Registered: Sep 2007
Distribution: openSUSE 10.2
Posts: 48

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by khinch View Post
I recommend connecting directly to the router and setting it up that way before attempting the wireless connection, it could save you a lot of headaches. What kind of router do you have? Have you connected to it before using other operating systems?

Once you know whether you are using DHCP or not, and you know the IP address of the router, go into YaST (in KDE go KMENU -> System -> YaST) then click "Network Devices" on the left panel, and then "network card" in the right panel.

In the screen "Network Setup Method", I recommend choosing "Traditional Method with ifup". Click next. Then click your network card in the list and choose "edit".

In the "Network Address Screen" choose the "Address" tab and then if your router uses DHCP check this button, if not enter your IP manually (something like 192.168.0.2 and subnet mask 255.255.255.0).

Under "detailed settings" click "hostname and name server" and enter your desired computer name together with domain/workgroup if you want something different from the default. Under "name server1" add the IP address of your router, then click OK.

Click "routing" and in the "default gateway" box add the IP address of your router once more, and click OK.

After clicking on the "advanced" button there should be four options. It's likely you don't have to do anything in any of these, but I make a habit of clicking on each one in turn, and OKing the default settings. I started doing this a while back when I had similar connection problems to your own, and I honestly think it helped once.

Back in the "Network Address Setup" screen click next, and then in the next screen click finish.

Now try ifconfig again.
Ok thanks I will try that and then post the results
 
Old 09-18-2007, 11:23 AM   #24
Controlpanel
Member
 
Registered: Sep 2007
Distribution: openSUSE 10.2
Posts: 48

Original Poster
Rep: Reputation: 15
I have a linksys router by the way.
 
Old 09-20-2007, 06:18 PM   #25
Controlpanel
Member
 
Registered: Sep 2007
Distribution: openSUSE 10.2
Posts: 48

Original Poster
Rep: Reputation: 15
I finally got a wired connection to the internet set up. What know to get wireless internet?

ifconfig
Quote:
eth0 Link encap:Ethernet HWaddr 00:14:22:90:98:B0
inet addr:192.168.1.100 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::214:22ff:fe90:98b0/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:3752 errors:0 dropped:0 overruns:0 frame:0
TX packets:3414 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:2611803 (2.4 Mb) TX bytes:591242 (577.3 Kb)
Interrupt:217

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:66 errors:0 dropped:0 overruns:0 frame:0
TX packets:66 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:4572 (4.4 Kb) TX bytes:4572 (4.4 Kb)
lspci
Quote:
00:00.0 Host bridge: Intel Corporation Mobile 915GM/PM/GMS/910GML Express Processor to DRAM Controller (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 1 (rev 03)
00:1c.3 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 4 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #3 (rev 03)
00:1d.3 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev d3)
00:1f.0 ISA bridge: Intel Corporation 82801FBM (ICH6M) LPC Interface Bridge (rev 03)
00:1f.1 IDE interface: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) IDE Controller (rev 03)
02:00.0 Ethernet controller: Broadcom Corporation BCM4401-B0 100Base-TX (rev 02)
02:03.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)
 
Old 09-20-2007, 09:47 PM   #26
Controlpanel
Member
 
Registered: Sep 2007
Distribution: openSUSE 10.2
Posts: 48

Original Poster
Rep: Reputation: 15
I would like to configure my wireless network card, but I have no idea how to do this. I have tried looking on google, but that has not helped.
 
Old 09-21-2007, 11:21 AM   #27
Controlpanel
Member
 
Registered: Sep 2007
Distribution: openSUSE 10.2
Posts: 48

Original Poster
Rep: Reputation: 15
I searched for drivers for my wireless network card and could not figure out which driver to use there are so many could someone help me?
 
Old 09-21-2007, 12:37 PM   #28
khinch
Member
 
Registered: Apr 2007
Location: Carlisle, UK
Distribution: Debian
Posts: 73

Rep: Reputation: 18
If you're having trouble finding native Linux drivers, you can try using ndiswrapper to install the windows drivers under Linux.

First go into YaST > Software > Software Management and make sure ndiswrapper is installed.

Next locate the windows driver .INF file for your card. This should have come with it, or else you'll probably find it on the manufacturer's website. Open a terminal and become root. Navigate to the directory the .INF file is in, then type "ndiswrapper -i <drivername>.inf".

To check it has installed correctly, type "ndiswrapper -l".

Now you should be able to set up the card as a wireless card under YaST > Network Devices > Network Card > ADD (instead of EDIT this time).

If you get lost, refer to one of these guides: ndiswrapper - OpenSuSE or ndiswrapper - howto
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
SUSE Linux without internet - possible? mdg583 Linux - Desktop 2 12-29-2006 05:59 PM
Suse LInux+Internet connection winnie.linux Linux - Networking 1 09-02-2006 05:07 PM
SuSE 10.0 Llinux internet probem: the first time after installing SuSE the internet kunala05 Linux - Wireless Networking 1 07-27-2006 11:03 PM
Internet is slow under SUSE Linux bubble SUSE / openSUSE 9 11-23-2004 03:12 PM
Linux SuSE 9.0 Cannot connect to the Internet rangerssg Linux - Software 20 11-01-2004 06:52 PM


All times are GMT -5. The time now is 12:24 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration