LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-20-2011, 09:17 PM   #16
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.8, Centos 5.10
Posts: 17,240

Rep: Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324

Seeing as you've got a 5.x system, this manual will be useful http://www.linuxtopia.org/online_boo...ion/index.html.
As above, Centos is a faithful copy of RHEL, so that will be fine to learn on.
 
Old 04-20-2011, 09:44 PM   #17
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Debian, Mint, OpenBSD
Posts: 11,342
Blog Entries: 12

Rep: Reputation: 2730Reputation: 2730Reputation: 2730Reputation: 2730Reputation: 2730Reputation: 2730Reputation: 2730Reputation: 2730Reputation: 2730Reputation: 2730Reputation: 2730
Quote:
Originally Posted by infinite_scale View Post
Eth0 connection
Primary DNS 192.168.1.1
Are you running your own DNS server?

192.168.1.1 is normally the address of the gateway router in a home network, not of the DNS server.
 
Old 04-21-2011, 12:51 AM   #18
infinite_scale
Member
 
Registered: Feb 2011
Location: NCR, Uttar Pradesh, India
Posts: 74

Original Poster
Rep: Reputation: 1
sibe,

Yes, it shows the same results for eth1 and eth2.
However when I run ls /etc/sysconfig/network-scripts | grep ifcfg it shows--
ifcfg-eth1
ifcfg-lo

And I ran the above command after su - only, supposing that every command we run from now on should be through this prevelidged root only.. Right??

Also, I'd appreciate if you can just add a short explanation after each step you tell me to perform, describing what it does; what directories/files do what..etc and whatever is related to it .

Thanx

Last edited by infinite_scale; 04-21-2011 at 12:53 AM.
 
Old 04-21-2011, 12:58 AM   #19
infinite_scale
Member
 
Registered: Feb 2011
Location: NCR, Uttar Pradesh, India
Posts: 74

Original Poster
Rep: Reputation: 1
Hi frankbell,
When I launch network from Administration, it just shows the following 4 tabs and New Edit Delete buttons--
Devices Hardware IPsec DNS Host

There is no services section
And I guess it has to be 192.168.1.1 in Primary hosts?? Right??
 
Old 04-24-2011, 12:10 PM   #20
infinite_scale
Member
 
Registered: Feb 2011
Location: NCR, Uttar Pradesh, India
Posts: 74

Original Poster
Rep: Reputation: 1
Hey guys, why have you stopped responding?

I need your help guys, please help in mi issue's resolution.
 
Old 04-24-2011, 12:59 PM   #21
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, SLES, CentOS, Red Hat
Posts: 2,385

Rep: Reputation: 476Reputation: 476Reputation: 476Reputation: 476Reputation: 476
@ Reply

Hi there,

Just trying to catch up with you guys and as I can understand RHEL is unable to see any eth device on your system.

When you installed RHEL at that time did eth appeared on the list I am sure it should be.

Another thing check whether you see any eth device under /dev

Type:

cd /dev/
ls -l

Also check which are the modules that are loaded. Check in the list if you see any module related to network card

lsmod

Usually RedHat standard kernel detects all connected hardware automatically. If it has not detected it you can give a try to following command:

depmod -a

Also I would be interested in knowing which type of network card you are using. Give a try to following command and let me know the output:

modprobe -lt net

If still have a problem check you system's peripheral again RedHat HCL: https://hardware.redhat.com/
 
Old 04-24-2011, 03:47 PM   #22
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,818

Rep: Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408
from the how to's and guides
have you ran " gnome-network-properties" and "system-config-network" from the terminal

are you using the Daemon "networkManager" OR the older " Network" ???
It is VERY important to know what one you are using
network is a manual configure for a static ip
networkManager is a auto detect and best for a wireless or if using a router

Quote:
There is no services section
??? what ???
yes there IS there is a gnome menu item called
System / Administration / Service

click on service

also seeing as you are SO new to linux i would NOT recommend that you use RHEL
now if you HAVE BOUGHT the REQUIRED license and support contract then USE IT and call red hat on the phone and get help from the all ready paid for contract

or

install a "new user friendly" distro like Ubuntu or Mint

red hat and it's like ( CentOS, Scientific Linux) are not meant for the "new to Linux" group
there target user is the Server admin ! The corporate IT department ! the Laboratory IT department
basically experienced users.
 
Old 04-26-2011, 12:08 PM   #23
infinite_scale
Member
 
Registered: Feb 2011
Location: NCR, Uttar Pradesh, India
Posts: 74

Original Poster
Rep: Reputation: 1
Quote:
Originally Posted by John VV View Post
??? what ???
yes there IS there is a gnome menu item called
System / Administration / Service


also seeing as you are SO new to linux i would NOT recommend that you use RHEL
now if you HAVE BOUGHT the REQUIRED license and support contract then USE IT and call red hat on the phone and get help from the all ready paid for contract

or

install a "new user friendly" distro like Ubuntu or Mint

red hat and it's like ( CentOS, Scientific Linux) are not meant for the "new to Linux" group
there target user is the Server admin ! The corporate IT department ! the Laboratory IT department
basically experienced users.
Actually John, I was talking about the absence of Services tab in Network, not Services in Administration. Sorry for the misquote.

Also, I started using Linux (RHEL) with the intention of having a career in Linux. That's why I thought I should start working with RHEL or Centos. If in addition to this thread's issue, you can guide me on how should I go about learning Linux and what resources (books, etc) should I use, I'd really appreciate that.
 
Old 04-26-2011, 12:11 PM   #24
infinite_scale
Member
 
Registered: Feb 2011
Location: NCR, Uttar Pradesh, India
Posts: 74

Original Poster
Rep: Reputation: 1
Hi Terminator,

Will try ASAP all that you posted, and post the results.
Right now, I'm away from my home.

Thanks :-)
 
Old 04-30-2011, 03:47 AM   #26
infinite_scale
Member
 
Registered: Feb 2011
Location: NCR, Uttar Pradesh, India
Posts: 74

Original Poster
Rep: Reputation: 1
Quote:
Originally Posted by T3RM1NVT0R View Post
Another thing check whether you see any eth device under /dev

Type:

cd /dev/
ls -l

Also check which are the modules that are loaded. Check in the list if you see any module related to network card

lsmod

Usually RedHat standard kernel detects all connected hardware automatically. If it has not detected it you can give a try to following command:

depmod -a

Also I would be interested in knowing which type of network card you are using. Give a try to following command and let me know the output:

modprobe -lt net

If still have a problem check you system's peripheral again RedHat HCL: https://hardware.redhat.com/
There is no "eth" under /dev/
ls mod returns nothing
"depmod -a" also returns nothing
"modprobe -lt net" returns a lot of stuff. There are a lot of paths and each file in the end end s with a .ko extension

My network card is Realtek 1839; checked this in Windows some time back.
 
Old 04-30-2011, 04:00 AM   #27
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,818

Rep: Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408
at this point try a clean install
and in the second window -- i think- during install it asks to set up the network
set it up there

also ( this WAS A BIG issue for me and MY ISP - now fixed-) but not too many others
"wide open west" was royally messing up ipv6 calls so bad that THE ONLY way i could get the network to work was to DISABLE ipv6 support during the install there is a check box buried in the install menu to disable ipv6 .BUT set the network ip address and the dns there
use "google DNS"( 8,8,8,8) or "OpenDNS"(208.67.222.222) your ISP's DNS might be Microsoft only ( as in will not even work for Mac )

my issue and might not be yours .This was fixed by the ISP and no longer an issue for me

and seeing as there are no more ipv4 addresses ipv6 IS A MUST
 
Old 04-30-2011, 10:06 AM   #28
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, SLES, CentOS, Red Hat
Posts: 2,385

Rep: Reputation: 476Reputation: 476Reputation: 476Reputation: 476Reputation: 476
@ Reply

Hi there,

It might be the limitation of the existing kernel and that is why it is not able to detect the ethernet card. You can try building the custom kernel using the following steps:

1. Get the kernel from www.kernel.org
2. Usually it get downloaded to /user/Desktop location.
3. Copy it to the location where you have enough space.
3. If it is a .bz file use tar -xjvf file_name else go with tar -zxvf file_name.
4. Once the above file is extracted go in the extracted directory and check if you see any .config file
5. If not the next step is to run make config or make menu config or make gconfig or make xconfig depend which tool you want to use to create custom kernel. I prefer using make gconfig.
6. Once the tool is launched you can select which options you want there in the custom kernel. Make sure that your custom kernel is modular so that you can load device drivers as module instead of compiling them with kernel. This also enhances performance.
7. Once done with building up the configuration save it and exit the tool. This will create .config file in that location which will contain custom settings that you did with the tool (make config or make menuconfig etc)
8. Run make mrproper
9. Go to the file with the name MakeFile which will be in the same location as that of extraction. Change the EXTRAVERSION parameter in that file to the name that you would like to give to your custom kernel, save and exit. Do not change anything else.
10. Now before going with make rpm. Make sure that you have enough space on /usr directory. If you have anything important there then copy it to some other location. For me it worked even with 2 GB. But you can go with a little more say 3-4 GB.
11. Run the make rpm from the location where you have .config file.
12. After running the above command you will find the rpm in usr/src/RPMS/i386 if you have built it for i386 architecture else look under the appropriate architecture directory under /usr/src/RPMS
13. Run rpm -ivh rpm_filename (Do not run rpm -Uvh as this will upgrade your existing kernel and what if this new kernel didn't work for you)
14. After installing the new kernel make appropriate changes in /boot/grub/grub.conf file to reflect the new kernel load script.
15. Make initial RAM disk image for your new kernel. This you can do by going in /boot directory and then issuing makeinitrd /xyzkernel.img kernel_name. Where xyz will be the name of your custom kernel.
16. Reboot the system and see you see a new kernel entry at the startup in grub :-) If you find any issues with new kernel then we can always boot in old kernel to get it fixed :-)

OR

If you are planning to perform a fresh install then at the boot prompt where it ask you to select the way you want to install go with linux noprobe this will prompt you to select every driver according to your wish (Ofcourse you need to know which driver will be required for your device)

Last edited by T3RM1NVT0R; 05-01-2011 at 12:03 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Help configuring Bind on RHEL 5 ma-xr Linux - Server 3 03-03-2011 09:57 PM
[SOLVED] Internet not working in newly installed RHEL 5 infinite_scale Red Hat 11 02-17-2011 03:59 PM
Configuring DHCP and Internet sharing on RHEL5, still not working. mid_nightslover Linux - Enterprise 5 03-21-2010 02:20 AM
Internet is not working in RHEL server 5 kumar.chakram Linux - Newbie 7 12-14-2009 12:31 AM


All times are GMT -5. The time now is 06:33 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration