LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-17-2006, 09:05 AM   #1
bindusaleel
LQ Newbie
 
Registered: Jun 2006
Posts: 5

Rep: Reputation: 0
Internet Not Working


I have recently installed Ubuntu ( Linux) but ungortunately am unable to connect to the internet as it does not identify my connection, tho in windows I have no probs.I m using a Siemens Speedstream 6520 to connect to the internet and the driver provided with it is only compatible for windows / mac os. It was provided by the Internet Service Provider in my area ( Etisalat in UAE ) and when I contacted them for help they said that they do not provide support for linux. So, now I am in a fix as I really liked Ubuntu but am unable to switch to it completely as I cant be connected to he net. Pls help.
 
Old 06-17-2006, 09:31 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
the speedstream 6520 is an ethernet router. it does not use drivers or anything, and it operate wholly independently to whatever machines connect to it. you need to look elsewhere to find what the problem is. firstly check your ethernet card is working, that you have layer 2 connectivity (a light on it) and that you can then ping the ip of the router. also check the output of "route -n" abnd "ifconfig" to see what your network settings currently look like.
 
Old 06-17-2006, 09:50 AM   #3
bindusaleel
LQ Newbie
 
Registered: Jun 2006
Posts: 5

Original Poster
Rep: Reputation: 0
it is working with windows XP cos thats how i am online now. But what is ifconfig? I do not know much about what is to be done.
 
Old 06-17-2006, 10:00 AM   #4
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
open a root terminal and run the commands i suggested. how do you even know your connection is not working?
 
Old 06-17-2006, 10:05 AM   #5
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 5,872

Rep: Reputation: Disabled
Well, the difference between using Linux or Windows is everything is automatically configured for Windows by the software provided by your ISP. In order to make it work under Linux you need to know how exactly your connection works. Nobody here can help you without knowing this. The problem here is some ISP's disable the router features of the modem and ship it pre-configured in bridge mode. This is probably an attempt to save on resources - user gets disconnected when computer is shut down. Anyway, you need to look at your connection under Windows. If Windows does all the PPPoE stuff (and has a public IP address) then your modem is in bridge mode.
 
Old 06-17-2006, 10:16 AM   #6
bindusaleel
LQ Newbie
 
Registered: Jun 2006
Posts: 5

Original Poster
Rep: Reputation: 0
I know it does not work cos when I open the browser in linux it gives server not found. It is not identifying the connection. and then I do not understand how to add any of the details in terminal except for the username and password. I did not have to do anything in windows. Just put in the cd and the whole thing got configured.
 
Old 06-17-2006, 10:46 AM   #7
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
well why not actually do what we are suggesting... run route and ifconfig in a terminal as root. "detecting the connection" means next to nothing. if the commands fail to run, run them with a full path, e.g. /sbin/route and /sbin/ifconfig.

that's really crap if the isp is just bridging... but then why dish out a 4 port wireless route if it's just bridging?

Last edited by acid_kewpie; 06-17-2006 at 10:47 AM.
 
Old 06-24-2006, 10:45 AM   #8
bindusaleel
LQ Newbie
 
Registered: Jun 2006
Posts: 5

Original Poster
Rep: Reputation: 0
This is what I get when I run ifconfig...Can you help me out now to configure my internet in any way??



eth0 Link encap:Ethernet HWaddr 00:14:85:01:CA:7C
inet addr:169.254.100.217 Bcast:169.254.255.255 Mask:255.255.0.0
inet6 addr: fe80::214:85ff:fe01:ca7c/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:43 errors:0 dropped:0 overruns:0 frame:0
TX packets:42 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:2580 (2.5 KiB) TX bytes:3780 (3.6 KiB)
Interrupt:185

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:392 errors:0 dropped:0 overruns:0 frame:0
TX packets:392 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:28808 (28.1 KiB) TX bytes:28808 (28.1 KiB)
 
Old 06-24-2006, 11:03 AM   #9
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 5,872

Rep: Reputation: Disabled
RFC 3330 - 169.254.0.0/16 - This is the "link local" block. It is allocated for communication between hosts on a single link. Hosts obtain these addresses by auto-configuration, such as when a DHCP server may not be found.

The IP address your NIC has does not help much because you have no active connection (see above). What you really need to do is to see whether Windows is using a public or private address. Right now it looks like buying one of those little routers might be best way to resolve this problem - as acid_kewpie suggested. Ubuntu can deal easily with ethernet/DHCP connections, so I still suspect your modem is in bridge mode.
 
Old 06-24-2006, 11:44 AM   #10
bindusaleel
LQ Newbie
 
Registered: Jun 2006
Posts: 5

Original Poster
Rep: Reputation: 0
Actually, I think the connection is not active cos I have not managed to configure it yet. I still don't know what to put where..

I cannot use any other routers as this is what is provided by the Internet provider here in Abu Dhabi. And my internet provider did tell me that this router can be configured for linux but they will just not provide any help ..

but how do I know if it is in bridge mode? Plas help..I really want to start using ubuntu..Thanks guys..
 
Old 07-02-2006, 10:10 PM   #11
igorc
Member
 
Registered: May 2005
Location: Sydney, Australia
Distribution: Ubuntu 5.04, Debian 3.1
Posts: 74

Rep: Reputation: 15
Hi,

I'm using Ubuntu with SpeedStream 4200 DSL modem/router and I have successfully connected to internet. I think Emerson is right, your modem/router is probably set in bridge mode, atlist mine is. This is what you should do:

1. Because you said everything works fine for you in Windows, go to your TCP/IP connection setup and wright down the IP address (mine was 10.1.1.3), default gateway address (it should be the IP address of your modem/router e.g. 10.1.1.1), netmask value (e.g. 255.255.0.0) and DNS address (or addresses) of your ISP DNS server(s)

2. Then restart in Ubuntu and configure your eth0 interface like this (as root in terminal window):

# ifconfig eth0 IP_address_from_windows netmask netmask_value_from_windows
# route add default gw Gateway_address_from_windows dev eth0
# ifconfig -you should see here the eth0 configuration like the one you have in windows
# vi /etc/resolve.conf - put here the following line(s), you can use some other text editor if you are not comfortable with vi
nameserver DNS_address1_from_windows
nameserver DNS_address2_from_windows

This should be enaf for you to connect to the internet with your eth0 interface statically configured. To make this changes permanent yo should put all of this informations in /etc/network/interfaces file under the line for eth0.

I hope this will help. It works for me.

Regards,

Igor
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How do i get my internet working? ExplodingTeddyBear Linux - Newbie 6 12-29-2005 10:49 PM
Internet not working, network working Vossy Linux - Networking 3 12-20-2005 06:20 PM
internet is not working oldi Slackware 18 05-14-2004 07:52 PM
Internet not working. stillme Linux - Networking 10 04-11-2004 04:59 PM
Internet working, network not working... phoenix07 Fedora 1 04-11-2004 03:30 AM


All times are GMT -5. The time now is 12:39 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration