LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 02-26-2005, 11:21 AM   #1
wardialer
Member
 
Registered: Sep 2004
Distribution: SUSE Linux Pro 9.3
Posts: 375

Rep: Reputation: 30
Internet connection problems


Here are my current LAN settings under Configure LAN Settings:
Adapter 1: eth0
Start on Boot: Yes
DHCP Protocol: DHCP


I am using a Router.
This is a stand-alone PC.

In the part of the Wizard setup, I see this:
Automatic IP (bootp/dhcp/zeroconf)
IP address: 10.0.0.10
Netmask: 255.255.255.0


What should I select above???? Please explain.

Now heres the problem, everytime during the bootup process, "The Checking Internet connections to start at boot" hangs for a minute.

Also, how come I have to manually go into MCC to manually connect myself to the Internet even though I selected to Connect on Boot with DHCP settings?

Even though I selected Start on Boot, it will not connect automatically to the Internet upon boot. I have to do it through the MCC.

How could I solve this problem?

Last edited by wardialer; 02-26-2005 at 11:30 AM.
 
Old 02-26-2005, 11:25 AM   #2
knoxlinuxuser
Member
 
Registered: Feb 2005
Location: Knoxville, Tennessee
Distribution: SuSE 9.0, Gentoo 2005.0, Fedora Core 4
Posts: 42

Rep: Reputation: 15
wardialer,

I had a similar problem.
Use "ifconfig" to change your IP address for the ethernet (probably eth1) and your submask. Check out the man page for exact syntax.
Then use ifconfig again to make eth1 up
"ifconfig eth1 up"

Then run "pump -i eth1", but remember you must be root to use pump.
That fixed the problem for me.
 
Old 02-26-2005, 11:32 AM   #3
wardialer
Member
 
Registered: Sep 2004
Distribution: SUSE Linux Pro 9.3
Posts: 375

Original Poster
Rep: Reputation: 30
So what IP address do I have to change it to??? I JUST WANT TO BE ABLE TO CONNECT AUTOMATICALLY ON BOOT. THATS ALL. AND WHY IS THE "CHECKING INTERNET CONNECTIONS AT BOOT" HANGING ALL THE TIME???

Explain the steps on what I have to do?

My current settings are like this.

Here are my current LAN settings under Configure LAN Settings:
Adapter 1: eth0
Start on Boot: Yes
DHCP Protocol: DHCP

I am using a Router.
This is a stand-alone PC.

In the part of the Wizard setup, I see this:
Automatic IP (bootp/dhcp/zeroconf)
IP address: 10.0.0.10
Netmask: 255.255.255.0

I want to be able to connect on boot right away. So what should I do in the Wizard?

Here is the putput of ifconfig:

Code:
ifconfig
eth0      Link encap:Ethernet  HWaddr **MAC ADDRESS BLOCKED***
          inet addr:192.168.1.100  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:662 errors:0 dropped:0 overruns:0 frame:0
          TX packets:867 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          RX bytes:365868 (357.2 Kb)  TX bytes:160221 (156.4 Kb)
          Interrupt:11 Base address:0xd000

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:206 errors:0 dropped:0 overruns:0 frame:0
          TX packets:206 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:13326 (13.0 Kb)  TX bytes:13326 (13.0 Kb)

Last edited by wardialer; 02-26-2005 at 11:48 AM.
 
Old 02-26-2005, 11:54 AM   #4
wardialer
Member
 
Registered: Sep 2004
Distribution: SUSE Linux Pro 9.3
Posts: 375

Original Poster
Rep: Reputation: 30
Well... I guess know one knows.

I really need some help with this. What do I have to do with these settings below in order to connect on boot and get rid of that hang on bootup thing?

Here are my current LAN settings under Configure LAN Settings:
Adapter 1: eth0
Start on Boot: Yes
DHCP Protocol: DHCP

I dont know why it has the IP Address of 10.0.0.10??

In the part of the Wizard setup, I see this:
Automatic IP (bootp/dhcp/zeroconf)
IP address: 10.0.0.10
Netmask: 255.255.255.0

Last edited by wardialer; 02-26-2005 at 11:55 AM.
 
Old 02-26-2005, 12:16 PM   #5
wardialer
Member
 
Registered: Sep 2004
Distribution: SUSE Linux Pro 9.3
Posts: 375

Original Poster
Rep: Reputation: 30
Its pretty weird that Im here on a Linux forum and know body seems to know the answer to this question....
 
Old 02-26-2005, 12:37 PM   #6
chris318
Member
 
Registered: Feb 2005
Distribution: Slack
Posts: 122

Rep: Reputation: 18
Maybe a problem:

inet addr:192.168.1.100 Bcast:192.168.1.255 Mask:255.255.255.0

is 192.168.1.100 really the ip the router is assigning you, or is it the ip of the router itself?
 
Old 02-26-2005, 12:49 PM   #7
wardialer
Member
 
Registered: Sep 2004
Distribution: SUSE Linux Pro 9.3
Posts: 375

Original Poster
Rep: Reputation: 30
Its the IP address of the router. But I disabled the IPTables under services and seemed to fixed the issue. My guess is, that maybe AND I STRESS.....MAYBE..... that since my router is designed for firewalling, I think the IPtables and the router had a conflict....

I dont know. but the problem solved. And also i played around in the Connection Wizard a bit and did some settings such as removing that IP address of 10.0.0.10 and just checking the Auto IP and Start on Boot checked. Oh well...and addition to this, the hang went away on bootup too.

And another small issue here..... Ok, I started downloading the new release of Firefox for Linux and Im getting a download speed of 5.5kbps.... which is very strange considering Im on DSL.

Could anyone shed some light on this???

Last edited by wardialer; 02-26-2005 at 12:51 PM.
 
Old 02-26-2005, 12:55 PM   #8
chris318
Member
 
Registered: Feb 2005
Distribution: Slack
Posts: 122

Rep: Reputation: 18
sounds like you have a dns problem and it's taking forever to resolve names to ip address. edit your /etc/resolv.conf with your correct dsn servers.

/etc/resolv.conf
nameserver "ip_address"
nameserver "ip_address"

See if that helps.
 
Old 02-26-2005, 03:11 PM   #9
wardialer
Member
 
Registered: Sep 2004
Distribution: SUSE Linux Pro 9.3
Posts: 375

Original Poster
Rep: Reputation: 30
I did this command as root and I get a Permission Denied.
 
Old 02-26-2005, 03:14 PM   #10
chris318
Member
 
Registered: Feb 2005
Distribution: Slack
Posts: 122

Rep: Reputation: 18
huh, impossible. root is the king. root can edit /etc/resolv.conf and any other file. not sure what that is about?
 
Old 02-26-2005, 03:17 PM   #11
chris318
Member
 
Registered: Feb 2005
Distribution: Slack
Posts: 122

Rep: Reputation: 18
you did sub edit for a real editor right?

say
root$ vi /etc/resolv.conf
or
root$ pico /etc/resolv.conf
or
root$ emacs /etc/resolv.conf

any editor will do the trick
 
Old 02-26-2005, 03:33 PM   #12
wardialer
Member
 
Registered: Sep 2004
Distribution: SUSE Linux Pro 9.3
Posts: 375

Original Poster
Rep: Reputation: 30
I use GEDIT to configure settings: I will try that.

I opened up Gedit and located that directory and heres what happened:

nameserver 127.0.0.1
nameserver 66.51.205.100
nameserver 66.51.206.100
search localhost local

Which is right. Thats DNS servers

Last edited by wardialer; 02-26-2005 at 03:37 PM.
 
Old 02-26-2005, 03:48 PM   #13
chris318
Member
 
Registered: Feb 2005
Distribution: Slack
Posts: 122

Rep: Reputation: 18
take out the nameserver 127.0.0.1. problem solved. have a nice day.
 
Old 02-26-2005, 04:03 PM   #14
wardialer
Member
 
Registered: Sep 2004
Distribution: SUSE Linux Pro 9.3
Posts: 375

Original Poster
Rep: Reputation: 30
Well thanks alot. thats more like it. Getting 40 kbps download speed now. Thanks a bunch
 
Old 02-27-2005, 12:31 PM   #15
wardialer
Member
 
Registered: Sep 2004
Distribution: SUSE Linux Pro 9.3
Posts: 375

Original Poster
Rep: Reputation: 30
Everything was working great, but this morning, I cant even open webpages now. Well, I could because my Google homepage popped up, but the other webpages will not open or will just hang.

What the hell is going on here????

I did what Chri318 said and it worked yesterday, but why I am now having troulbe opening up webpages????

Please explain the settings for the following:

1. How can I start the connection automatically without going into MCC and doing it manually?

2. I have a DSL modem connection with a Router that does the PPPoE. What settings I need to do here???

Please explain.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
internet connection problems drevil666 Linux - Newbie 3 06-29-2005 02:34 PM
problems with internet connection aertim Linux - Wireless Networking 0 12-04-2004 12:16 PM
Internet Connection problems. wo1fz Slackware 6 06-29-2004 04:19 PM
Internet Connection Problems...again! justiceisblind Linux - Newbie 0 04-21-2002 12:38 PM
internet connection problems greatgatsby26 Linux - Networking 4 05-04-2001 08:40 PM


All times are GMT -5. The time now is 02:54 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration