LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-01-2006, 07:00 AM   #1
john555red
LQ Newbie
 
Registered: Dec 2005
Posts: 2

Rep: Reputation: 0
internet connection


I have a kn8ultra939 mb with inbuilt gigabit connection the internet is optus cable work fine on xp but can not get it to work on red hat 9. There is no dns for optus as it is a permanent connection
can anyone help or is it impossible to do
 
Old 06-01-2006, 09:22 AM   #2
lord-fu
Member
 
Registered: Apr 2005
Location: Ohio
Distribution: Slackware && freeBSD
Posts: 676

Rep: Reputation: 30
I dont understand what you mean there is no dns, there has to be dns or there will be no sort of name resolution taking place. I believe what you mean is that you have a dynamic ip. If this is the case you just need to set up your network connection to dhcp. This means it will use your ISP as its dns source.
Hope that helps.
Sorry If I am wrong.
 
Old 06-01-2006, 09:26 AM   #3
osor
HCL Maintainer
 
Registered: Jan 2006
Distribution: (H)LFS, Gentoo
Posts: 2,450

Rep: Reputation: 75
Quote:
Originally Posted by john555red
I have a kn8ultra939 mb with inbuilt gigabit connection the internet is optus cable work fine on xp but can not get it to work on red hat 9. There is no dns for optus as it is a permanent connection
can anyone help or is it impossible to do
There has to be a DNS of some sort (either your own, your ISP's, or an open one) in order to look up hostnames. Is there anything in-between the cable modem and the computer? If it works in XP, then get the network information (IP address, and DNS servers) from XP and use those in linux.

P.S.
If you are starting out in linux, I suggest you get a more modern distro (redhat 9 is old and unsupported --- try fedora core, a community-version derivative).
 
Old 06-01-2006, 09:36 AM   #4
camorri
LQ Guru
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1, 14.2
Posts: 5,145

Rep: Reputation: 503Reputation: 503Reputation: 503Reputation: 503Reputation: 503Reputation: 503
You always will have DNS for any internet service provider, regardless of the type of connection. Find out ( form XP id it works ) what your DNS addresses are and edit your /etc/resolv.conf file ( edit it as root ) and add lines such as :

nameserver 206.47.244.52
nameserver 206.47.244.108

These are the name servers my ISP provides, they won't work for you.
 
Old 06-02-2006, 08:46 PM   #5
john555red
LQ Newbie
 
Registered: Dec 2005
Posts: 2

Original Poster
Rep: Reputation: 0
Thanks to all re the internet connection you are all right and as a newbie I guess its understandble. I have put all the ip address numbers sub net mask numbers dns server numbers etc however it still does not connect I guess this is because it is a gigabitconnection so Linux doesnt understand this type of connection

Cheers
 
Old 06-02-2006, 11:44 PM   #6
osor
HCL Maintainer
 
Registered: Jan 2006
Distribution: (H)LFS, Gentoo
Posts: 2,450

Rep: Reputation: 75
Quote:
Originally Posted by john555red
Thanks to all re the internet connection you are all right and as a newbie I guess its understandble. I have put all the ip address numbers sub net mask numbers dns server numbers etc however it still does not connect I guess this is because it is a gigabitconnection so Linux doesnt understand this type of connection
Cheers
I still don't understand the problem. What is not working? Where are you putting the numbers in? How have you tried to fix it? I doubt that linux does not have a driver for that card, but redhat 9 used a kernel 2.4.20(?), and may not included it. As I said before, if this is your first try at linux (which it seems to be), why not a newer distro?
 
Old 06-02-2006, 11:46 PM   #7
JimBass
Senior Member
 
Registered: Oct 2003
Location: New York City
Distribution: Debian Sid 2.6.32
Posts: 2,100

Rep: Reputation: 49
Your hardware is too new for Redhat 9. That came out years ago, when gigabit nics were super expensive server only things. As was mentioned above, upgrading to a distro that is from late 2005 or 2006 will automatically detect and use your gigabit card.

It is a shame Redhat 9 ever came out, becuase it was junk to begin with, and now years later, half the posts here are asking why things don't work with RH9. Please all newbies, ditch RH! If you like it, go to Fedora Core 5. That is correct, there have been 5 major releases by the same folks that gave us RH9.

Peace,
JimBass
 
  


Reply

Tags
john


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Slow Internet Connection when Connecting to Internet on Browsers lennysokol Linux - Networking 8 04-09-2011 04:29 PM
Nic card -> cable internet modem no internet connection zeshan_b Mandriva 21 09-26-2004 11:48 AM
Messed up my internet settings (NO internet connection) :( Almazick Linux - Networking 2 09-08-2004 12:05 PM
My internet apps cannot detect my internet connection esthon_wood Mandriva 5 08-30-2004 08:38 PM
i can get internet connection in windows but in LINUX there is no connection ruzvay Linux - Networking 2 06-08-2004 07:02 PM


All times are GMT -5. The time now is 01:44 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration