LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-21-2004, 08:10 AM   #1
Drake88
LQ Newbie
 
Registered: Oct 2003
Location: Denmark (DK)
Distribution: Mandrake 10.1
Posts: 23

Rep: Reputation: 15
Internet?


Hi. I'm running Mandrake Linux 10.1 and i'm connected to my network (a router) with a wireless device. I have a perfect connection to the network, however, I can't connect to the Internet. Under windows, I can just set the router (192.168.1.1) as the gateway. What do I do here..? Please, I'm desperate!
 
Old 12-21-2004, 08:26 AM   #2
jtshaw
Senior Member
 
Registered: Nov 2000
Location: Seattle, WA USA
Distribution: Ubuntu @ Home, RHEL @ Work
Posts: 3,892
Blog Entries: 1

Rep: Reputation: 67
In your /etc/resolve.conf file you need to put in the nameservers.

Syntax is as follows:
Code:
nameserver xxx.xxx.xxx.xxx
nameserver xxx.xxx.xxx.xxx
You need at least one, you can have as many as you'd like. I recommend at least two. You should be able to get them from the router status information as you probably want to use your ISP's nameservers.



BTW... if you using DHCP to get your address with the linux box it should do this automatically. Unless your router isn't giving out the information for some reason.
 
Old 12-22-2004, 12:03 PM   #3
Drake88
LQ Newbie
 
Registered: Oct 2003
Location: Denmark (DK)
Distribution: Mandrake 10.1
Posts: 23

Original Poster
Rep: Reputation: 15
Okay. Yeah, I'm using DHCP at the moment. So it should do that. But when I've established a connection to the router with wireless, I don't have any internet access. I might note that I also have another net interface (eth0) which isn't connected to anything, does this affect my net connection?
 
Old 12-22-2004, 01:27 PM   #4
ddu_
Member
 
Registered: Dec 2004
Distribution: Slackware
Posts: 114

Rep: Reputation: 16
Can you give us the output of ifconfig -a please?
 
Old 12-23-2004, 11:09 AM   #5
Drake88
LQ Newbie
 
Registered: Oct 2003
Location: Denmark (DK)
Distribution: Mandrake 10.1
Posts: 23

Original Poster
Rep: Reputation: 15
The output of ipconfig -a is:

eth0

Link encap:Ethernet HWaddr 00:0A:E6:30:64:B9
inet6 addr: fe80::20a:e6ff:fe30:64b9/64 Scope:Link
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:5 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:378 (378.0 b)
Interrupt:11 Base address:0x6000

lo

Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:150 errors:0 dropped:0 overruns:0 frame:0
TX packets:150 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:11088 (10.8 Kb) TX bytes:11088 (10.8 Kb)

ra0

Link encap:Ethernet HWaddr 00:0E:A6:B0:17:E3
inet addr:192.168.1.100 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::20e:a6ff:feb0:17e3/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:557 errors:0 dropped:0 overruns:0 frame:0
TX packets:39 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:43601 (42.5 Kb) TX bytes:1548 (1.5 Kb)
Interrupt:11 Base address:0xa000

sit0

Link encap:IPv6-in-IPv4
NOARP MTU:1480 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

I might note that ra0 is the wireless device and eth0 is the ethernet card which isn't wired to anything.
 
Old 12-23-2004, 09:10 PM   #6
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,275

Rep: Reputation: 370Reputation: 370Reputation: 370Reputation: 370
Did you remember to set your gateway. The following should do it:

route add default gw 192.168.1.1 dev ra0

That will ensure that your wireless device is used. If that doesn't work, post the output of the route command (with no arguments).
 
Old 12-23-2004, 10:38 PM   #7
whipermr5
Member
 
Registered: Dec 2004
Location: Singapore
Distribution: Fedora Core 5 Linux
Posts: 202

Rep: Reputation: 30
Maybe you should stop eth0 in linux.
 
Old 12-24-2004, 06:46 AM   #8
Drake88
LQ Newbie
 
Registered: Oct 2003
Location: Denmark (DK)
Distribution: Mandrake 10.1
Posts: 23

Original Poster
Rep: Reputation: 15
I'm not sure what I did... but it works now. Thanks to everyone for helping out. You're stars.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Slow Internet Connection when Connecting to Internet on Browsers lennysokol Linux - Networking 8 04-09-2011 05:29 PM
Nic card -> cable internet modem no internet connection zeshan_b Mandriva 21 09-26-2004 12:48 PM
Messed up my internet settings (NO internet connection) :( Almazick Linux - Networking 2 09-08-2004 01:05 PM
iptables. Can ping through to internet side nic but can't get to internet gonus Linux - Networking 19 07-15-2004 02:27 PM
can't connect to the internet:linux dont read my internet address droplsh Linux - General 1 02-29-2004 08:32 PM


All times are GMT -5. The time now is 12:46 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration