LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Intel WiFi link 5100 and BackTrack 4 (http://www.linuxquestions.org/questions/linux-newbie-8/intel-wifi-link-5100-and-backtrack-4-a-820698/)

goldenapplek 07-19-2010 10:30 AM

Intel WiFi link 5100 and BackTrack 4
 
I've seen similar questions posted about the myriad problems people have getting the intel wifi link 5100 to work with some OS. Here is my info:

I run BackTrack 4 on a Dell Vostro Mini 9. I installed an intel wifi link 5100 card.

Below is what i get with the various config commands, etc. So far, it looks to me like it should be working, but i can't get a signal. I'm sure everyone's been through this a million times, but please help me if you can, I'm really stumped. I've been checking forums for weeks, following different instructions with no success. I can't really be this stupid...thank you

root@bt:~# iwconfig wlan0
wlan0 IEEE 802.11abgn ESSID:""
Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
Tx-Power=15 dBm
Retry min limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

root@bt:~# dmesg | grep -iwireless
root@bt:~# dmesg|grep -i wireless
iwlagn: Intel(R) Wireless WiFi Link AGN driver for Linux, 1.3.27kd
iwlagn 0000:03:00.0: Detected Intel Wireless WiFi Link 5100AGN REV=0x54
root@bt:~# cat /proc/net/wireless
Inter-| sta-| Quality | Discarded packets | Missed | WE
face | tus | link level noise | nwid crypt frag retry misc | beacon | 22
wlan0: 0000 0 0 0 0 0 0 0 0 0
mon0: 0000 0 0 0 0 0 0 0 0 0
root@bt:~# zcat /proc/config.gz|grep IWL
CONFIG_IWLWIFI=m
CONFIG_IWLWIFI_LEDS=y
CONFIG_IWLWIFI_RFKILL=y
# CONFIG_IWLWIFI_SPECTRUM_MEASUREMENT is not set
CONFIG_IWLWIFI_DEBUG=y
CONFIG_IWLWIFI_DEBUGFS=y
CONFIG_IWLAGN=m
CONFIG_IWL4965=y
CONFIG_IWL5000=y
CONFIG_IWL3945=m
CONFIG_IWL3945_SPECTRUM_MEASUREMENT=y
root@bt:~# ls /lib/firmware/*.ucode
/lib/firmware/iwlwifi-3945-2.ucode /lib/firmware/iwlwifi-5000-2.ucode
/lib/firmware/iwlwifi-4965-2.ucode /lib/firmware/iwlwifi-5150-2.ucode
/lib/firmware/iwlwifi-5000-1.ucode

root@bt:~# ifup wlan0
Internet Systems Consortium DHCP Client V3.1.1
Copyright 2004-2008 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

mon0: unknown hardware address type 803
mon0: unknown hardware address type 803
Listening on LPF/wlan0/00:26:c6:a7:d4:f8
Sending on LPF/wlan0/00:26:c6:a7:d4:f8
Sending on Socket/fallback
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 5
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 13
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 14
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 14
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 8
No DHCPOFFERS received.
No working leases in persistent database - sleeping.
if-up.d/mountnfs[wlan0]: waiting for interface eth0 before doing NFS mounts
if-up.d/mountnfs[wlan0]: waiting for interface eth1 before doing NFS mounts
if-up.d/mountnfs[wlan0]: waiting for interface eth2 before doing NFS mounts
if-up.d/mountnfs[wlan0]: waiting for interface ath0 before doing NFS mounts
root@bt:~# lspci
00:00.0 Host bridge: Intel Corporation Mobile 945GME Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GME Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2 (rev 02)
00:1c.2 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 3 (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 02)
02:00.0 System peripheral: JMicron Technology Corp. SD/MMC Host Controller
02:00.2 SD Host controller: JMicron Technology Corp. Standard SD Host Controller
02:00.3 System peripheral: JMicron Technology Corp. MS Host Controller
03:00.0 Network controller: Intel Corporation Wireless WiFi Link 5100
04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 02)

lesorsier 07-19-2010 09:27 PM

intel 5100agn works fine with everything I tryed since now.
Back Track 4 too.
Now... what do you mean by "installed"?
It is mini pci card, it should be inside your laptop already.
If you changed the card by yourself, there is 2 antenna connector.
Both must be connected.(pig tails or internal laptop antenna)

and in BT4 just start wicd

goldenapplek 07-20-2010 09:19 AM

It was the Wicd issue. what I didn't realize was that Wicd is disabled by default in backtrack, once I started it and updated it, it seems to be working. Thank you!


All times are GMT -5. The time now is 01:18 AM.