LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 12-24-2008, 06:03 PM   #1
nik79
LQ Newbie
 
Registered: Dec 2008
Posts: 5

Rep: Reputation: 0
Post Intel Video Drivers


Hi,

I have Intel chipset laptop having Intel express 965 chipset, it is 32 bit.

I am a new bie installed Red Hat 5.0 Server on this and the "startx failed" , I am not able to see the GNOME its only in command promt, i dont know the reason but this is the error i get while starting startx.

XIO: fatal IO error 104 (Connection reset by peer) on X server ":0.0"




What could be the reason and how could i fix this??

Any help in this regard would be really appreciated.

Regards,
Nik
 
Old 12-24-2008, 08:00 PM   #2
centguy
Member
 
Registered: Feb 2008
Posts: 398
Blog Entries: 1

Rep: Reputation: 35
As far as I know, RH5 is just too old.
If you can fix it please let me know me (in other worlds, I don't believe it
can be fixed unless you compile the intel driver yourself, an exercise that is beyond most people's capability).
If you want to stick to Redhat, then try Fedora 9, or CentOS 5.2, or other non-redhat distros such as suse or ubuntu, which I am not too familiar.

A word of caution, CentOS5.1 may give trouble, see
http://www.centos.org/modules/newbb/...forumpost61781
 
Old 12-24-2008, 08:18 PM   #3
amani
Senior Member
 
Registered: Jul 2006
Location: Kolkata, India
Distribution: 64-bit GNU/Linux, Kubuntu64, Fedora QA, Slackware,
Posts: 2,758

Rep: Reputation: Disabled
In Fedora10 X is fully automatic.

You can try updating your RH system from CLI
Like so

#su
#yum upgrade
 
Old 12-24-2008, 10:14 PM   #4
nik79
LQ Newbie
 
Registered: Dec 2008
Posts: 5

Original Poster
Rep: Reputation: 0
Post

Well ...i don't think so it is old.

Please note I am talking about latest Red hat enterprise server:

http://www.redhat.com/rhel/server/

Red Hat Enterprise Linux 5 server.


Any help!
 
Old 12-25-2008, 01:45 AM   #5
nik79
LQ Newbie
 
Registered: Dec 2008
Posts: 5

Original Poster
Rep: Reputation: 0
Problem with startx

Hi,

I have Intel chipset laptop having Intel express 965 chipset, it is 32 bit.

I am a new bie installed Red Hat 5.0 Server on this and the "startx failed" , I am not able to see the GNOME its only in command promt, i dont know the reason but this is the error i get while starting startx.

XIO: fatal IO error 104 (Connection reset by peer) on X server ":0.0"




What could be the reason and how could i fix this??

Any help in this regard would be really appreciated.

Regards,
Nik
 
Old 12-25-2008, 01:48 AM   #6
divyashree
Senior Member
 
Registered: Apr 2007
Location: bbsr,orissa,India
Distribution: RHEL5 ,RHEL4,CENT OS5,FEDORA,UBUNTU
Posts: 1,356

Rep: Reputation: 135Reputation: 135
nik how much RAM u have ??
 
Old 12-25-2008, 01:52 AM   #7
nik79
LQ Newbie
 
Registered: Dec 2008
Posts: 5

Original Poster
Rep: Reputation: 0
Post

2 gb ram
 
Old 12-25-2008, 02:11 AM   #8
nik79
LQ Newbie
 
Registered: Dec 2008
Posts: 5

Original Poster
Rep: Reputation: 0
Post

Hey Guys!

I guess i have figured out the problem and troubleshooted also, it looks my vga driver was not recognized by the installer erlier...

/etc/X11 --> vim xorg.conf

Under "Device" section changed the Driver to "vesa"...earlier it was pointing to i810.
 
Old 12-25-2008, 02:52 AM   #9
centguy
Member
 
Registered: Feb 2008
Posts: 398
Blog Entries: 1

Rep: Reputation: 35
Interesting, I thought you meant the ancient RH.

RH and RHEL are two different things.

Just curious, how did you get RHEL ? You bought it ?

As far as I know, RHEL has an free equivalent version called CentOS, and if I am not wrong, RHEL-x = CentOS-x for whatever x.

Since I hit into various graphic problems even with the latest CentOS5.2, (i.e., even a simple glxgears will crash the Xorg! see
http://www.centos.org/modules/newbb/...forumpost61648 ) and Intel GM 965 chipset +graphic controller.

But since I am not a big 3D graphic user, so CentOS-5.2-GM965chipset-glxgears crash
problem is not that a big problem for me right now.

If what applies to CentOS5.2 will also apply to RHEL5.2, then I expect you might have a problem.

Finally, since CentOS 5.1 sucks (can't even get 1280x800 resolution) for Intel 965 chipset according to my experience, hence I think you only hope is RHEL5.2.

But I think I need to emphasize is that CentOS-5.2 works okay for GM965 chipset (as long as you don't stress the 3D graphics) and perfectly okay for older Intel graphic cards (I can run beryl perfect on
CentOS-5.2 with Intel Corporation 82G33/G31 Express Integrate
d Graphics Controller).

Anyone else has other comments about CentOS intel GM965 chipset experience ?

I am hoping that CentOS or RHEL can spend a little of their time to handle the GM965 chipset in the newer version! (noted added: may be "yum update" on CentOS5.2 will fix GM965 graphic problem but I don't intend to do it right now).

Last edited by centguy; 12-25-2008 at 02:55 AM.
 
Old 12-25-2008, 04:58 AM   #10
Hitboxx
Senior Member
 
Registered: Mar 2006
Location: India
Distribution: Fedora
Posts: 1,562
Blog Entries: 3

Rep: Reputation: 51
@nik79, please post the contents of your /etc/X11/xorg.conf
 
Old 12-25-2008, 06:36 AM   #11
hasanatizaz
Member
 
Registered: Nov 2007
Location: Pakistan
Distribution: Redhat and Debian
Posts: 302
Blog Entries: 1

Rep: Reputation: 34
another way of doing is you can delete xorg.conf
and use
"system-config-dispaly" in runlevel 3
 
Old 12-25-2008, 08:53 AM   #12
danish5041
LQ Newbie
 
Registered: May 2004
Location: Pakistan
Distribution: RHEL 4.0
Posts: 7

Rep: Reputation: 0
You can also try this to fix it.

system -config-display –reconfig --set-resolution=1024x768

This will reconfigure your X Windows

REgards,
Danish Usman
 
Old 12-25-2008, 09:07 AM   #13
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 729Reputation: 729Reputation: 729Reputation: 729Reputation: 729Reputation: 729Reputation: 729
Please do not start new threads when you already have one on the same topic.

I'm merging this with your original thread.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help finding and installing Intel video drivers le Stone Linux - Newbie 7 09-06-2008 10:03 AM
Intel video drivers on slackware 12 enine Slackware 5 05-06-2008 07:50 AM
Where to find Intel i810 video drivers enine Slackware 4 02-27-2008 02:43 PM
Where can I find video drivers for Intel Integrated? dustin_wielenga Linux - Laptop and Netbook 5 11-29-2006 03:26 PM
video drivers and Intel 945g chipset? gottin Linux - Hardware 10 10-15-2005 06:04 PM


All times are GMT -5. The time now is 05:06 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration