LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 03-17-2005, 01:43 AM   #1
Emmanuel_uk
Senior Member
 
Registered: Nov 2004
Distribution: Mandriva mostly, vector 5.1, tried many.Suse gone from HD because bad Novell/Zinblows agreement
Posts: 1,604

Rep: Reputation: 47
Question intel 536EP random connection speed to ISP (<10% 45333 bps, mostly often slow 33000)


Hi

My dialup connection is seldom at 45 kbps, that is the modem connects 95% of the time in V34.
On some rare occasions it connected at 45333 in V90 or V92 mode.

Any suggestion of what to do? Where to look?
Can/Do ISP descriminate against linux user?
(I just have this daft wonder now that I cannot get a 45 k dialup all the time)...

I use mandrake 10.1 CE, kernel 2.6.8.1
The i 536EP driver is from the intel website
I connect using kppp.
The modem (intel 536EP based) is on a PCI card.
I have ipv6 installed.

- the local telephone loop is ok because our other computer, a zindoze, always connect at 45 k
- I cannot test the modem in zindoze unless I move the PCI modem card into the other computer
(the modem is nearly new so I do not see why it would be faulty)
- I think I tried to swap the modem cable from the 2 computers, no changes. They are the same length
- I have played more than enough with the AT commands to try to force a V90/V92 mode (for 2 weeks)
(I tried series of about 30 dial up / hang up, and after connecting once at 45 k, I did not the next time...) I have even read the full i536ep AT command list
- I have played with the connection port speed (the kppp drop down menu, and always used one of the 2 fastest speed)
- I have tried wvdial instead of kppp. Same problem low speed, but easier to use as CLI
to read the messages

I have tried to put that damn "deflate" option in ppp configuration file, as I thought it would help.
I does not, I cannot connect if I try tweecking the file.

BTW I am still a newbee, so any suggestion will be appreciated.
I am very puzzled that I so seldom get a fast connection...

Thanks
regards

Last edited by Emmanuel_uk; 03-17-2005 at 01:45 AM.
 
Old 03-18-2005, 10:13 AM   #2
deepsix
Member
 
Registered: Apr 2003
Distribution: ANY
Posts: 337

Rep: Reputation: 31
this is most likely due to incorrect or unneeded modem initialization strings........I recommend googling for information on it........also check this page out http://www.jenera.com/modems/
 
Old 03-31-2005, 11:52 PM   #3
Emmanuel_uk
Senior Member
 
Registered: Nov 2004
Distribution: Mandriva mostly, vector 5.1, tried many.Suse gone from HD because bad Novell/Zinblows agreement
Posts: 1,604

Original Poster
Rep: Reputation: 47
Thanks for the link.
I will try some different strings and post the results
 
Old 04-25-2005, 01:29 AM   #4
Emmanuel_uk
Senior Member
 
Registered: Nov 2004
Distribution: Mandriva mostly, vector 5.1, tried many.Suse gone from HD because bad Novell/Zinblows agreement
Posts: 1,604

Original Poster
Rep: Reputation: 47
I have found out one answer to my question:

There are some ISPs which are linux hostile and I quote from
the scanmodem comments in one of the outputs
http://linmodems.technion.ac.il

However, after testing another old PC at home with a different modem,
I know now that my ISP is linux compatible.

Regards

Last edited by Emmanuel_uk; 04-26-2005 at 01:27 AM.
 
Old 04-26-2005, 01:10 AM   #5
Emmanuel_uk
Senior Member
 
Registered: Nov 2004
Distribution: Mandriva mostly, vector 5.1, tried many.Suse gone from HD because bad Novell/Zinblows agreement
Posts: 1,604

Original Poster
Rep: Reputation: 47
Unhappy

speedcom + modem not in Jenera.
So I used no special string with kppp, as root.
Connected the first time round at 45300 bps. Youhhaa
Disconnect, then tried as user 33200 :-(
Disconnect again try as root 33200 :-( again
tried about 10 times, no luck, changed parameters in Kppp: no luck
Tried string +MS=V90,1,0,0 (accepted by modem)
Disconnect again try as root 33200 :-( again

Tried kppp and wvdial, compared kppp input of user and root.
looked at /etc/kppprc and /etc/kde/kpprc
and also /.kde/share/config/kpprc
No luck

Will post tail -f /var/log/syslog if this can help
and /etc/kppprc

Last edited by Emmanuel_uk; 04-26-2005 at 01:26 AM.
 
Old 04-27-2005, 01:30 AM   #6
Emmanuel_uk
Senior Member
 
Registered: Nov 2004
Distribution: Mandriva mostly, vector 5.1, tried many.Suse gone from HD because bad Novell/Zinblows agreement
Posts: 1,604

Original Poster
Rep: Reputation: 47
Unhappy verbose pppd output

The last time I connected at 45333 bps the only init string was ATZ.
I also tried +MS=V90,,,,,45333 and many other strings
accepted OK but still giving 33200 bps

Now, I found /etc/sysconfig/network-scripts/ifcfg-ppp0
Does this file above take over /etc/ppp/options?

Enclosed a very verbose output of the connection

Cat /etc/ppp/options
#lock
noauth
noipdefault
usepeerdns
crtscts
dump
#dryrun
115200
deflate 10,10
connect-delay 1000

# cat /etc/sysconfig/network-scripts/ifcfg-ppp0
DEVICE="ppp0"
USERCTL="no"
MODEMPORT="/dev/modem"
LINESPEED="115200"
PERSIST="yes"
DEFABORT="yes"
DEBUG="yes"
INITSTRING="ATZ"
DEFROUTE="yes"
HARDFLOWCTL="yes"
ESCAPECHARS="no"
PPPOPTIONS=""
PAPNAME="myusername"
REMIP=""
NETMASK=""
IPADDR=""
MRU=""
MTU=""
DISCONNECTTIMEOUT="5"
RETRYTIMEOUT="60"
BOOTPROTO="none"
PEERDNS="yes"
METRIC=40
ONBOOT=no

# wvdial myconf.conf
--> WvDial: Internet dialer version 1.54.0
--> Initializing modem.
--> Sending: AT+MS=V90
AT+MS=V90
OK
--> Sending: AT+GCI=B4
AT+GCI=B4
OK
--> Modem initialized.
--> Sending: ATDT08450796699
--> Waiting for carrier.
ATDTsomeNo
CONNECT 31200
--> Carrier detected. Waiting for prompt.
~[7f]}#@!}!}!} }!}$}%\}"}&} }*} } }#}$@#}%}&_/t[05]}'}"}(}"}1}$}%b*}<~
--> PPP negotiation detected.
--> Starting pppd at Tue Apr 26 23:24:26 2005
--> pid of pppd: 7332
Apr 26 23:22:48 localhost smartd[4830]: Device: /dev/hda, SMART Usage Attribute: 194 Temperature_Celsius changed from 189 to 183
Apr 26 23:24:26 localhost pppd[7332]: pppd options in effect:
Apr 26 23:24:26 localhost pppd[7332]: -detach^I^I# (from command line)
Apr 26 23:24:26 localhost pppd[7332]: idle 0^I^I# (from command line)
Apr 26 23:24:26 localhost pppd[7332]: logfd 6^I^I# (from command line)
Apr 26 23:24:26 localhost pppd[7332]: connect-delay 1000^I^I# (from /etc/ppp/options)
Apr 26 23:24:26 localhost pppd[7332]: dump^I^I# (from /etc/ppp/options)
Apr 26 23:24:26 localhost pppd[7332]: noauth^I^I# (from /etc/ppp/peers/wvdial)
Apr 26 23:24:26 localhost pppd[7332]: name localhost^I^I# (from /etc/ppp/peers/wvdial)
Apr 26 23:24:26 localhost pppd[7332]: user myusername^I^I# (from command line)
Apr 26 23:24:26 localhost pppd[7332]: usehostname^I^I# (from command line)
Apr 26 23:24:26 localhost pppd[7332]: remotename myusername^I^I# (from command line)
Apr 26 23:24:26 localhost pppd[7332]: 460800^I^I# (from command line)
Apr 26 23:24:26 localhost pppd[7332]: crtscts^I^I# (from command line)
Apr 26 23:24:26 localhost pppd[7332]: modem^I^I# (from command line)
Apr 26 23:24:26 localhost pppd[7332]: noipdefault^I^I# (from command line)
Apr 26 23:24:26 localhost pppd[7332]: defaultroute^I^I# (from command line)
Apr 26 23:24:26 localhost pppd[7332]: usepeerdns^I^I# (from command line)
Apr 26 23:24:26 localhost pppd[7332]: deflate 10^I^I# (from /etc/ppp/options)
Apr 26 23:24:26 localhost pppd[7332]: pppd 2.4.2 started by root, uid 0
Apr 26 23:24:26 localhost netplugd[4401]: ppp0: ignoring event
Apr 26 23:24:26 localhost pppd[7332]: Using interface ppp0
Apr 26 23:24:26 localhost pppd[7332]: Connect: ppp0 <--> /dev/536ep
--> pppd: pppd options in effect:
--> pppd: -detach # (from command line)
--> pppd: idle 0 # (from command line)
--> pppd: logfd 6 # (from command line)
--> pppd: connect-delay 1000 # (from /etc/ppp/options)
--> pppd: dump # (from /etc/ppp/options)
--> pppd: noauth # (from /etc/ppp/peers/wvdial)
--> pppd: name localhost # (from /etc/ppp/peers/wvdial)
--> pppd: user myusername # (from command line)
--> pppd: usehostname # (from command line)
--> pppd: remotename myusername # (from command line)
--> pppd: 460800 # (from command line)
--> pppd: crtscts # (from command line)
--> pppd: modem # (from command line)
--> pppd: noipdefault # (from command line)
--> pppd: defaultroute # (from command line)
--> pppd: usepeerdns # (from command line)
--> pppd: deflate 10 # (from /etc/ppp/options)
--> Using interface ppp0
--> pppd: Connect: ppp0 <--> /dev/536ep
--> pppd: PAP authentication succeeded
--> local IP address 81.............
--> remote IP address 195.............
--> primary DNS address 195.92.195.95
--> secondary DNS address 195.92.195.94
Apr 26 23:24:29 localhost pppd[7332]: PAP authentication succeeded
Apr 26 23:24:29 localhost pppd[7332]: local IP address 81.............
Apr 26 23:24:29 localhost pppd[7332]: remote IP address 195.............
Apr 26 23:24:29 localhost pppd[7332]: primary DNS address 195.92.195.95
Apr 26 23:24:29 localhost pppd[7332]: secondary DNS address 195.92.195.94
Apr 26 23:24:29 localhost netplugd[4401]: ppp0: ignoring event
Apr 26 23:24:29 localhost netplugd[4401]: ppp0: ignoring event
Apr 26 23:24:30 localhost postfix[7376]: warning: My hostname localhost is not a fully qualified name - set myhostname or mydomain in /etc/postfix/main.cf



Apr 25 21:14:14 localhost pppd[6547]: pppd 2.4.2 started by root, uid 0
Apr 25 21:14:14 localhost netplugd[4412]: ppp0: ignoring event
Apr 25 21:14:14 localhost pppd[6547]: Using interface ppp0
Apr 25 21:14:14 localhost pppd[6547]: Connect: ppp0 <--> /dev/536ep
Apr 25 21:14:15 localhost pppd[6547]: PAP authentication succeeded
Apr 25 21:14:15 localhost kernel: PPP BSD Compression module registered
Apr 25 21:14:15 localhost kernel: PPP Deflate Compression module registered
Apr 25 21:14:16 localhost pppd[6547]: local IP address 81.76.199.113
Apr 25 21:14:16 localhost pppd[6547]: remote IP address 195.92.168.41
Apr 25 21:14:16 localhost pppd[6547]: primary DNS address 195.92.195.95
Apr 25 21:14:16 localhost pppd[6547]: secondary DNS address 195.92.195.94
Apr 25 21:14:16 localhost netplugd[4412]: ppp0: ignoring event
Apr 25 21:14:16 localhost netplugd[4412]: ppp0: ignoring event
Apr 25 21:14:16 localhost postfix[6599]: warning: My hostname localhost is not a fully qualified name - set myhostname or mydomain in /etc/postfix/main.cf

Apr 25 21:19:23 localhost pppd[6715]: pppd 2.4.2 started by wnet, uid 502
Apr 25 21:19:23 localhost netplugd[4412]: ppp0: ignoring event
Apr 25 21:19:23 localhost pppd[6715]: Using interface ppp0
Apr 25 21:19:23 localhost pppd[6715]: Connect: ppp0 <--> /dev/536ep
Apr 25 21:19:24 localhost pppd[6715]: PAP authentication succeeded
Apr 25 21:19:24 localhost pppd[6715]: local IP address 81.76.240.106
Apr 25 21:19:24 localhost pppd[6715]: remote IP address 195.92.168.44
Apr 25 21:19:24 localhost pppd[6715]: primary DNS address 195.92.195.95
Apr 25 21:19:24 localhost pppd[6715]: secondary DNS address 195.92.195.94
Apr 25 21:19:24 localhost netplugd[4412]: ppp0: ignoring event
Apr 25 21:19:24 localhost netplugd[4412]: ppp0: ignoring event
Apr 25 21:19:24 localhost postfix[6761]: warning: My hostname localhost is not a fully qualified name - set myhostname or mydomain in /etc/postfix/main.cf

Apr 25 21:52:53 localhost pppd[7331]: pppd 2.4.2 started by root, uid 0
Apr 25 21:52:53 localhost netplugd[4412]: ppp0: ignoring event
Apr 25 21:52:53 localhost pppd[7331]: Using interface ppp0
Apr 25 21:52:53 localhost pppd[7331]: Connect: ppp0 <--> /dev/536ep
Apr 25 21:52:54 localhost pppd[7331]: PAP authentication succeeded
Apr 25 21:52:55 localhost pppd[7331]: local IP address 81.76.227.75
Apr 25 21:52:55 localhost pppd[7331]: remote IP address 195.92.168.43
Apr 25 21:52:55 localhost pppd[7331]: primary DNS address 195.92.195.95
Apr 25 21:52:55 localhost pppd[7331]: secondary DNS address 195.92.195.94
Apr 25 21:52:55 localhost netplugd[4412]: ppp0: ignoring event
Apr 25 21:52:55 localhost netplugd[4412]: ppp0: ignoring event
Apr 25 21:52:55 localhost postfix[7379]: warning: My hostname localhost is not a fully qualified name - set myhostname or mydomain in /etc/postfix/main.cf
 
Old 05-03-2005, 01:27 AM   #7
Emmanuel_uk
Senior Member
 
Registered: Nov 2004
Distribution: Mandriva mostly, vector 5.1, tried many.Suse gone from HD because bad Novell/Zinblows agreement
Posts: 1,604

Original Poster
Rep: Reputation: 47
Unhappy

In desperation, I installed zinblows to get the init string from the
modem log.
I also tried the modem within zinblows and got 44000 bps out of it, first time round.

I copied the 5 init strings from zinblows into wvdial,
still got 33200 or 28000 bps.

I checked the version of the intel driver does support V9x as per readme.txt.

I start wondering if this is a kernel compatibility issue or something else

 
Old 05-04-2005, 02:17 AM   #8
Emmanuel_uk
Senior Member
 
Registered: Nov 2004
Distribution: Mandriva mostly, vector 5.1, tried many.Suse gone from HD because bad Novell/Zinblows agreement
Posts: 1,604

Original Poster
Rep: Reputation: 47
a similar thread

http://www.linuxquestions.org/questi...02#post1624702
 
Old 05-10-2005, 06:04 AM   #9
Emmanuel_uk
Senior Member
 
Registered: Nov 2004
Distribution: Mandriva mostly, vector 5.1, tried many.Suse gone from HD because bad Novell/Zinblows agreement
Posts: 1,604

Original Poster
Rep: Reputation: 47
Installed suze 9.2 pro with the intel driver shipped in.
Modem works but only at 32000 again
Kernel was 2.6.8.24
 
Old 05-11-2005, 01:23 AM   #10
Emmanuel_uk
Senior Member
 
Registered: Nov 2004
Distribution: Mandriva mostly, vector 5.1, tried many.Suse gone from HD because bad Novell/Zinblows agreement
Posts: 1,604

Original Poster
Rep: Reputation: 47
Installed mandrake 10.2 kernel 2.6.11-6mdk

Still 32000 bps, will try some other init strings again

May as well try with kernel 2.4 series if I figure out how to install it
on the spare 10.1 partition
 
Old 05-16-2005, 01:14 AM   #11
Emmanuel_uk
Senior Member
 
Registered: Nov 2004
Distribution: Mandriva mostly, vector 5.1, tried many.Suse gone from HD because bad Novell/Zinblows agreement
Posts: 1,604

Original Poster
Rep: Reputation: 47
modem handshake protocol broken / not working

Gave up.

Put the modem in another PC (known ISP, cable and connection always >= 44000 bps)
, in zinblows), same problem as linux now, connected only once at 44600,
rest of the time at 32000

Modem new a few weeks ago never worked well then.

Must conclude the handshake protocol is faulty.

Will ditch it and get a hardware modem.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
slow internet connection speed 666 Mandriva 12 09-24-2005 09:54 AM
intel 536ep jupiter3437 Linux - Software 1 09-21-2005 02:37 PM
Intel 536ep jupiter3437 Linux - Software 3 09-09-2005 02:51 PM
Intel 536EP anjum Linux - Software 1 08-04-2005 11:56 AM
intel 536ep Nenoslayedme Linux - Hardware 4 08-13-2004 11:58 AM


All times are GMT -5. The time now is 06:37 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration