LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 02-18-2005, 06:47 PM   #1
browneyes
LQ Newbie
 
Registered: Sep 2004
Distribution: Suse 9.2
Posts: 21

Rep: Reputation: 15
intel 2200bg on suse 9.2 Pro


Hi,

linux newbie here.

Installed suse 9.2 pro couple days ago on my vaio s150, but my wireless

still not working.

I heard it should work right out of the box. I could access my router AP, but

Could not connect to internet. Wired works but wireless not working. Any

help would be appreciated.
 
Old 02-18-2005, 10:02 PM   #2
browneyes
LQ Newbie
 
Registered: Sep 2004
Distribution: Suse 9.2
Posts: 21

Original Poster
Rep: Reputation: 15
anyone???
 
Old 02-18-2005, 10:13 PM   #3
mdj
LQ Newbie
 
Registered: Jan 2005
Location: Halfmoon, NY
Posts: 26

Rep: Reputation: 15
I think this probably needs to be an FAQ. This sounds like the same problem I had initially, which was that I was getting connected to the AP and getting an address via DHCP, but not getting a default route for the wireless interface (eth1). Here's the catch: when dhcpcd starts up for multiple interfaces, it only accepts a default route on the <b>first</b> interface. Once I changed the wired (eth0) interface to come up manually instead of "onboot", the wireless worked fine.
 
Old 02-18-2005, 10:46 PM   #4
browneyes
LQ Newbie
 
Registered: Sep 2004
Distribution: Suse 9.2
Posts: 21

Original Poster
Rep: Reputation: 15
Quote:
Once I changed the wired (eth0) interface to come up manually instead of "onboot", the wireless worked fine.
How do I change that? I really newbie at linux
 
Old 02-18-2005, 10:55 PM   #5
mdj
LQ Newbie
 
Registered: Jan 2005
Location: Halfmoon, NY
Posts: 26

Rep: Reputation: 15
Bring up YaST, go to "Network Devices", "Network Card". Select your wired card. Under the "advanced" settings, there's a dropdown menu for "Device Activation". It's probably set to "At Boot Time". Change it to "manually".
 
Old 02-18-2005, 11:40 PM   #6
browneyes
LQ Newbie
 
Registered: Sep 2004
Distribution: Suse 9.2
Posts: 21

Original Poster
Rep: Reputation: 15
I tried that but no luck.

when starting, there was an error saying...

ERROR: command 'iwconfig' eth1 mode 'manged' returned
error for wireless request "set mode" (8B06):
set failed on device eth1; operation not supported.

eth1 (DHCP) ..... ip net mask: 192.168.103 / 255.255.255.0

I got this message with all 3 modes...what's wrong with this?
 
Old 02-18-2005, 11:45 PM   #7
mdj
LQ Newbie
 
Registered: Jan 2005
Location: Halfmoon, NY
Posts: 26

Rep: Reputation: 15
That's odd. But it looks like you're getting an address from DHCP, even with the error. Can you paste in the output from "ifconfig eth1", "iwconfig eth1", and "netstat -nr"?
 
Old 02-18-2005, 11:58 PM   #8
browneyes
LQ Newbie
 
Registered: Sep 2004
Distribution: Suse 9.2
Posts: 21

Original Poster
Rep: Reputation: 15
when i typed first 2 on x-terminal...it says bash: ifconfig: command not found, and iwconfig: command not found. maybe I didn't installed some packages??

but netstat -nr

kernel ip routhing table

destination gateway genmask flags msswindow irtt iface
192.168.1.0 0.0.0.0 255.255.255.0 u 0 0 0 eth1
169.254.0.0 0.0.0.0 255.255.0.0 u 0 0 0 eth1
127.0.0.0 0.0.0.0 255.0.0.0 u 0 0 0 lo
0.0.0.0 192.168.1.1 0.0.0.0 ug 0 0 0 eth1

Last edited by browneyes; 02-19-2005 at 12:01 AM.
 
Old 02-19-2005, 12:05 AM   #9
mdj
LQ Newbie
 
Registered: Jan 2005
Location: Halfmoon, NY
Posts: 26

Rep: Reputation: 15
They're in /sbin and /usr/sbin, you probably don't have those in your path. That looks like a good routing table, though. What happens when you try to ping something like, say, www.novell.com?
 
Old 02-19-2005, 12:09 AM   #10
browneyes
LQ Newbie
 
Registered: Sep 2004
Distribution: Suse 9.2
Posts: 21

Original Poster
Rep: Reputation: 15
i get unknown host www.novell.com
 
Old 02-19-2005, 12:24 AM   #11
mdj
LQ Newbie
 
Registered: Jan 2005
Location: Halfmoon, NY
Posts: 26

Rep: Reputation: 15
OK, how about if you try to ping them by IP (130.57.4.27)? Sounds like you may not be gettng a name server, which could be a configuration issue with your AP.
 
Old 02-19-2005, 12:32 AM   #12
browneyes
LQ Newbie
 
Registered: Sep 2004
Distribution: Suse 9.2
Posts: 21

Original Poster
Rep: Reputation: 15
it works...

ping 130.57.4.27 (130.57.4.27) 56(84) byes of data.

64bytes from 130.57.4.27: icmp_sq1 ttl =52 time70.3 ms
64bytes from 130.57.4.27: icmp_sq2 ttl =52 time69.0 ms
64bytes from 130.57.4.27: icmp_sq3 ttl =52 time73.6 ms

--- 130.57.4.27 ping statistics ---

3 packets transmitted, 3 received, 0% packet loss, time 2001ms
rtt min/avg/max/mdev = 69.097/71.034/73.646/1.929 ms

if this works then...what's that mean?
 
Old 02-19-2005, 12:36 AM   #13
mdj
LQ Newbie
 
Registered: Jan 2005
Location: Halfmoon, NY
Posts: 26

Rep: Reputation: 15
It means that you'r e not getting a DNS server address from your DHCP host. I don't know how your network is set up, but typically either
a) you have an all-in-one router/AP/firewall dingus, or
b) you have a router/firewall box and a separate WAP.

In either case, you typically have to tell whichever box is providing DNS for you to hand out a DNS server address. Usually the address is the router or WAP itself, and it just proxies DNS queries out to another system. But your Linux system seems to be doing everything it should be.
 
Old 02-19-2005, 12:42 AM   #14
browneyes
LQ Newbie
 
Registered: Sep 2004
Distribution: Suse 9.2
Posts: 21

Original Poster
Rep: Reputation: 15
im lost....

how do get the dns server address from my dhcp host?

I really do not get this.....on xp i have no trouble surfing wireless...
 
Old 02-19-2005, 12:46 AM   #15
mdj
LQ Newbie
 
Registered: Jan 2005
Location: Halfmoon, NY
Posts: 26

Rep: Reputation: 15
Sorry, I'm pretty much out of suggestions at hit point. Without knowing what your DHCP host is, I couldn't even venture a guess. The only useful suggestion I could give you at this point is to look at the documentation for your DHCP device and see if it says anything useful. Oh, one other thing you could do as a workaround for the moment: put the address of your DHCP device (which is almost certainly proxying DNS) directly into /etc/resolv.conf (man resolv.conf will tell you the format of the file). Good luck!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Intel PRO/Wireless 2200BG henriette Linux - Laptop and Netbook 5 05-20-2007 02:50 PM
Intel PRO/Wireless 2200BG wfischer Linux - Wireless Networking 3 10-25-2006 09:20 AM
suse 9.3 intel pro/wlan 2200bg lonley soul Linux - Laptop and Netbook 3 06-07-2006 03:07 AM
Intel pro/wireless 2200BG lobwolf Linux - Wireless Networking 27 11-01-2005 10:20 AM
Intel PRO 2200BG doesn't turn on motovoi Linux - Wireless Networking 0 10-10-2004 10:42 AM


All times are GMT -5. The time now is 01:35 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration