LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-21-2010, 08:43 AM   #1
_linux_newbie_
LQ Newbie
 
Registered: Nov 2010
Posts: 9

Rep: Reputation: 0
Installing windows driver on kubuntu


Hello,

I have the driver cd of a frontech pen tablet which is for windows (there are also driver files for mac os in the cd). On Kubuntu, I am trying to use the ndiswrapper -i driver_file.inf command but there are many .inf files on the cd. I am having trouble recognizing which file is the driver file for the pen tablet.

Please help.
 
Old 11-21-2010, 08:46 AM   #2
stress_junkie
Senior Member
 
Registered: Dec 2005
Location: Massachusetts, USA
Distribution: Ubuntu 10.04 and CentOS 5.5
Posts: 3,873

Rep: Reputation: 332Reputation: 332Reputation: 332Reputation: 332
Check the following web page.

http://wiki.linuxquestions.org/wiki/NDIS_Wrapper

Ndiswrapper is for network cards and is typically used to get wireless network cards to work on Linux.

Did you try plugging the tablet into the machine with Linux running to see what would happen? It is possible that Linux has a driver that it will automatically use.

Last edited by stress_junkie; 11-21-2010 at 08:48 AM.
 
Old 11-21-2010, 02:43 PM   #3
_linux_newbie_
LQ Newbie
 
Registered: Nov 2010
Posts: 9

Original Poster
Rep: Reputation: 0
Yes I tried to plug in the pen tablet while Kubuntu was running, but the following things happen then:

1. The light on the tablet gets blinked once (as it should).
2. No notificaiton is there that a new device has been connected.
3. When I try to move the cursor with the pen on the tablet, it jumps up to the top left and starts clicking there. Nothing else happens.

Does this mean that the driver is already on Kubuntu? If ndiswrapper doesn't install tablet drivers, what will?

Thank you.
 
Old 11-21-2010, 03:54 PM   #4
stress_junkie
Senior Member
 
Registered: Dec 2005
Location: Massachusetts, USA
Distribution: Ubuntu 10.04 and CentOS 5.5
Posts: 3,873

Rep: Reputation: 332Reputation: 332Reputation: 332Reputation: 332
This is what I just did. I went to the Google web site and searched for "linux driver for frontech pen tablet" and found several web sites with instructions. Here is one.

http://www.electronic-gadget.info/ar...+on+linux.html

Unfortunately most of the Google listings pertain to Wacom or Aiptek. They may or may not help with your Front Tech pad. Hopefully the page that I listed above will be helpful enough to get the job done.

Last edited by stress_junkie; 11-21-2010 at 03:57 PM.
 
Old 11-22-2010, 06:28 AM   #5
_linux_newbie_
LQ Newbie
 
Registered: Nov 2010
Posts: 9

Original Poster
Rep: Reputation: 0
This is deleted by me.

Last edited by _linux_newbie_; 11-23-2010 at 02:05 AM. Reason: New reply posted below
 
Old 11-23-2010, 01:51 AM   #6
_linux_newbie_
LQ Newbie
 
Registered: Nov 2010
Posts: 9

Original Poster
Rep: Reputation: 0
Okay by searching a lot on Google I finally came up with the solution BUT the having problems in some bash commands -- Please help

Details:
1. From lsusb, I found out that my pen is called Wizardpen
2. From google, reached this page where there are instructions on how to install drivers for wizardpen tablet.
3. The ./configure --with..... command does not work for me. I downloaded the tar.gz package of the driver for linux and extracted in directory then cd into that directory and then did the ./configure command. But that returns the error:

++++++++++++++++++++++++++++++++++++++++++++++++++++++
checking for XORG... configure: error: Package requirements (xorg-server >= 1.0.99.901 xproto ) were not met:

Package xorg-server was not found in the pkg-config search path.
Perhaps you should add the directory containing `xorg-server.pc'
to the PKG_CONFIG_PATH environment variable
No package 'xorg-server' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables XORG_CFLAGS
and XORG_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
+++++++++++++++++++++++++++++++++++++++++++++++++++++

What should I do now? Please help

Last edited by _linux_newbie_; 11-23-2010 at 02:06 AM. Reason: Changing the error reported.
 
Old 11-23-2010, 02:11 AM   #7
rylan76
Senior Member
 
Registered: Apr 2004
Location: Potchefstroom, South Africa
Distribution: Fedora 17 - 3.3.4-5.fc17.x86_64
Posts: 1,487

Rep: Reputation: 88
Hmm this most likely means you do not have the Xorg development packages installed, or if it IS installed, it cannot be found.

This might be done on some distros (Xwindows, but no dev packages), e.g. you DO have XWindows itself installed, but you do not have the development packages FOR Xwindows installed.

Can you confirm whether you DO have the Xorg development packages installed in fact, or not?

Different steps might be taken depending - if you DO have xorg dev packages installed, you can probably do some things, if you do not have them installed, a first step would be to install the ones that match the version of Xorg you've got running...
 
Old 11-23-2010, 02:13 AM   #8
rylan76
Senior Member
 
Registered: Apr 2004
Location: Potchefstroom, South Africa
Distribution: Fedora 17 - 3.3.4-5.fc17.x86_64
Posts: 1,487

Rep: Reputation: 88
Quote:
Originally Posted by _linux_newbie_ View Post
Okay by searching a lot on Google I finally came up with the solution BUT the having problems in some bash commands -- Please help

++++++++++++++++++++++++++++++++++++++++++++++++++++++
checking for XORG... configure: error: Package requirements (xorg-server >= 1.0.99.901 xproto ) were not met:

Package xorg-server was not found in the pkg-config search path.
Perhaps you should add the directory containing `xorg-server.pc'
to the PKG_CONFIG_PATH environment variable
No package 'xorg-server' found
Try doing this, in a terminal, as root:

Code:
find / -name xorg-server.pc
if you find such a file, it means that you probably DO have the xorg dev packages installed, only, the configure script can't find the file. If you do NOT find such a file, it probably means you do not have the xorg dev packages installed, and you'll probably need to install them first before attempting to compile the driver again.
 
Old 11-23-2010, 02:21 AM   #9
_linux_newbie_
LQ Newbie
 
Registered: Nov 2010
Posts: 9

Original Poster
Rep: Reputation: 0
I did the command:

find / -name xorg-server.pc

and the output was:

/usr/lib/pkgconfig/xorg-server.pc

So that probably means I have the package on this system?

Thank you
 
Old 11-23-2010, 02:54 AM   #10
_linux_newbie_
LQ Newbie
 
Registered: Nov 2010
Posts: 9

Original Poster
Rep: Reputation: 0
Smile

Please help.

Last edited by _linux_newbie_; 11-23-2010 at 02:55 AM.
 
Old 11-23-2010, 03:53 AM   #11
rylan76
Senior Member
 
Registered: Apr 2004
Location: Potchefstroom, South Africa
Distribution: Fedora 17 - 3.3.4-5.fc17.x86_64
Posts: 1,487

Rep: Reputation: 88
Quote:
Originally Posted by _linux_newbie_ View Post
I did the command:

find / -name xorg-server.pc

and the output was:

/usr/lib/pkgconfig/xorg-server.pc

So that probably means I have the package on this system?

Thank you
Yes, I think that does mean it is installed.

Ok, try this. Open your .bashrc and add a line that reads

Code:
PKG_CONFIG_PATH=$PKG_CONFIG_PATH:/usr/lib/pkgconfig
which, as far as I know IS this:

Quote:
Package xorg-server was not found in the pkg-config search path.
Perhaps you should add the directory containing `xorg-server.pc'
to the PKG_CONFIG_PATH environment variable
then save the .bashrc and re-open your terminal so the new .bashrc gets parsed.

Now try and ./configure again.

If it still doesn't work, you can try and find the location of the xorg libraries by opening the xorg-server.pc and looking for a Cflags and Libs line.

Take whatever you find in these Cflags and Libs lines, and try and copy that content into a XORG_CFLAGS and XORG_LIBS line in your .bashrc.

Note thought that the .pc file may use symbols. E. g. on my system "xtrans.pc" looks like this:

Code:
prefix=/usr
exec_prefix=/usr
libdir=/usr/share
includedir=/usr/include

Name: XTrans
Description: Abstract network code for X
Version: 1.2.2
Cflags: -I${includedir} -D_BSD_SOURCE -DHAS_FCHOWN -DHAS_STICKY_DIR_BIT
Libs:
Requires:
which means my "correct" cflags are in fact

Code:
-I/usr/include -D_BSD_SOURCE -DHAS_FCHOWN -DHAS_STICKY_DIR_BIT
since includedir is defined as "/usr/include" - so look out for something similar in your .pc file.

Do the same with the "libs" line for your xorg-server.pc file - watch out for symbols.

Then put what you find in those lines into lines in your .bashrc:

Code:
XORG_LIBS="whatever you find in the libs line in your xorg-server.pc file"
export XORG_LIBS
XORG_CFLAGS ="whatever you find in the cflags line in your xorg-server.pc file"
export XORG_CFLAGS
which IS:

Quote:
Alternatively, you may set the environment variables XORG_CFLAGS
and XORG_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
then close your terminal and re-open it to make it parse the new .bashrc file.

Try configuring again to see if it works.

If it still does not, you can also try to make a symlink to the xorg-server.pc file from /usr/share/pkgconfig - I checked, and on my FC11 system, most of my .pc Package Config files are in /usr/share/pkconfig - so maybe the configure script you are trying to run to get the driver compiled is simply looking in the wrong location.

So in a terminal, as root, do

Code:
# cd /usr/share/pkgconfig
# ln -s /usr/lib/pkgconfig/xorg-server.pc xorg-server.pc
this will "point" /usr/share/pkgconfig/xorg-server.pc "to" /usr/lib/pkgconfig/xorg-server.pc

which means that IF the configure script does look in "/usr/share/pkgconfig" ONLY for xorg-server.pc, it will now "find" it - while it actually finds only a "symlink" to /usr/lib/pkgconfig/xorg-server.pc

Hopefully some of this helps...!

Note though that the most of the above is Fedora centric, so it might not work on your system, or might not work at all, period. Your mileage may vary.

Last edited by rylan76; 11-23-2010 at 03:55 AM.
 
Old 11-23-2010, 04:21 AM   #12
_linux_newbie_
LQ Newbie
 
Registered: Nov 2010
Posts: 9

Original Poster
Rep: Reputation: 0
First option

I opened .bashrc by typing :
Code:
kate .bashrc
and pasted this at the end of the file:
Code:
PKG_CONFIG_PATH=$PKG_CONFIG_PATH:/usr/lib/pkgconfig
then saved and closed the file, and then re-opened the terminal and again tried the ./configure command, but the same error persisted. Did I do something wrong?

Now trying the second option:

Last edited by _linux_newbie_; 11-23-2010 at 04:24 AM. Reason: .
 
Old 11-23-2010, 04:23 AM   #13
_linux_newbie_
LQ Newbie
 
Registered: Nov 2010
Posts: 9

Original Poster
Rep: Reputation: 0
Unhappy Second option

The Cflags and Libs on my kubuntu are as follows:
Code:
Cflags: -I${sdkdir} -fvisibility=hidden
Libs: -L${libdir}
Can you tell the correct ones?
 
Old 11-23-2010, 05:32 AM   #14
_linux_newbie_
LQ Newbie
 
Registered: Nov 2010
Posts: 9

Original Poster
Rep: Reputation: 0
Quote:
since includedir is defined as "/usr/include"
My Cflag and Lib files are as follows:
Code:
Cflags: -I${sdkdir} -fvisibility=hidden
Libs: -L${libdir}v
How is sdkdir and libdir defined then?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Getting back to kubuntu after installing windows. Nexxt Linux - General 1 01-11-2007 04:32 PM
Installing a Windows driver through Ndiswrapper in Ubunto 6.10 Dannt Linux - Wireless Networking 1 12-03-2006 04:01 PM
Can somebody help me with installing Kubuntu on a Gateway and keeping Windows XP too? supertunaman Linux - Newbie 17 09-03-2006 09:01 PM


All times are GMT -5. The time now is 06:41 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration