LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   installing weblogic on CentOS (http://www.linuxquestions.org/questions/linux-newbie-8/installing-weblogic-on-centos-4175420581/)

figure20012 08-06-2012 01:20 AM

installing weblogic on CentOS
 
java.awt.HeadlessException:
No X11 DISPLAY variable was set, but this program performed an operation which requires it.
at java.awt.GraphicsEnvironment.checkHeadless(GraphicsEnvironment.java:159)
at java.awt.Window.<init>(Window.java:432)
at java.awt.Frame.<init>(Frame.java:403)
at java.awt.Frame.<init>(Frame.java:368)
at javax.swing.JFrame.<init>(JFrame.java:158)
at com.bea.quickstart.gui.QuickStartFrame.<init>(QuickStartFrame.java:24)
at com.bea.quickstart.QuickStartController.display(QuickStartController.java:128)
at com.bea.quickstart.QuickStartController.displayQuickStart(QuickStartController.java:422)
at com.bea.quickstart.QuickStartController.main(QuickStartController.java:444)

No X11 DISPLAY variable was set, but this program performed an operation which requires it.


I dont have graphical interface
i am connecting to the server through ssh.
Can anyone please tell me what should i do for weblogic to work.
thanks

kbp 08-06-2012 06:32 AM

You need to redirect X via ssh to the machine you are connecting from, there are several steps to make this work:

In /etc/ssh/sshd_config:
Code:

X11Fowarding yes
Restart sshd if you had to change the file above:
Code:

service sshd restart
Make sure the xauth package is installed:
Code:

rpm -q xauth || yum -y install xauth
The next part depends on what OS you are connecting from, if it's Windows:

- Download Xming from sourceforge, install it and run it
- Download PuTTY and unzip it
- Open PuTTY, in the settings on the left hand side go to Connection >> SSH >> X11 and check "Enable X11 forwarding", type localhost:0 in the "X display location" box.
- click on Session at the top left, then click on Default settings on the right hand side, then click the save button.
- connect to the server and run your application again.

If you're in linux (or Mac?), then just run:
Code:

ssh -X user@host

figure20012 08-07-2012 02:25 AM

Quote:

Originally Posted by kbp (Post 4747109)
You need to redirect X via ssh to the machine you are connecting from, there are several steps to make this work:

In /etc/ssh/sshd_config:
Code:

X11Fowarding yes
Restart sshd if you had to change the file above:
Code:

service sshd restart
Make sure the xauth package is installed:
Code:

rpm -q xauth || yum -y install xauth
The next part depends on what OS you are connecting from, if it's Windows:

- Download Xming from sourceforge, install it and run it
- Download PuTTY and unzip it
- Open PuTTY, in the settings on the left hand side go to Connection >> SSH >> X11 and check "Enable X11 forwarding", type localhost:0 in the "X display location" box.
- click on Session at the top left, then click on Default settings on the right hand side, then click the save button.
- connect to the server and run your application again.

If you're in linux (or Mac?), then just run:
Code:

ssh -X user@host


thnx for helping kbp :)


All times are GMT -5. The time now is 06:54 PM.