LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-01-2012, 01:15 PM   #1
alpha1234
LQ Newbie
 
Registered: Mar 2012
Posts: 10

Rep: Reputation: Disabled
Installing VLC. Won't work due to dependancies


Hi, I'm trying to update my VLC as the current version won't play MP4 files correctly. I'm running CentOS. I downloaded the latest rpm of vlc and tried the following to install. Thanks in advance for your help!

Code:
# rpm -Uvh vlc-1.1.13-74.el5.i386.rpm 
warning: vlc-1.1.13-74.el5.i386.rpm: Header V4 DSA signature: NOKEY, key ID 66534c2b
error: Failed dependencies:
        bitstream-vera-serif-fonts is needed by vlc-1.1.13-74.el5.i386
        libFLAC.so.8 is needed by vlc-1.1.13-74.el5.i386
        libX11-xcb.so.1 is needed by vlc-1.1.13-74.el5.i386
        liba52.so.0 is needed by vlc-1.1.13-74.el5.i386
        libaa.so.1 is needed by vlc-1.1.13-74.el5.i386
        libavcodec.so.53 is needed by vlc-1.1.13-74.el5.i386
        libavcodec.so.53(LIBAVCODEC_53) is needed by vlc-1.1.13-74.el5.i386
        libavformat.so.53 is needed by vlc-1.1.13-74.el5.i386
        libavformat.so.53(LIBAVFORMAT_53) is needed by vlc-1.1.13-74.el5.i386
        libavutil.so.51 is needed by vlc-1.1.13-74.el5.i386
        libavutil.so.51(LIBAVUTIL_51) is needed by vlc-1.1.13-74.el5.i386
        libcdio.so.10 is needed by vlc-1.1.13-74.el5.i386
        libcdio.so.10(CDIO_10) is needed by vlc-1.1.13-74.el5.i386
        libdca.so.0 is needed by vlc-1.1.13-74.el5.i386
        libdirac_decoder.so.0 is needed by vlc-1.1.13-74.el5.i386
        libdirac_encoder.so.0 is needed by vlc-1.1.13-74.el5.i386
        libdirect-1.4.so.5 is needed by vlc-1.1.13-74.el5.i386
        libdirectfb-1.4.so.5 is needed by vlc-1.1.13-74.el5.i386
        libdvbpsi.so.7 is needed by vlc-1.1.13-74.el5.i386
        libdvdnav.so.4 is needed by vlc-1.1.13-74.el5.i386
        libdvdread.so.4 is needed by vlc-1.1.13-74.el5.i386
        libebml.so.2 is needed by vlc-1.1.13-74.el5.i386
        libfaad.so.2 is needed by vlc-1.1.13-74.el5.i386
        libfribidi.so.0 is needed by vlc-1.1.13-74.el5.i386
        libfusion-1.4.so.5 is needed by vlc-1.1.13-74.el5.i386
        libgoom2.so.0 is needed by vlc-1.1.13-74.el5.i386
        libid3tag.so.0 is needed by vlc-1.1.13-74.el5.i386
        libiso9660.so.7 is needed by vlc-1.1.13-74.el5.i386
        libjack.so.0 is needed by vlc-1.1.13-74.el5.i386
        liblirc_client.so.0 is needed by vlc-1.1.13-74.el5.i386
        liblua-5.1.so is needed by vlc-1.1.13-74.el5.i386
        libmad.so.0 is needed by vlc-1.1.13-74.el5.i386
        libmatroska.so.2 is needed by vlc-1.1.13-74.el5.i386
        libmpcdec.so.6 is needed by vlc-1.1.13-74.el5.i386
        libmpeg2.so.0 is needed by vlc-1.1.13-74.el5.i386
        libpostproc.so.51 is needed by vlc-1.1.13-74.el5.i386
        libpostproc.so.51(LIBPOSTPROC_51) is needed by vlc-1.1.13-74.el5.i386
        libprojectM.so.2.0.1 is needed by vlc-1.1.13-74.el5.i386
        libspeex.so.1 is needed by vlc-1.1.13-74.el5.i386
        libssh2.so.1 is needed by vlc-1.1.13-74.el5.i386
        libswscale.so.2 is needed by vlc-1.1.13-74.el5.i386
        libswscale.so.2(LIBSWSCALE_2) is needed by vlc-1.1.13-74.el5.i386
        libtag.so.1 is needed by vlc-1.1.13-74.el5.i386
        libtwolame.so.0 is needed by vlc-1.1.13-74.el5.i386
        libva-0.32.0.2.so.1 is needed by vlc-1.1.13-74.el5.i386
        libva-x11-0.32.0.2.so.1 is needed by vlc-1.1.13-74.el5.i386
        libvcdinfo.so.0 is needed by vlc-1.1.13-74.el5.i386
        libvcdinfo.so.0(VCDINFO_0) is needed by vlc-1.1.13-74.el5.i386
        libvga.so.1 is needed by vlc-1.1.13-74.el5.i386
        libvgagl.so.1 is needed by vlc-1.1.13-74.el5.i386
        libx264.so.118 is needed by vlc-1.1.13-74.el5.i386
        libxcb-keysyms.so.0 is needed by vlc-1.1.13-74.el5.i386
        libxcb-shm.so.0 is needed by vlc-1.1.13-74.el5.i386
        libxcb-xv.so.0 is needed by vlc-1.1.13-74.el5.i386
        libxcb.so.1 is needed by vlc-1.1.13-74.el5.i386
        libxosd.so.2 is needed by vlc-1.1.13-74.el5.i386
        xdg-utils is needed by vlc-1.1.13-74.el5.i386

Last edited by alpha1234; 03-01-2012 at 04:01 PM.
 
Old 03-01-2012, 02:21 PM   #2
alpha1234
LQ Newbie
 
Registered: Mar 2012
Posts: 10

Original Poster
Rep: Reputation: Disabled
Also tried Yum

I also tried the following:

Code:
# yum install vlc-1.1.13-74.el5.i386.rpm --skip-broken
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
Setting up Install Process
Examining vlc-1.1.13-74.el5.i386.rpm: vlc-1.1.13-74.el5.i386
Marking vlc-1.1.13-74.el5.i386.rpm as an update to vlc-0.8.6h-1.el5.rf.x86_64
vlc-1.1.13-74.el5.i386.rpm: does not update installed package.
Resolving Dependencies
--> Running transaction check
---> Package vlc.i386 0:1.1.13-74.el5 set to be updated
--> Processing Dependency: bitstream-vera-serif-fonts for package: vlc
--> Processing Dependency: libFLAC.so.8 for package: vlc
--> Processing Dependency: libX11-xcb.so.1 for package: vlc
--> Processing Dependency: liba52.so.0 for package: vlc
--> Processing Dependency: libaa.so.1 for package: vlc
--> Processing Dependency: libavcodec.so.53 for package: vlc
--> Processing Dependency: libavcodec.so.53(LIBAVCODEC_53) for package: vlc
--> Processing Dependency: libavformat.so.53 for package: vlc
--> Processing Dependency: libavformat.so.53(LIBAVFORMAT_53) for package: vlc
--> Processing Dependency: libavutil.so.51 for package: vlc
--> Processing Dependency: libavutil.so.51(LIBAVUTIL_51) for package: vlc
--> Processing Dependency: libcdio.so.10 for package: vlc
--> Processing Dependency: libcdio.so.10(CDIO_10) for package: vlc
--> Processing Dependency: libdca.so.0 for package: vlc
--> Processing Dependency: libdirac_decoder.so.0 for package: vlc
--> Processing Dependency: libdirac_encoder.so.0 for package: vlc
--> Processing Dependency: libdirect-1.4.so.5 for package: vlc
--> Processing Dependency: libdirectfb-1.4.so.5 for package: vlc
--> Processing Dependency: libdvbpsi.so.7 for package: vlc
--> Processing Dependency: libdvdnav.so.4 for package: vlc
--> Processing Dependency: libdvdread.so.4 for package: vlc
--> Processing Dependency: libebml.so.2 for package: vlc
--> Processing Dependency: libfaad.so.2 for package: vlc
--> Processing Dependency: libfribidi.so.0 for package: vlc
--> Processing Dependency: libfusion-1.4.so.5 for package: vlc
--> Processing Dependency: libgoom2.so.0 for package: vlc
--> Processing Dependency: libid3tag.so.0 for package: vlc
--> Processing Dependency: libiso9660.so.7 for package: vlc
--> Processing Dependency: libjack.so.0 for package: vlc
--> Processing Dependency: liblirc_client.so.0 for package: vlc
--> Processing Dependency: liblua-5.1.so for package: vlc
--> Processing Dependency: libmad.so.0 for package: vlc
--> Processing Dependency: libmatroska.so.2 for package: vlc
--> Processing Dependency: libmpcdec.so.6 for package: vlc
--> Processing Dependency: libmpeg2.so.0 for package: vlc
--> Processing Dependency: libpostproc.so.51 for package: vlc
--> Processing Dependency: libpostproc.so.51(LIBPOSTPROC_51) for package: vlc
--> Processing Dependency: libprojectM.so.2.0.1 for package: vlc
--> Processing Dependency: libspeex.so.1 for package: vlc
--> Processing Dependency: libssh2.so.1 for package: vlc
--> Processing Dependency: libswscale.so.2 for package: vlc
--> Processing Dependency: libswscale.so.2(LIBSWSCALE_2) for package: vlc
--> Processing Dependency: libtag.so.1 for package: vlc
--> Processing Dependency: libtwolame.so.0 for package: vlc
--> Processing Dependency: libva-0.32.0.2.so.1 for package: vlc
--> Processing Dependency: libva-x11-0.32.0.2.so.1 for package: vlc
--> Processing Dependency: libvcdinfo.so.0 for package: vlc
--> Processing Dependency: libvcdinfo.so.0(VCDINFO_0) for package: vlc
--> Processing Dependency: libvga.so.1 for package: vlc
--> Processing Dependency: libvgagl.so.1 for package: vlc
--> Processing Dependency: libx264.so.118 for package: vlc
--> Processing Dependency: libxcb-keysyms.so.0 for package: vlc
--> Processing Dependency: libxcb-shm.so.0 for package: vlc
--> Processing Dependency: libxcb-xv.so.0 for package: vlc
--> Processing Dependency: libxcb.so.1 for package: vlc
--> Processing Dependency: libxosd.so.2 for package: vlc
--> Processing Dependency: xdg-utils for package: vlc
--> Running transaction check
---> Package fribidi.i386 0:0.10.7-5.1 set to be updated
---> Package speex.i386 0:1.0.5-4.el5_1.1 set to be updated
---> Package vlc.i386 0:1.1.13-74.el5 set to be updated
--> Processing Dependency: bitstream-vera-serif-fonts for package: vlc
--> Processing Dependency: libFLAC.so.8 for package: vlc
--> Processing Dependency: libX11-xcb.so.1 for package: vlc
--> Processing Dependency: liba52.so.0 for package: vlc
--> Processing Dependency: libaa.so.1 for package: vlc
--> Processing Dependency: libavcodec.so.53 for package: vlc
--> Processing Dependency: libavcodec.so.53(LIBAVCODEC_53) for package: vlc
--> Processing Dependency: libavformat.so.53 for package: vlc
--> Processing Dependency: libavformat.so.53(LIBAVFORMAT_53) for package: vlc
--> Processing Dependency: libavutil.so.51 for package: vlc
--> Processing Dependency: libavutil.so.51(LIBAVUTIL_51) for package: vlc
--> Processing Dependency: libcdio.so.10 for package: vlc
--> Processing Dependency: libcdio.so.10(CDIO_10) for package: vlc
--> Processing Dependency: libdca.so.0 for package: vlc
--> Processing Dependency: libdirac_decoder.so.0 for package: vlc
--> Processing Dependency: libdirac_encoder.so.0 for package: vlc
--> Processing Dependency: libdirect-1.4.so.5 for package: vlc
--> Processing Dependency: libdirectfb-1.4.so.5 for package: vlc
--> Processing Dependency: libdvbpsi.so.7 for package: vlc
--> Processing Dependency: libdvdnav.so.4 for package: vlc
--> Processing Dependency: libdvdread.so.4 for package: vlc
--> Processing Dependency: libebml.so.2 for package: vlc
--> Processing Dependency: libfaad.so.2 for package: vlc
--> Processing Dependency: libfusion-1.4.so.5 for package: vlc
--> Processing Dependency: libgoom2.so.0 for package: vlc
--> Processing Dependency: libid3tag.so.0 for package: vlc
--> Processing Dependency: libiso9660.so.7 for package: vlc
--> Processing Dependency: libjack.so.0 for package: vlc
--> Processing Dependency: liblirc_client.so.0 for package: vlc
--> Processing Dependency: liblua-5.1.so for package: vlc
--> Processing Dependency: libmad.so.0 for package: vlc
--> Processing Dependency: libmatroska.so.2 for package: vlc
--> Processing Dependency: libmpcdec.so.6 for package: vlc
--> Processing Dependency: libmpeg2.so.0 for package: vlc
--> Processing Dependency: libpostproc.so.51 for package: vlc
--> Processing Dependency: libpostproc.so.51(LIBPOSTPROC_51) for package: vlc
--> Processing Dependency: libprojectM.so.2.0.1 for package: vlc
--> Processing Dependency: libssh2.so.1 for package: vlc
--> Processing Dependency: libswscale.so.2 for package: vlc
--> Processing Dependency: libswscale.so.2(LIBSWSCALE_2) for package: vlc
--> Processing Dependency: libtag.so.1 for package: vlc
--> Processing Dependency: libtwolame.so.0 for package: vlc
--> Processing Dependency: libva-0.32.0.2.so.1 for package: vlc
--> Processing Dependency: libva-x11-0.32.0.2.so.1 for package: vlc
--> Processing Dependency: libvcdinfo.so.0 for package: vlc
--> Processing Dependency: libvcdinfo.so.0(VCDINFO_0) for package: vlc
--> Processing Dependency: libvga.so.1 for package: vlc
--> Processing Dependency: libvgagl.so.1 for package: vlc
--> Processing Dependency: libx264.so.118 for package: vlc
--> Processing Dependency: libxcb-keysyms.so.0 for package: vlc
--> Processing Dependency: libxcb-shm.so.0 for package: vlc
--> Processing Dependency: libxcb-xv.so.0 for package: vlc
--> Processing Dependency: libxcb.so.1 for package: vlc
--> Processing Dependency: libxosd.so.2 for package: vlc
---> Package xdg-utils.noarch 0:1.0.2-2.el5.centos set to be updated
--> Finished Dependency Resolution
vlc-1.1.13-74.el5.i386 from /vlc-1.1.13-74.el5.i386 has depsolving problems
  --> Missing Dependency: libX11-xcb.so.1 is needed by package vlc-1.1.13-74.el5.i386 (/vlc-1.1.13-74.el5.i386)
vlc-1.1.13-74.el5.i386 from /vlc-1.1.13-74.el5.i386 has depsolving problems
  --> Missing Dependency: libssh2.so.1 is needed by package vlc-1.1.13-74.el5.i386 (/vlc-1.1.13-74.el5.i386)
vlc-1.1.13-74.el5.i386 from /vlc-1.1.13-74.el5.i386 has depsolving problems
  --> Missing Dependency: libmpcdec.so.6 is needed by package vlc-1.1.13-74.el5.i386 (/vlc-1.1.13-74.el5.i386)
vlc-1.1.13-74.el5.i386 from /vlc-1.1.13-74.el5.i386 has depsolving problems
  --> Missing Dependency: libvcdinfo.so.0 is needed by package vlc-1.1.13-74.el5.i386 (/vlc-1.1.13-74.el5.i386)
vlc-1.1.13-74.el5.i386 from /vlc-1.1.13-74.el5.i386 has depsolving problems
  --> Missing Dependency: libxcb-xv.so.0 is needed by package vlc-1.1.13-74.el5.i386 (/vlc-1.1.13-74.el5.i386)
vlc-1.1.13-74.el5.i386 from /vlc-1.1.13-74.el5.i386 has depsolving problems
  --> Missing Dependency: libdvdnav.so.4 is needed by package vlc-1.1.13-74.el5.i386 (/vlc-1.1.13-74.el5.i386)
vlc-1.1.13-74.el5.i386 from /vlc-1.1.13-74.el5.i386 has depsolving problems
  --> Missing Dependency: libxcb-keysyms.so.0 is needed by package vlc-1.1.13-74.el5.i386 (/vlc-1.1.13-74.el5.i386)
vlc-1.1.13-74.el5.i386 from /vlc-1.1.13-74.el5.i386 has depsolving problems
  --> Missing Dependency: libiso9660.so.7 is needed by package vlc-1.1.13-74.el5.i386 (/vlc-1.1.13-74.el5.i386)
vlc-1.1.13-74.el5.i386 from /vlc-1.1.13-74.el5.i386 has depsolving problems
  --> Missing Dependency: libtag.so.1 is needed by package vlc-1.1.13-74.el5.i386 (/vlc-1.1.13-74.el5.i386)
vlc-1.1.13-74.el5.i386 from /vlc-1.1.13-74.el5.i386 has depsolving problems
  --> Missing Dependency: libavutil.so.51(LIBAVUTIL_51) is needed by package vlc-1.1.13-74.el5.i386 (/vlc-1.1.13-74.el5.i386)
vlc-1.1.13-74.el5.i386 from /vlc-1.1.13-74.el5.i386 has depsolving problems
  --> Missing Dependency: libxcb-shm.so.0 is needed by package vlc-1.1.13-74.el5.i386 (/vlc-1.1.13-74.el5.i386)
vlc-1.1.13-74.el5.i386 from /vlc-1.1.13-74.el5.i386 has depsolving problems
  --> Missing Dependency: libvga.so.1 is needed by package vlc-1.1.13-74.el5.i386 (/vlc-1.1.13-74.el5.i386)
vlc-1.1.13-74.el5.i386 from /vlc-1.1.13-74.el5.i386 has depsolving problems
  --> Missing Dependency: libavformat.so.53(LIBAVFORMAT_53) is needed by package vlc-1.1.13-74.el5.i386 (/vlc-1.1.13-74.el5.i386)
vlc-1.1.13-74.el5.i386 from /vlc-1.1.13-74.el5.i386 has depsolving problems
  --> Missing Dependency: libebml.so.2 is needed by package vlc-1.1.13-74.el5.i386 (/vlc-1.1.13-74.el5.i386)
vlc-1.1.13-74.el5.i386 from /vlc-1.1.13-74.el5.i386 has depsolving problems
  --> Missing Dependency: libpostproc.so.51(LIBPOSTPROC_51) is needed by package vlc-1.1.13-74.el5.i386 (/vlc-1.1.13-74.el5.i386)
vlc-1.1.13-74.el5.i386 from /vlc-1.1.13-74.el5.i386 has depsolving problems
  --> Missing Dependency: libFLAC.so.8 is needed by package vlc-1.1.13-74.el5.i386 (/vlc-1.1.13-74.el5.i386)
vlc-1.1.13-74.el5.i386 from /vlc-1.1.13-74.el5.i386 has depsolving problems
  --> Missing Dependency: libvcdinfo.so.0(VCDINFO_0) is needed by package vlc-1.1.13-74.el5.i386 (/vlc-1.1.13-74.el5.i386)
vlc-1.1.13-74.el5.i386 from /vlc-1.1.13-74.el5.i386 has depsolving problems
  --> Missing Dependency: libcdio.so.10(CDIO_10) is needed by package vlc-1.1.13-74.el5.i386 (/vlc-1.1.13-74.el5.i386)
vlc-1.1.13-74.el5.i386 from /vlc-1.1.13-74.el5.i386 has depsolving problems
  --> Missing Dependency: libdvbpsi.so.7 is needed by package vlc-1.1.13-74.el5.i386 (/vlc-1.1.13-74.el5.i386)
vlc-1.1.13-74.el5.i386 from /vlc-1.1.13-74.el5.i386 has depsolving problems
  --> Missing Dependency: libtwolame.so.0 is needed by package vlc-1.1.13-74.el5.i386 (/vlc-1.1.13-74.el5.i386)
vlc-1.1.13-74.el5.i386 from /vlc-1.1.13-74.el5.i386 has depsolving problems
  --> Missing Dependency: libgoom2.so.0 is needed by package vlc-1.1.13-74.el5.i386 (/vlc-1.1.13-74.el5.i386)
vlc-1.1.13-74.el5.i386 from /vlc-1.1.13-74.el5.i386 has depsolving problems
  --> Missing Dependency: libprojectM.so.2.0.1 is needed by package vlc-1.1.13-74.el5.i386 (/vlc-1.1.13-74.el5.i386)
vlc-1.1.13-74.el5.i386 from /vlc-1.1.13-74.el5.i386 has depsolving problems
  --> Missing Dependency: libdca.so.0 is needed by package vlc-1.1.13-74.el5.i386 (/vlc-1.1.13-74.el5.i386)
vlc-1.1.13-74.el5.i386 from /vlc-1.1.13-74.el5.i386 has depsolving problems
  --> Missing Dependency: libvgagl.so.1 is needed by package vlc-1.1.13-74.el5.i386 (/vlc-1.1.13-74.el5.i386)
vlc-1.1.13-74.el5.i386 from /vlc-1.1.13-74.el5.i386 has depsolving problems
  --> Missing Dependency: libavformat.so.53 is needed by package vlc-1.1.13-74.el5.i386 (/vlc-1.1.13-74.el5.i386)
vlc-1.1.13-74.el5.i386 from /vlc-1.1.13-74.el5.i386 has depsolving problems
  --> Missing Dependency: liblirc_client.so.0 is needed by package vlc-1.1.13-74.el5.i386 (/vlc-1.1.13-74.el5.i386)
vlc-1.1.13-74.el5.i386 from /vlc-1.1.13-74.el5.i386 has depsolving problems
  --> Missing Dependency: libxcb.so.1 is needed by package vlc-1.1.13-74.el5.i386 (/vlc-1.1.13-74.el5.i386)
vlc-1.1.13-74.el5.i386 from /vlc-1.1.13-74.el5.i386 has depsolving problems
  --> Missing Dependency: libid3tag.so.0 is needed by package vlc-1.1.13-74.el5.i386 (/vlc-1.1.13-74.el5.i386)
vlc-1.1.13-74.el5.i386 from /vlc-1.1.13-74.el5.i386 has depsolving problems
  --> Missing Dependency: libdirac_encoder.so.0 is needed by package vlc-1.1.13-74.el5.i386 (/vlc-1.1.13-74.el5.i386)
vlc-1.1.13-74.el5.i386 from /vlc-1.1.13-74.el5.i386 has depsolving problems
  --> Missing Dependency: libdirac_decoder.so.0 is needed by package vlc-1.1.13-74.el5.i386 (/vlc-1.1.13-74.el5.i386)
vlc-1.1.13-74.el5.i386 from /vlc-1.1.13-74.el5.i386 has depsolving problems
  --> Missing Dependency: libfaad.so.2 is needed by package vlc-1.1.13-74.el5.i386 (/vlc-1.1.13-74.el5.i386)
vlc-1.1.13-74.el5.i386 from /vlc-1.1.13-74.el5.i386 has depsolving problems
  --> Missing Dependency: liba52.so.0 is needed by package vlc-1.1.13-74.el5.i386 (/vlc-1.1.13-74.el5.i386)
vlc-1.1.13-74.el5.i386 from /vlc-1.1.13-74.el5.i386 has depsolving problems
  --> Missing Dependency: bitstream-vera-serif-fonts is needed by package vlc-1.1.13-74.el5.i386 (/vlc-1.1.13-74.el5.i386)
vlc-1.1.13-74.el5.i386 from /vlc-1.1.13-74.el5.i386 has depsolving problems
  --> Missing Dependency: libcdio.so.10 is needed by package vlc-1.1.13-74.el5.i386 (/vlc-1.1.13-74.el5.i386)
vlc-1.1.13-74.el5.i386 from /vlc-1.1.13-74.el5.i386 has depsolving problems
  --> Missing Dependency: libx264.so.118 is needed by package vlc-1.1.13-74.el5.i386 (/vlc-1.1.13-74.el5.i386)
vlc-1.1.13-74.el5.i386 from /vlc-1.1.13-74.el5.i386 has depsolving problems
  --> Missing Dependency: libdvdread.so.4 is needed by package vlc-1.1.13-74.el5.i386 (/vlc-1.1.13-74.el5.i386)
vlc-1.1.13-74.el5.i386 from /vlc-1.1.13-74.el5.i386 has depsolving problems
  --> Missing Dependency: libva-0.32.0.2.so.1 is needed by package vlc-1.1.13-74.el5.i386 (/vlc-1.1.13-74.el5.i386)
vlc-1.1.13-74.el5.i386 from /vlc-1.1.13-74.el5.i386 has depsolving problems
  --> Missing Dependency: libavutil.so.51 is needed by package vlc-1.1.13-74.el5.i386 (/vlc-1.1.13-74.el5.i386)
vlc-1.1.13-74.el5.i386 from /vlc-1.1.13-74.el5.i386 has depsolving problems
  --> Missing Dependency: libswscale.so.2(LIBSWSCALE_2) is needed by package vlc-1.1.13-74.el5.i386 (/vlc-1.1.13-74.el5.i386)
vlc-1.1.13-74.el5.i386 from /vlc-1.1.13-74.el5.i386 has depsolving problems
  --> Missing Dependency: libaa.so.1 is needed by package vlc-1.1.13-74.el5.i386 (/vlc-1.1.13-74.el5.i386)
vlc-1.1.13-74.el5.i386 from /vlc-1.1.13-74.el5.i386 has depsolving problems
  --> Missing Dependency: libfusion-1.4.so.5 is needed by package vlc-1.1.13-74.el5.i386 (/vlc-1.1.13-74.el5.i386)
vlc-1.1.13-74.el5.i386 from /vlc-1.1.13-74.el5.i386 has depsolving problems
  --> Missing Dependency: libva-x11-0.32.0.2.so.1 is needed by package vlc-1.1.13-74.el5.i386 (/vlc-1.1.13-74.el5.i386)
vlc-1.1.13-74.el5.i386 from /vlc-1.1.13-74.el5.i386 has depsolving problems
  --> Missing Dependency: libavcodec.so.53 is needed by package vlc-1.1.13-74.el5.i386 (/vlc-1.1.13-74.el5.i386)
vlc-1.1.13-74.el5.i386 from /vlc-1.1.13-74.el5.i386 has depsolving problems
  --> Missing Dependency: libdirect-1.4.so.5 is needed by package vlc-1.1.13-74.el5.i386 (/vlc-1.1.13-74.el5.i386)
vlc-1.1.13-74.el5.i386 from /vlc-1.1.13-74.el5.i386 has depsolving problems
  --> Missing Dependency: libjack.so.0 is needed by package vlc-1.1.13-74.el5.i386 (/vlc-1.1.13-74.el5.i386)
vlc-1.1.13-74.el5.i386 from /vlc-1.1.13-74.el5.i386 has depsolving problems
  --> Missing Dependency: libdirectfb-1.4.so.5 is needed by package vlc-1.1.13-74.el5.i386 (/vlc-1.1.13-74.el5.i386)
vlc-1.1.13-74.el5.i386 from /vlc-1.1.13-74.el5.i386 has depsolving problems
  --> Missing Dependency: libavcodec.so.53(LIBAVCODEC_53) is needed by package vlc-1.1.13-74.el5.i386 (/vlc-1.1.13-74.el5.i386)
vlc-1.1.13-74.el5.i386 from /vlc-1.1.13-74.el5.i386 has depsolving problems
  --> Missing Dependency: libmpeg2.so.0 is needed by package vlc-1.1.13-74.el5.i386 (/vlc-1.1.13-74.el5.i386)
vlc-1.1.13-74.el5.i386 from /vlc-1.1.13-74.el5.i386 has depsolving problems
  --> Missing Dependency: liblua-5.1.so is needed by package vlc-1.1.13-74.el5.i386 (/vlc-1.1.13-74.el5.i386)
vlc-1.1.13-74.el5.i386 from /vlc-1.1.13-74.el5.i386 has depsolving problems
  --> Missing Dependency: libmatroska.so.2 is needed by package vlc-1.1.13-74.el5.i386 (/vlc-1.1.13-74.el5.i386)
vlc-1.1.13-74.el5.i386 from /vlc-1.1.13-74.el5.i386 has depsolving problems
  --> Missing Dependency: libswscale.so.2 is needed by package vlc-1.1.13-74.el5.i386 (/vlc-1.1.13-74.el5.i386)
vlc-1.1.13-74.el5.i386 from /vlc-1.1.13-74.el5.i386 has depsolving problems
  --> Missing Dependency: libxosd.so.2 is needed by package vlc-1.1.13-74.el5.i386 (/vlc-1.1.13-74.el5.i386)
vlc-1.1.13-74.el5.i386 from /vlc-1.1.13-74.el5.i386 has depsolving problems
  --> Missing Dependency: libpostproc.so.51 is needed by package vlc-1.1.13-74.el5.i386 (/vlc-1.1.13-74.el5.i386)
vlc-1.1.13-74.el5.i386 from /vlc-1.1.13-74.el5.i386 has depsolving problems
  --> Missing Dependency: libmad.so.0 is needed by package vlc-1.1.13-74.el5.i386 (/vlc-1.1.13-74.el5.i386)

Packages skipped because of dependency problems:
    fribidi-0.10.7-5.1.i386 from base
    speex-1.0.5-4.el5_1.1.i386 from base
    vlc-1.1.13-74.el5.i386 from /vlc-1.1.13-74.el5.i386
    xdg-utils-1.0.2-2.el5.centos.noarch from extras

Last edited by alpha1234; 03-01-2012 at 04:02 PM.
 
Old 03-01-2012, 03:33 PM   #3
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,090

Rep: Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474
please DO NOT use rpm to install software on a red hat based distro
only use it as a LAST resort or for the unusual times that you do need to
Installing a repo file is one

as to vlc on Cent/RHEL/SL

please fallow the instructions on the VLC web page
http://www.videolan.org/vlc/download-redhat.html

you NEED to first install "rpmforge" then install AND CONFIGURE yum-priorities plugin

on cent 5 rmpforge is INCOMPATIBLE with the base install and will try to replace SYSTEM files
making CentOS 5 incompatible with the Cent repos
-- very important you READ AND FALLOW ALL warnings on the Cent wiki !!!!--
the page for installing repos in cent
http://wiki.centos.org/AdditionalResources/Repositories
-- cent 5 --
http://wiki.centos.org/AdditionalRes...11404998926a1b

THEN after "rpmforge" and "yum-priorities" are installed you run this command
Code:
su -
yum install vlc
PS. cent is NOT a good choice for a home "everyday" install
so it is not recommended for running your everyday computer
it is however a GOOD choice for running your business office and running your business server

but not for surfing the net and playing games
 
Old 03-01-2012, 03:48 PM   #4
alpha1234
LQ Newbie
 
Registered: Mar 2012
Posts: 10

Original Poster
Rep: Reputation: Disabled
Installing rpmforge

Hi there, thanks for your reply. I am fairly new to linux. CentOS is installed here at my work so I can't change it.

I tried to go to the first link you posted for rpmforge, but after I clicked the link for the 0.9.9 version of rpmforge, it just redirected me to a link with a bunch of directories in there. How do I install from there?

I can't believe it is this difficult just to install a simple program.
 
Old 03-01-2012, 04:15 PM   #5
alpha1234
LQ Newbie
 
Registered: Mar 2012
Posts: 10

Original Poster
Rep: Reputation: Disabled
Ok, looks like I have installed rpmforge and htop as per your third link, and I also installed yum-priorities.

I typed yum install vlc and it seems to be working. IT works!
I didn't even need to type "yum install vlc-1.1.13-74.el5.i386.rpm" which actually didn't work.

Well, I don't understand why it works now and didn't before, and I don't know how I would have figured it out without this forum, but IT WORKS!

Thanks a lot John!

Cheers
 
Old 03-01-2012, 04:50 PM   #6
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,090

Rep: Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474
Quote:
yum install vlc-1.1.13-74.el5.i386.rpm
that is not the command i posted nor is it the one you use
you ALSO MUST configure yum-priorities
-- this IS VERY VERY important ---

you must set the settings on the /etc/yum.repos.d/??? files
you need to edit the text files
see the wiki page
http://wiki.centos.org/PackageManagement/Yum/Priorities

if you skip that you WILL KILL your install
you might never even be able to reboot
( not likely )
but you WILL royally mess up the install
and the cent install will NOT be able yo install updates
and some programs might NOT ever work again
-- or you might have to reinstall Cent5 to fix it

and no i am NOT exaggerating
- you NEED to configure "Priorities" or use "ProtectBase"
http://wiki.centos.org/PackageManage...um/ProtectBase
and HEED ALL AND EVERY WARNING !!!
http://wiki.centos.org/AdditionalResources/Repositories
 
Old 03-01-2012, 05:06 PM   #7
alpha1234
LQ Newbie
 
Registered: Mar 2012
Posts: 10

Original Poster
Rep: Reputation: Disabled
Configuring Priorities

Can I just uninstall the priorities thing now that VLC works?

I don't know what you mean by configuring it, is there an easy way to do it? Maybe I should yum remove it..
 
Old 03-01-2012, 05:09 PM   #8
alpha1234
LQ Newbie
 
Registered: Mar 2012
Posts: 10

Original Poster
Rep: Reputation: Disabled
Also, since it is working now, and everything seems to be working, does that mean it does not need to be modified any further?
 
Old 03-01-2012, 05:10 PM   #9
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,090

Rep: Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474
the wiki page has the instructions
http://wiki.centos.org/PackageManagement/Yum/Priorities

remember that Cent is just like RHEL in that it was designed to be used by system administrators
it is not an easy operating system to learn on .There is a VERY steep learning curve .
 
Old 03-01-2012, 05:19 PM   #10
alpha1234
LQ Newbie
 
Registered: Mar 2012
Posts: 10

Original Poster
Rep: Reputation: Disabled
Linux distributions

So you mean that not every version of linux is this difficult? Next time, if I decide to use linux at home, which one should I install? Hopefully a free one that is easy to use.

About the priorities configuration, should I just copy and paste all of the code examples in that link?

Like this:
Code:
[main]
enabled=1
or this:
Code:
[base], [addons], [updates], [extras] ... priority=1
[centosplus] priority=1 (same priority as base and updates) but should be left disabled
[contrib] ... priority=2
Third Party Repos ... priority=N  (where N is > 10 and based on your preference)
 
Old 03-01-2012, 05:30 PM   #11
alpha1234
LQ Newbie
 
Registered: Mar 2012
Posts: 10

Original Poster
Rep: Reputation: Disabled
Hello John,

I don't want to mess up my work computer, so I have removed the yum-priorities plugin

Quote:
yum remove yum-priorities
VLC is still working, so I hope its ok.
 
Old 03-01-2012, 05:45 PM   #12
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,090

Rep: Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474
if you do not want to mess up the work computer then YOU MUST use yum-priorities or yumprotectbase

the rpmforge repo IS INCOMPATIBLE with the cent 5 base install

this has been mostly fixed with RHEL6 / Centos6 / SL 6
 
Old 03-01-2012, 05:49 PM   #13
snowpine
Senior Member
 
Registered: Feb 2009
Posts: 4,184

Rep: Reputation: 1168Reputation: 1168Reputation: 1168Reputation: 1168Reputation: 1168Reputation: 1168Reputation: 1168Reputation: 1168Reputation: 1168
Does your workplace have a system administrator or IT person who can help you install VLC and yum-priorities so that you don't mess up your work computer? I am sure he/she would rather help you a little now than a lot later.
 
Old 03-01-2012, 05:59 PM   #14
alpha1234
LQ Newbie
 
Registered: Mar 2012
Posts: 10

Original Poster
Rep: Reputation: Disabled
OMG! Ok i have reinstalled the yum-priorities thing. I have read the link you said about configuring it, but I'm not sure what it means by repositories and stuff like that, so I'm not sure how to configure it.

No there's no administrator, i have root on the computer.

---------- Post added 03-01-12 at 04:00 PM ----------

Maybe I should just uninstall rpmforge?
 
Old 03-01-2012, 07:06 PM   #15
alpha1234
LQ Newbie
 
Registered: Mar 2012
Posts: 10

Original Poster
Rep: Reputation: Disabled
I used:

Code:
rpm -K rpmforge-release-0.5.2-2.el5.rf.*.rpm
rpm -i rpmforge-release-0.5.2-2.el5.rf.*.rpm
to install rpmforge. How do I remove it?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Flash plugin doesn't work. Error installing VLC. ShellyCat Linux - Software 7 09-21-2010 06:15 AM
Unable to install vlc on fedora due to error 404 ! kkrockstar Linux - Newbie 9 07-02-2008 05:05 AM
Zip drive won't work due to security policy geeare1 Slackware 3 08-02-2007 01:31 PM
Missing Dependancies when attempting to install totem and vlc on Fedora 6 system. walkingtheredpath Linux - Software 9 07-04-2007 10:33 PM
One DVD won't work in Xine but does in VLC? astacha Linux - Desktop 1 05-02-2007 01:39 AM


All times are GMT -5. The time now is 08:36 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration