LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 11-11-2007, 07:48 PM   #1
shill
LQ Newbie
 
Registered: Nov 2007
Posts: 4

Rep: Reputation: 0
installing ubuntu on an imac with no os


2 imac's no os installed
Ram: 384
CPU: 400 & 500
HD: 13 & 30

Ubuntu 6.06 alternate burned with infrarecord.
Tried 7.10 live cd first. tried to load and shut down computer.
Read to start with 6.06 alternate for ppc.

It gets to the base system install and gives errors at libc6 package.
red screens and all.

I have it connected via ethernet to the linksys router switch behind a cable modem. Not sure if this would add to problems. Tried disconnecting the cable, still errors.

verified md5sums of the disk.

What is the problem? Is it so different without the actual operating system on the machine?
 
Old 11-11-2007, 08:08 PM   #2
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
Quote:
gives errors at libc6 package
... what are these errors: quote exactly.

Quote:
I have it connected via ethernet to the linksys router switch behind a cable modem. Not sure if this would add to problems.
... as long as it does dhcp, there will be no problems with this.

Quote:
Is it so different without the actual operating system on the machine?
... probably not - which iso are you using (give the name of the file and where you got it from) and how did you burn it (machine, software, speed)?
 
Old 11-11-2007, 08:29 PM   #3
matthewg42
Senior Member
 
Registered: Oct 2003
Location: UK
Distribution: Kubuntu 12.10 (using awesome wm though)
Posts: 3,530

Rep: Reputation: 63
For what it's worth, I have Debian Etch on my old PPC iBook (600 MHz). It installed flawlessly and now sits under my sofa happily rendering map tiles for the OpenStreetMap project, and downloading images from various webcams, from which I make timelapse movies
 
Old 11-11-2007, 09:10 PM   #4
shill
LQ Newbie
 
Registered: Nov 2007
Posts: 4

Original Poster
Rep: Reputation: 0
installing ubuntu on an imac with no os

downloaded from ubuntu site
used infrarecord to burn, at 4x speed on a Windows XP box, Intel pentium D processor dual core, 2 gigs RAM 250Gig hard disk

http://www.gtlib.gatech.edu/pub/ubuntu-releases/
ubuntu-6.06.1-alternate-powerpc

base system install portion

file: //cdrom pool/main/glibc/glibc6_2.3.6-0ubuntu20_powerpc.deb was corrupt

could not download package glibc/

and once

file: //cdrom pool/main/gpm/glibgpmg1_1.19.6/ubuntu20_powerpc.deb was corrupt
could not download package libgpmg/

keep in mind I tried this cd multiple times


tried different install commands instead of the default, tried oem, oem-powerpc, check, check powerpc, etc.

Last edited by shill; 11-11-2007 at 09:13 PM. Reason: machine software speed
 
Old 11-11-2007, 11:37 PM   #5
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
file: //cdrom pool/main/glibc/glibc6_2.3.6-0ubuntu20_powerpc.deb was corrupt
file: //cdrom pool/main/gpm/glibgpmg1_1.19.6/ubuntu20_powerpc.deb was corrupt
... sorry, file is corrupt: you gotta burn it again.
Try reburning at 1x - use different (brand) media, different burner.

Why didn't you try gutsy?
http://cdimage.ubuntu.com/ports/releases/gutsy/release/
 
Old 11-24-2007, 02:10 PM   #6
shill
LQ Newbie
 
Registered: Nov 2007
Posts: 4

Original Poster
Rep: Reputation: 0
Installed ubuntu and tried upgrading to 7.10

Had finally gotten the install of ubuntu on an imac, starting with the 6.06 power pc version. I did upgrade to 7.04 and was in the process of upgrading to 7.10. Got it installed but it would not boot after it restarted. Typed help but did not know what command to type. Tried a few commands but nothing progressed further.

Does 7.10 not work on mac's?

What do I do next? Start over with reformatting and re-installing 6.06 and stopping with 7.04?
 
Old 11-24-2007, 06:42 PM   #7
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
Does 7.10 not work on mac's?
AFAIK - it does.
To upgrade you need to go one level at a time. 6.06 - 6.10 - 7.04 - 7.10.
It is best to just burn the gutsy PPC CD image and install in one go.

Where does the boot process stop?
Presumably you see the POST - then perhaps the grub stage 1.5 message blips by... then what?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Video Issues with Ubuntu 5.10 Live CD on iMac G3 Cold Coffee Linux - Newbie 4 06-24-2009 08:59 PM
Ubuntu 5.10 on iMac G3 E-chan Linux - Newbie 13 05-25-2008 12:32 AM
Ubuntu on an imac 24 futhamucka Linux - Newbie 3 09-04-2007 07:17 PM
ubuntu on imac lawdiv Ubuntu 7 05-02-2007 12:18 AM
installing ubuntu on imac g3 with 2 partions E.M.P99 Linux - Newbie 1 09-19-2006 08:31 PM


All times are GMT -5. The time now is 11:59 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration