LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 01-11-2004, 06:13 PM   #1
drknow
Member
 
Registered: Jan 2004
Distribution: Shrike (RH9)
Posts: 73

Rep: Reputation: 15
installing tls


I have to install tls to run amsn. How do i install it. The files I got (all in /root/tls1.4) were libtls.so, pkgindex.tcl, and tls.tcl. I am using redhat 9. How do I install them or move them to where they will work with amsn.
 
Old 01-11-2004, 06:54 PM   #2
Thymox
Senior Member
 
Registered: Apr 2001
Location: Cornwall, England.
Distribution: Debian + Ubuntu
Posts: 4,345

Rep: Reputation: 56
The tls.tcl file... set it to executable (chmod +x tls.tcl) and run it... see if that works out.
 
Old 01-11-2004, 06:56 PM   #3
drknow
Member
 
Registered: Jan 2004
Distribution: Shrike (RH9)
Posts: 73

Original Poster
Rep: Reputation: 15
How do i run it once ive set it to executable?
 
Old 01-11-2004, 07:04 PM   #4
Thymox
Senior Member
 
Registered: Apr 2001
Location: Cornwall, England.
Distribution: Debian + Ubuntu
Posts: 4,345

Rep: Reputation: 56
./tls.tcl

Do not forget the dot-forwardslash... that tells your console session to run the file tls.tcl from the current directory.
 
Old 03-14-2004, 06:00 PM   #5
DarkVenger
Member
 
Registered: Mar 2004
Location: VCO
Distribution: Arch
Posts: 42

Rep: Reputation: 25
Hello, when I try to make the ./configure for the tls instalation I get

Quote:
configure: error: /usr/local/openssl is not a valid directory
This resolves just by making this directory or I have to point configure to the real directory were I have openssl?? If the last option is the soluction, how do I do that?
 
Old 03-14-2004, 07:22 PM   #6
Komakino
Senior Member
 
Registered: Feb 2004
Location: Somerset, England
Distribution: Slackware 10.2, Slackware 10.0, Ubuntu 9.10
Posts: 1,938

Rep: Reputation: 53
You shouldn't need to install tls manually...when I ran aMsn (the installer version) for the first time it told me it needed it, asked me my architecture and then installed it for me.
 
Old 03-15-2004, 03:03 AM   #7
DarkVenger
Member
 
Registered: Mar 2004
Location: VCO
Distribution: Arch
Posts: 42

Rep: Reputation: 25
It work, I do not knew that aMsn could preform the instalation by it-self
 
Old 07-01-2006, 07:21 PM   #8
maxstradamus
LQ Newbie
 
Registered: Mar 2006
Distribution: FC5
Posts: 15

Rep: Reputation: 0
Quote:
configure: error: /usr/local/openssl is not a valid directory
is there any way to fix this manually?
 
Old 07-02-2006, 03:39 PM   #9
Komakino
Senior Member
 
Registered: Feb 2004
Location: Somerset, England
Distribution: Slackware 10.2, Slackware 10.0, Ubuntu 9.10
Posts: 1,938

Rep: Reputation: 53
do
Code:
./configure --help
and see if there is a command you can pass it to tell it the location of openssl
 
Old 07-03-2006, 11:46 AM   #10
maxstradamus
LQ Newbie
 
Registered: Mar 2006
Distribution: FC5
Posts: 15

Rep: Reputation: 0
Code:
Configuration:
  --cache-file=FILE       cache test results in FILE
  --help                  print this message
  --no-create             do not create output files
  --quiet, --silent       do not print `checking...' messages
  --version               print the version of autoconf that created configure
Directory and file names:
  --prefix=PREFIX         install architecture-independent files in PREFIX
                          [/usr/local]
  --exec-prefix=EPREFIX   install architecture-dependent files in EPREFIX
                          [same as prefix]
  --bindir=DIR            user executables in DIR [EPREFIX/bin]
  --sbindir=DIR           system admin executables in DIR [EPREFIX/sbin]
  --libexecdir=DIR        program executables in DIR [EPREFIX/libexec]
  --datadir=DIR           read-only architecture-independent data in DIR
                          [PREFIX/share]
  --sysconfdir=DIR        read-only single-machine data in DIR [PREFIX/etc]
  --sharedstatedir=DIR    modifiable architecture-independent data in DIR
                          [PREFIX/com]
  --localstatedir=DIR     modifiable single-machine data in DIR [PREFIX/var]
  --libdir=DIR            object code libraries in DIR [EPREFIX/lib]
  --includedir=DIR        C header files in DIR [PREFIX/include]
  --oldincludedir=DIR     C header files for non-gcc in DIR [/usr/include]
  --infodir=DIR           info documentation in DIR [PREFIX/info]
  --mandir=DIR            man documentation in DIR [PREFIX/man]
  --srcdir=DIR            find the sources in DIR [configure dir or ..]
  --program-prefix=PREFIX prepend PREFIX to installed program names
  --program-suffix=SUFFIX append SUFFIX to installed program names
  --program-transform-name=PROGRAM
                          run sed PROGRAM on installed program names
Host type:
  --build=BUILD           configure for building on BUILD [BUILD=HOST]
  --host=HOST             configure for HOST [guessed]
  --target=TARGET         configure for TARGET [TARGET=HOST]
Features and packages:
  --disable-FEATURE       do not include FEATURE (same as --enable-FEATURE=no)
  --enable-FEATURE[=ARG]  include FEATURE [ARG=yes]
  --with-PACKAGE[=ARG]    use PACKAGE [ARG=yes]
  --without-PACKAGE       do not use PACKAGE (same as --with-PACKAGE=no)
  --x-includes=DIR        X include files are in DIR
  --x-libraries=DIR       X library files are in DIR
--enable and --with options recognized:
  --enable-bsafe  Use RSA BSAFE SSL-C libraries instead of the default OpenSSL l ibraries.
  --with-ssl-dir=DIR  SSL root directory
  enable or disable patented code.  Default is patented code enabled.
  --enable-gcc            allow use of gcc if available [--disable-gcc]
  --with-gcclib         link with libgcc to resolve symbols in a gcc-built opens sl library
  --with-tcl              directory containing tcl configuration (tclConfig.sh)
  --enable-threads        build with threads
  --enable-shared         build and link with shared libraries [--enable-shared]
  --enable-symbols        build with debugging symbols [--disable-symbols]
this is what i get
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Proftpd and SSL/TLS mikeheggy Linux - Networking 3 12-19-2008 10:01 AM
Problem installing tls package for amsn TruthSeeker Linux - Software 9 11-06-2005 03:21 PM
a bug in tls.h cigarstub Programming 5 10-28-2005 09:13 AM
Sendmail TLS relay freealx Linux - Networking 1 03-12-2005 04:09 PM
SSL vs. TLS X11 Linux - Security 8 12-17-2002 03:39 PM


All times are GMT -5. The time now is 01:19 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration