LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   installing samba-3.0alpha24-1.i386.rpm into RedHat 8 and RedHat 9 (http://www.linuxquestions.org/questions/linux-newbie-8/installing-samba-3-0alpha24-1-i386-rpm-into-redhat-8-and-redhat-9-a-60123/)

Linh 05-16-2003 10:45 AM

installing samba-3.0alpha24-1.i386.rpm into RedHat 8 and RedHat 9
 
I installed samba-3.0alpha24-1.i386.rpm into RedHat 8 and RedHat 9 using thew command "rpm -i samba-3.0alpha24-1.i386.rpm", and I gor an error message

warning: samba-3.0alpha24-1.i386.rpm : V3 DSA signature:
NOKEY, key ID 2f87af6f
error: Failed depencencies:
perl(Net::LDAP::LDIF) is needed by
samba-3.0alpha24-1.i386.rpm.

I even try the commans "rpm --nodeps samba-3.0alpha24-1.i386.rpm", but I got the same error message. How can I fix this problem ?

benzo 06-03-2003 07:08 PM

Samba-3.0
 
Linh,

Have you had any luck with this? I'm in the same boat. I just started experimenting with 3.0 with rh8 and 9 and get the same perl dependency error.

I re-ran setup and installed every perl option that I can see, but still the same result. rpm -qa |grep perl displays perl to be there along with other perl programs.

Hope to hear from you or anyone else.

Cheers

Benzo

mhearn 06-04-2003 05:50 AM

SAMBA comes with Red Hat, you don't need to install it yourself.

For future reference, you can resolve perl dependancy errors by doing this:

perl -MCPAN -e 'shell'
(you get a command prompt)
install Whatever::Module::You::Need
exit

So in this case you want Net::LDAP::LDIF. But don't do this, as you already have Samba on the CDs


All times are GMT -5. The time now is 12:35 AM.