LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 10-20-2003, 06:52 PM   #1
crispy
LQ Newbie
 
Registered: Oct 2003
Posts: 1

Rep: Reputation: 0
installing pkg-config...where did it go?!?!?


hey,

First off, i have to say that this is like my second day using linux. I just recently installed suse, and im trying to get a feel for it. Someone told me I should get gaim, cuz then i can have msn/icq/etc etc etc....however...i never knew that it was going to be such a complex task!!

So i download gaim, untar it, then do ./configure, and i get the error saying that i have to install pkgconfig and glib 2.0........so i downloaded pkgconfig and installed it (i think it did). But when i download glib 2.2.3, and do ./configure, i get this:

checking for special C compiler options needed for large files... no
checking for _FILE_OFFSET_BITS value needed for large files... 64
checking for _LARGE_FILES value needed for large files... no
checking for pkg-config... no
configure: error: *** pkg-config not found. See *wont let me post the website....*

but then when i try to run the ./configure in the gaim directory again, i get an error saying that i only need to install glib:

checking for socklen_t... yes
checking for pkg-config... /usr/local/bin/pkg-config
checking for GLIB - version >= 2.0.0... no
*** Could not run GLIB test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GLIB is incorrectly installed.
configure: error:
*** GLib 2.0 is required to build Gaim; please make sure you have the GLib
*** development headers installed. The latest version of GLib is
*** always available at *wont let me post the website...*.

Can anyone help me out here?? possibly tell me what i am doing wrong and how i could go about fixing it!!

Thanks.
 
Old 10-23-2003, 09:45 AM   #2
tyccea
Member
 
Registered: Aug 2003
Location: atlanta, ga
Distribution: SuSE 8.2
Posts: 90

Rep: Reputation: 15
ftp://rpmfind.net/linux/SuSE-Linux/i....8-42.i586.rpm
ftp://rpmfind.net/linux/SuSE-Linux/i....0-20.i586.rpm
That's a link to the rpms for SuSE 8.2 (I bought 8.2 a while back). Just use
'rpm -Uvh blah_blah_blah.rpm' (without quotes) to install it.
You can always use a feature at http://rpmfind.net to "Search By Distribution", to list all RPMs for SuSE 8.2.
apt-get is available for SuSE 8.2 as well.

Last edited by tyccea; 10-23-2003 at 09:52 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
pkg-config and glib: Uninstalling Old and Installing New CooManChu Linux - Software 6 09-06-2005 03:35 PM
Problem installing Bluefish. pkg-config missing Rodotheos Linux - Software 5 04-15-2005 04:54 AM
installing pkg-config minm Linux - Software 1 08-23-2004 11:54 AM
Installing Glib, ATK, GTK, Pkg Config, and Pango! LinuZ Linux - Newbie 9 10-26-2003 02:58 PM
pkg-config TraCe66 Linux - Newbie 1 07-01-2003 02:56 PM


All times are GMT -5. The time now is 11:38 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration