LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-03-2005, 08:52 AM   #1
myd
LQ Newbie
 
Registered: Apr 2005
Posts: 6

Rep: Reputation: 0
Installing phpBB with MySQL 5


Hi all

I'm having problems installing a forum in my server... I've search a lot, but i can't find an article tha solve my problem.

I have MySQL-server-5.0.3 installed with php4.3.11 on a Fedora Core 3 machine, when i try to install the phpBB forum it give me a message saying "The PHP configuration on your server doesn't support the database type that you chose". I'd try it with MySQL 3.x and MySQL 4.x (the most logical), with the others DBs the error is the same.

Anyone knows how to solve this?

Thanks in advance.
 
Old 05-03-2005, 09:30 AM   #2
Spudley
Member
 
Registered: Mar 2003
Location: Berkshire, England.
Distribution: SuSE 10.0
Posts: 299

Rep: Reputation: 32
MySQL v5 is brand new (literally, it was released just in the last few weeks), so I'm not suprised that phpBB doesn't support it yet.

It would probably work fine; it's just that phpBB is checking and finding a version it doesn't know about, and preventing you from using it.

MySQL 5 has a lot of new features (some of them have been long-awaited), but phpBB won't use any of them, so my first suggestion would be to switch to MySQL v4 if you can.

If you can't (or don't want to) downgrade your database, your best bet would be to ask on the forums at www.phpBB.com whether they're planning to release an update to support v5 (I assume they will do fairly soon). And there's bound to be other people there with the same problem, so they may have a solution already.

Alternatively, if you know enough about PHP, you could try tweaking the phpBB code to accept MySQL v5 as if it was v4, as it should all still work the same once you've got past the version check. But that's something I'd prefer to avoid, at least until you've spoken to the guys at phpbb.com.

Hope that helps.
 
Old 05-20-2005, 02:30 PM   #3
Muppet1856
LQ Newbie
 
Registered: May 2005
Posts: 1

Rep: Reputation: 0
PHP Problems x 2

I have a similar problem (In fact, I've seen postings all over google...) I'm running:

PHP 4.3.11
Apache 2.052
MySQL 4.1.11
phpBB 2.0.15

The message reads the exact same....
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with MySQL when installing phpBB dranobob Linux - Newbie 2 09-06-2005 10:11 AM
phpbb won't work with mysql 4.x and php 4.x Gsee Linux - Software 2 07-27-2005 10:22 AM
phpBB and MySQL The_Messiah Linux - Software 5 04-18-2005 02:34 PM
phpBB and MySQL problem (please HELP!) domen Linux - Software 6 06-27-2004 09:31 AM
Creat MySQL database for phpBB Pug405 Linux - Software 9 05-11-2004 02:24 PM


All times are GMT -5. The time now is 03:44 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration