LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-19-2009, 01:35 PM   #1
lucass
LQ Newbie
 
Registered: Oct 2009
Posts: 3

Rep: Reputation: 0
Installing OpenSSH-5.2 Red Hat Enterprise 5 X86_64


Hi,

I have been trying to update my openssh version in my Red Hat Enterprise 5 server.
Currently I have version 4.3p2, which is the newest version on Red Hat Network.
I found the RMPs for openssh 5.2:

openssh-askpass-5.2p1-2.el5.x86_64.rpm
openssh-5.2p1-2.el5.x86_64.rpm
openssh-clients-5.2p1-2.el5.x86_64.rpm
openssh-server-5.2p1-2.el5.x86_64.rpm

However, when I try to install those, installation fails due to missing dependencies. I could not satisfy this dependencies using yum.

Is there an easier way of installing openssh? I need any version newer than 4.4, a serious security update was implemented in this version..

Thank you.
 
Old 10-19-2009, 01:40 PM   #2
anomie
Senior Member
 
Registered: Nov 2004
Location: Texas
Distribution: RHEL, Scientific Linux, Debian, Fedora
Posts: 3,935
Blog Entries: 5

Rep: Reputation: Disabled
Where did you find those rpms? Also, which openssh security update are you referring to? Red Hat backports security fixes for the versions it supports.
 
Old 10-19-2009, 01:48 PM   #3
lucass
LQ Newbie
 
Registered: Oct 2009
Posts: 3

Original Poster
Rep: Reputation: 0
This RPMs were downloaded from rpmfind.net.
It seems that openssh version previously to 4.4 have a security issue called "OpenSSH Signal Handler Denial of Service Vulnerability". This problem could allow remote attackers to cause a denial of service (connection slot exhaustion) via multiple login attempts.
 
Old 10-19-2009, 02:06 PM   #4
anomie
Senior Member
 
Registered: Nov 2004
Location: Texas
Distribution: RHEL, Scientific Linux, Debian, Fedora
Posts: 3,935
Blog Entries: 5

Rep: Reputation: Disabled
It's almost certainly been patched by Red Hat. They may not do a major/minor version upgrade, but they will backport such fixes. You might contact RH support (or review errata) to confirm.
 
Old 10-19-2009, 02:24 PM   #5
lucass
LQ Newbie
 
Registered: Oct 2009
Posts: 3

Original Poster
Rep: Reputation: 0
It seems to be pathched. Anyway I will get in touch with RH to confirm it.
Thank you
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Rumours of critical vulnerability in OpenSSH in Red Hat Enterprise Linux LXer Syndicated Linux News 0 07-09-2009 12:20 AM
ipm timed out error on Red Hat 2.6.9-67.0.22.ELsmp #1 SMP x86_64 x86_64 x86_64 GNU/L bellnarm Linux - Newbie 0 07-07-2009 05:36 PM
Is Posible Install Enterprise Red Hat 4.6 (X86_64) on Itanium (ia64)? fsoteloh Linux - Software 3 12-31-2008 01:35 PM
Installing Red Hat Enterprise 4 shane200_ Red Hat 2 01-02-2007 11:58 AM


All times are GMT -5. The time now is 04:32 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration