LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-07-2012, 11:27 AM   #1
roman143
LQ Newbie
 
Registered: Feb 2012
Location: Netherlands
Distribution: Centos
Posts: 1

Rep: Reputation: Disabled
Installing Old Version of Apache2


Hello,

I am windows guy and manage the VMWare Infrastructure(since it is GUI) so my linux knowledge is zero. So please do not mind if i am asking some very basic question

I need to install Apache2.2.21 on CentOS 5.7 with MySQL 5.0.77 (As it is requirement of our PHP Programmers for some project, Dont know why they want specifically this version)

I tried installing Apache-2.2.21. I keep getting error

make[2]: Entering directory '/root/httpd-2.2.21/srclib/pcre'
Makefile:7: /build/ltlib.mk: No such file or directory
make[2]: ***No rule to make target '/build/ltlib.mk'. Stop.
make[2]: Leaving directory '/root/httpd-2.2.21/srclib/pcre'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/root/httpd-2.2.21/srclib'
make: ***[all-recursive] Error 1

I am not really sure what is going wrong here, I have installed the openssl, srclib but i am still getting this error. Can anyone help please ?
 
Old 02-07-2012, 12:10 PM   #2
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,518

Rep: Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501
Hi and welcome to LQ,

You should post the ./configure options you've used in order to build apache.
Also openssl is installed in your system. All you need to do is to install its development libraries. For this you can run:
Code:
yum install openssl-devel
BTW since you're trying to compile apache from source, try httpd-2.2.22 that fixes some bugs of 2.2.21

Regards
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Switching PHP version on Apache2 dashrantic Linux - Server 3 03-25-2010 02:34 AM
Yum is installing an old version of subversion -- how can I get the latest version? dhjdhj Linux - Newbie 6 06-18-2009 02:34 AM
Update Apache2 to the latest version on Debian. elvisious Linux - Software 1 06-12-2009 07:59 PM
uninstalling old software version and installing the new version RottenMutt Linux - Newbie 4 07-11-2003 12:32 AM
Installing Apache2.0.44 webee Linux - General 2 01-23-2003 04:50 PM


All times are GMT -5. The time now is 05:10 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration