LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-11-2012, 02:33 AM   #61
eepunk
LQ Newbie
 
Registered: Jun 2012
Posts: 2

Rep: Reputation: Disabled

@roelfrenkema - agreed, change the accounts. This thing is taxed enough just running a desktop without being zombied into someones cash farm.

I tried both the Ubuntu and Debian instructions from http://www.cnx-software.com/2012/04/...a10-based-stb/

Couldn't get any better than a black screen, responded to Ctrl_Alt_del and nothing else.

So I gave up and decided to tailor the existing image.
  • Got rid of Weng and Ubuntu accounts, reset the Root password. Created a new account.
  • Dropped gwm and Gnome, replaced them with lxde and Slim.
  • Dropped Firefox, replaced with Midori.
  • Dumped network-manager-gnome and installed WICD.

It's more usable but still not exactly what I would call good.

Until the Mali drivers mature this is gonna stay a toy.

E.E.
 
Old 06-11-2012, 02:40 AM   #62
michaelfisk
Member
 
Registered: May 2012
Posts: 32

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by eepunk View Post
@roelfrenkema - agreed, change the accounts. This thing is taxed enough just running a desktop without being zombied into someones cash farm.

I tried both the Ubuntu and Debian instructions from http://www.cnx-software.com/2012/04/...a10-based-stb/

Couldn't get any better than a black screen, responded to Ctrl_Alt_del and nothing else.

So I gave up and decided to tailor the existing image.
  • Got rid of Weng and Ubuntu accounts, reset the Root password. Created a new account.
  • Dropped gwm and Gnome, replaced them with lxde and Slim.
  • Dropped Firefox, replaced with Midori.
  • Dumped network-manager-gnome and installed WICD.

It's more usable but still not exactly what I would call good.

Until the Mali drivers mature this is gonna stay a toy.

E.E.
We're you able to try a Bluetooth USB? Also I've been trying to install Dropbox on it today with no luck, keep getting errors. Anybody else tried this yet?
 
Old 06-11-2012, 04:12 AM   #63
ebina1
LQ Newbie
 
Registered: Jun 2012
Posts: 7

Rep: Reputation: Disabled
@davey39 Those instructions just use the kernel from the mele A1000 image. I want to build my own kernel (uImage).

I tried the instructions here:
http://rhombus-tech.net/allwinner_a1...Code_for_Mele/

Which should be how they built the kernel for that mele A1000 image, but the instructions seem to be missing something, the resulting kernel doesn't boot.
 
Old 06-11-2012, 05:37 AM   #64
davy39
LQ Newbie
 
Registered: Jun 2012
Posts: 13

Rep: Reputation: Disabled
This could also be a usefull link to keep informed of the evolutions related to allwinner and Mali drivers: http://www.j1nx.nl/
 
Old 06-11-2012, 10:12 AM   #65
roelfrenkema
LQ Newbie
 
Registered: Jun 2012
Posts: 5

Rep: Reputation: Disabled
Quote:
Originally Posted by eepunk View Post
It's more usable but still not exactly what I would call good.

Until the Mali drivers mature this is gonna stay a toy.

E.E.
That depends on what you need the Mali for, I run it mostly as a home server and am quite happy with it without the GPU for now. Also you might have a look at http://www.cnx-software.com/2012/04/...a10-based-stb/

for debian instructions :-D

Last edited by roelfrenkema; 06-11-2012 at 10:44 AM.
 
Old 06-11-2012, 03:06 PM   #66
ALWAYZBLESS
LQ Newbie
 
Registered: Jun 2012
Posts: 19

Rep: Reputation: Disabled
I wish someone would create a Lubuntu img for this thing, or any other light weight distro for that matter I dont ever expect this device to run any version of ubuntu properly, especially after seeing the videos of this thing in action
 
Old 06-11-2012, 03:32 PM   #67
davy39
LQ Newbie
 
Registered: Jun 2012
Posts: 13

Rep: Reputation: Disabled
Follow some simple commands to write a puppylinux (light weight distro) for allwinner (initially mele 1000) in a SD card :

Code:
sudo apt-get install parted kpartx
wget https://raw.github.com/cnxsoft/a10-tools/master/makeSD.sh
wget http://distro.ibiblio.org/quirky/arm/releases/alpha/mele-sd-4gb-lui-5.2.90.img.xz
7z x mele-sd-4gb-lui-5.2.90.img.xz
chmod a+x makeSD.sh
./makeSD.sh /dev/sdX mele-sd-4gb-lui-5.2.90.img
Replace X by the letter corresponding to your SD card (type fdisk -l to know it).


Let us know if it works on MK802.

Read more here.

edit: sorry the linkto makeSD.sh script was wrong. I've corrected it.

Last edited by davy39; 06-12-2012 at 05:59 AM.
 
Old 06-11-2012, 09:48 PM   #68
ALWAYZBLESS
LQ Newbie
 
Registered: Jun 2012
Posts: 19

Rep: Reputation: Disabled
Quote:
Originally Posted by davy39 View Post
Follow some simple commands to write a puppylinux (light weight distro) for allwinner (initially mele 1000) in a SD card :

Code:
sudo apt-get install parted kpartx
wget https://github.com/cnxsoft/a10-tools/blob/master/makeSD.sh
wget http://distro.ibiblio.org/quirky/arm/releases/alpha/mele-sd-4gb-lui-5.2.90.img.xz
7z x mele-sd-4gb-lui-5.2.90.img.xz
chmod a+x makeSD.sh
./makeSD.sh /dev/sdX mele-sd-4gb-lui-5.2.90.img
Replace X by the letter corresponding to your SD card (type fdisk -l to know it).

Let us know if it works on MK802.

Read more here.
./makeSD.sh: line 4: syntax error near unexpected token `newline'
./makeSD.sh: line 4: `<!DOCTYPE html>'
 
Old 06-11-2012, 09:50 PM   #69
EricBetts
LQ Newbie
 
Registered: Jun 2012
Posts: 18

Rep: Reputation: Disabled
try

Code:
wget https://raw.github.com/cnxsoft/a10-tools/master/makeSD.sh

Last edited by EricBetts; 06-11-2012 at 09:55 PM.
 
Old 06-11-2012, 10:02 PM   #70
ALWAYZBLESS
LQ Newbie
 
Registered: Jun 2012
Posts: 19

Rep: Reputation: Disabled
Quote:
Originally Posted by EricBetts View Post
try

Code:
wget https://raw.github.com/cnxsoft/a10-tools/master/makeSD.sh
Getting permission denied.. "./makeSD.sh.2 /dev/sdb mele-sd-4gb-lui-5.2.90.img" <-- thats what I entered, and I am logged in as root

Last edited by ALWAYZBLESS; 06-11-2012 at 10:03 PM.
 
Old 06-11-2012, 10:03 PM   #71
EricBetts
LQ Newbie
 
Registered: Jun 2012
Posts: 18

Rep: Reputation: Disabled
try

Code:
sudo ./makeSD.sh.2 /dev/sdb mele-sd-4gb-lui-5.2.90.img
 
Old 06-11-2012, 10:08 PM   #72
ALWAYZBLESS
LQ Newbie
 
Registered: Jun 2012
Posts: 19

Rep: Reputation: Disabled
Quote:
Originally Posted by EricBetts View Post
try

Code:
sudo ./makeSD.sh.2 /dev/sdb mele-sd-4gb-lui-5.2.90.img
cp: cannot stat `mntIMGvfat/*': No such file or directory
Failed to copy VFAT partition data to SD Card
./makeSD.sh: 145: ./makeSD.sh: goto: not found
Copy rootfs partition files to SD Card
cp: cannot stat `mntIMGrootfs/*': No such file or directory
Failed to copy rootfs partition data to SD Card
./makeSD.sh: 151: ./makeSD.sh: goto: not found
Umount VFAT Partition (IMG)
umount: mntIMGvfat: not mounted
Failed to umount VFAT Partition (IMG))
Umount EXT4 Partition (IMG)
umount: mntIMGrootfs: not mounted
Failed to umount EXT4 Partition (IMG))
loop deleted : /dev/loop1
Umount VFAT Partition (SD)
Delete mntSDvfat
Umount EXT4 Partition (SD)
Delete mntSDrootfs

Last edited by ALWAYZBLESS; 06-11-2012 at 10:23 PM.
 
Old 06-11-2012, 10:16 PM   #73
ALWAYZBLESS
LQ Newbie
 
Registered: Jun 2012
Posts: 19

Rep: Reputation: Disabled
^^^ thats what im getting now, im probably doing something wrong though

Last edited by ALWAYZBLESS; 06-11-2012 at 10:35 PM.
 
Old 06-12-2012, 06:45 AM   #74
davy39
LQ Newbie
 
Registered: Jun 2012
Posts: 13

Rep: Reputation: Disabled
Hi,
Sorry for the bad link to makeSD.sh...
So even if I have no hardware to test it, I've tryed to follow the instruction with a USB key.

I've done exactly this :
Code:
sudo apt-get install parted kpartx
wget https://raw.github.com/cnxsoft/a10-tools/master/makeSD.sh
wget http://distro.ibiblio.org/quirky/arm/releases/alpha/mele-sd-4gb-lui-5.2.90.img.xz
7z x mele-sd-4gb-lui-5.2.90.img.xz
chmod a+x makeSD.sh
./makeSD.sh /dev/sdX mele-sd-4gb-lui-5.2.90.img
and get same kind of message as your.

I've sent a message to cnxsoft to get help.
 
Old 06-12-2012, 07:08 AM   #75
davy39
LQ Newbie
 
Registered: Jun 2012
Posts: 13

Rep: Reputation: Disabled
Hi again !

I've found the problem of this script and the authors modified github. So try again ! If you still have mele-sd-4gb-lui-5.2.90.img.xz decompressed, just do :
Code:
rm makeSD*
wget https://raw.github.com/cnxsoft/a10-tools/master/makeSD.sh
./makeSD.sh /dev/sdb mele-sd-4gb-lui-5.2.90.img
PS : the problem was in Line 77:
Quote:
loop_device=`sudo kpartx -l ../$2 | grep p1 | awk '{ print $5 }' | cut -c10`
should be
Quote:
loop_device=`sudo kpartx -l $2 | grep p1 | awk '{ print $5 }' | cut -c10`

Last edited by davy39; 06-12-2012 at 08:29 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: $74 Android PC MK802 To Compete With Cotton Candy LXer Syndicated Linux News 0 05-18-2012 07:51 PM
installing aurora linux in sun blade 150----not installing? kingston Linux - General 1 01-14-2010 08:10 AM
Toshiba Satellite 110CS installing pdf reader, installing linux nappy501 Linux - Laptop and Netbook 3 10-11-2008 11:45 AM
installing default packages after installing linux ninux Linux - Newbie 5 09-12-2007 08:00 AM
Installing Windows after installing LINUX brads@kwlink.com Linux - General 4 01-08-2006 11:03 AM


All times are GMT -5. The time now is 03:57 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration