LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-27-2007, 04:45 PM   #1
trainee
Member
 
Registered: Dec 2004
Distribution: Slackware
Posts: 142

Rep: Reputation: 16
Installing KDE 3.5.6 (manually) could not locate Qt


I am installing KDE manually using the instruction here.

http://docs.kde.org/development/en/k...q/install.html

Before doing this, I have installed Qt (version 3.3.7) as required by KDE that version of Qt >3.3 and < 4.0.

Then, I unpacked the arts-1.5.6.tar.bz2 (as the website said, this is the first package that need to be installed.)
But when I changedir and type ./configure, after going smoothly for a little bit, it thrown me out, saying that it cannot locate the Qt.
I even tried
./configure -with-qt=$QTDIR
with QTDIR is the directory where Qt was installed to. But no luck.
Would you please tell me what did I do wrong? Or am I missing something?

Thanks


P.S. the distro I am using is Zenwalk 4.2

Last edited by trainee; 01-27-2007 at 04:47 PM.
 
Old 01-27-2007, 04:51 PM   #2
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,568

Rep: Reputation: 164Reputation: 164
Have you installed Qt from package or from source?

If from source, you probably need to point the configure script to the correct Qt location. If I remember correctly it's --with-qt-dir

If from package, you need to install both qt qt-devel (or qt3 and qt3-devel).
 
Old 01-27-2007, 05:03 PM   #3
trainee
Member
 
Registered: Dec 2004
Distribution: Slackware
Posts: 142

Original Poster
Rep: Reputation: 16
I installed Qt from source.
And, what is the correct "Qt location".

In my case, I put it in /usr/src/qt-versrion and make a symlink to /usr/loca/qt as recommed by the INSTALL file of the Qt. When I installed Qt, I did everything as default as I was told in the INSTALL file.
 
Old 01-28-2007, 02:14 PM   #4
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,568

Rep: Reputation: 164Reputation: 164
Before compiling arts and the other packages you need to set up QT_DIR variable.
export QT_DIR = /usr/local/qt
and then configure in arts should work (in the same terminal window).
 
Old 01-28-2007, 02:33 PM   #5
trainee
Member
 
Registered: Dec 2004
Distribution: Slackware
Posts: 142

Original Poster
Rep: Reputation: 16
Thank you Mara. I'll try it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how to configure updatedb to update locate database manually septanla Linux - General 4 12-22-2010 03:05 PM
cdroms no longer mount manually OR in KDE cdale77 Slackware 7 12-14-2006 11:17 PM
Question about Manually Installing KDE cubdukat Linux - Desktop 4 10-29-2006 04:37 PM
Manually Installing Grub jan1024188 Fedora 3 08-16-2006 04:44 PM
How to manually modify the content of the K menu in KDE? pujolasdf Linux - Software 2 03-27-2005 12:26 PM


All times are GMT -5. The time now is 06:31 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration