LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-23-2004, 04:26 AM   #1
r4f
LQ Newbie
 
Registered: Sep 2004
Location: Denmark
Distribution: Ultima Linux
Posts: 11

Rep: Reputation: 0
Unhappy installing is gtk+-2.0 is a mess! pangox and libpng prob.


Okay, I've got Fedora Core 2. and I want to install gtk+-2.0.
I've installed atk, pango-1.5.2 and jpeg libs, and TIFF libs.
On my computer I also have libpng, but ./configure can't find it! So I try do --without-libpng, then configure stops and says:

checking for freetype-config... /usr/local/bin/freetype-config
checking for FT_New_Face in -lfreetype... yes
checking For sufficiently new FreeType (at least 2.0.1)... no
configure: errorangox Pango backend is required for x11 target



What do I do!?!?!? It's really a mess!
I've got freetype 2.1.7! And both freetype and pango are installed with rpm.

Can anyone help!? I'm getting really tired of this. I've been working on installation of gtk+-2.0 for hours!
 
Old 09-23-2004, 07:58 AM   #2
mhearn
LQ Guru
 
Registered: Nov 2002
Location: Durham, England
Distribution: Fedora Core 4
Posts: 1,565

Rep: Reputation: 47
If you have a default setup of Fedora Core 2 you already have GTK 2.4 installed. What do you think is drawing all your windows?

What you actually need is gtk2-devel. To get this go to Add/Remove Packages and install the developer tools packages (x11/gnome).
 
Old 09-23-2004, 12:21 PM   #3
r4f
LQ Newbie
 
Registered: Sep 2004
Location: Denmark
Distribution: Ultima Linux
Posts: 11

Original Poster
Rep: Reputation: 0
okay the reasen I wanted Gtk+

The reason that I wanted to install gtk+-2.0 is because I want to install ettercap-ng-0.7.0, and it says that it can't find gtk+-2.0... and that I should pkgconfig to gtk+-2.0.pc, the problem is that I don't have that file on my computer.... so I thought it wasn't installed... anyway, I'll try to install what you said in add/remove...

r4f
 
Old 09-25-2004, 12:02 PM   #4
mhearn
LQ Guru
 
Registered: Nov 2002
Location: Durham, England
Distribution: Fedora Core 4
Posts: 1,565

Rep: Reputation: 47
Oh, by the way in Fedora Core 2 you can type "yum install ettercap" as root to get it. I'd try that first.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
libpng and libpng-devel missing in mplayer configure mmarkvillanueva Linux - Software 2 11-29-2005 10:40 PM
Updated libpng, now existing GTK prog won't start anymore - Rh9 rylan76 Linux - Software 1 05-12-2005 01:06 PM
PROB: Mandrake or WinXP or Fedora mess up kevingpo Linux - Newbie 4 12-13-2004 11:41 AM
MPlayer install problems with libpng & libpng-devel Trey2501 Linux - Newbie 18 03-05-2004 11:24 PM
GTK installation for RH9 its a mess!!!!!!!!!!! cantrooper Linux - Software 4 08-15-2003 08:46 PM


All times are GMT -5. The time now is 01:44 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration