LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-11-2004, 09:01 AM   #1
gblue
LQ Newbie
 
Registered: Sep 2003
Location: Kinston, Alabama
Distribution: Redhat 5, 6 7 8 and 9.0 SuSe 9.0
Posts: 8

Rep: Reputation: 0
Installing ImageMagick


I am trying to update my ImageMagic on redhat 9.0. Currently I have version ImageMagick-5.4.7-10 Installed but I need a newer version.

I downloaded ImageMagick-5.5.7-10.i386.rpm but when I try to install it I get the following error.

rpm -Uvh ImageMagick-5.5.7-10.i386.rpm
error: Failed dependencies:
libMagick.so.5 is needed by (installed) ImageMagick-c++-5.4.7-10
libMagick.so.5 is needed by (installed) ImageMagick-perl-5.4.7-10
ImageMagick = 5.4.7-10 is needed by (installed) ImageMagick-c++-5.4.7-10
ImageMagick = 5.4.7-10 is needed by (installed) ImageMagick-devel-5.4.7-10
ImageMagick = 5.4.7 is needed by (installed) ImageMagick-c++-devel-5.4.7-10
ImageMagick = 5.4.7-10 is needed by (installed) ImageMagick-perl-5.4.7-10


What am I doing wrong ?

Thanks

Gill Blue
 
Old 01-11-2004, 09:46 AM   #2
wapcaplet
LQ Guru
 
Registered: Feb 2003
Location: Colorado Springs, CO
Distribution: Gentoo
Posts: 2,018

Rep: Reputation: 48
It looks like a lot of the stuff you already have installed needs the 5.4.7-10 version of ImageMagick. If you want to upgrade it, you will probably have to upgrade all the rest of the things it mentions also (ImageMagick-c++-devel and so on). It's probably easier to just stick with the old version unless you really need the newer one
 
Old 01-11-2004, 09:53 AM   #3
gblue
LQ Newbie
 
Registered: Sep 2003
Location: Kinston, Alabama
Distribution: Redhat 5, 6 7 8 and 9.0 SuSe 9.0
Posts: 8

Original Poster
Rep: Reputation: 0
Thanks,

Well I tried the other files as well c++ etc with the same basic errors, I do need the newer version, as the photo program I am using will not allow me to use insert watermarks on the photo's .. I guess I could try GD2 instead of IM..

Thanks

Gill Blue

Quote:
Originally posted by wapcaplet
It looks like a lot of the stuff you already have installed needs the 5.4.7-10 version of ImageMagick. If you want to upgrade it, you will probably have to upgrade all the rest of the things it mentions also (ImageMagick-c++-devel and so on). It's probably easier to just stick with the old version unless you really need the newer one
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to install ImageMagick after installing RHEL? Swakoo Linux - Newbie 2 04-27-2005 10:51 PM
ImageMagick without X jeru Debian 4 08-21-2004 07:29 PM
help installing ImageMagick w/out xwin Javelin Red Hat 2 02-08-2004 01:07 PM
ImageMagick jasonmcneil0 Linux - Software 2 11-14-2003 06:49 PM
ImageMagick! ifm Linux - Software 0 06-20-2002 09:13 PM


All times are GMT -5. The time now is 08:43 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration