LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 11-09-2002, 04:59 PM   #1
AldebaranDanu
LQ Newbie
 
Registered: Nov 2002
Distribution: Red Hat 8.0
Posts: 15

Rep: Reputation: 0
Installing Development Stuff in Redhat 8.0 Problems.


I didn't install the development tools (things like gcc, etc....) when I installed because I didn't know how many programs out there would require my knowledge of compiling in Linux in order to even use them.

So, I insert my Red Hat 8.0 CD, autorun it, then select to add the development tools.... but it tells me that in order to do it, I need to have the following RPM installed:
krb5-libs = 1.2.5-6
And that it's required by:
krb5-devel

So, I did some searching on the web, and found the RPM (here: http://at.rpmfind.net/opsys/linux/RP....5-6.i386.html). So, I download it, double-click it, and it tells me that a newer version is already installed.

So, what am I supposed to do?

Any help is appreciated.
Thank you,
AldebaranDanu

Last edited by AldebaranDanu; 11-09-2002 at 05:05 PM.
 
Old 11-09-2002, 05:36 PM   #2
Bert
Senior Member
 
Registered: Jul 2001
Location: 406292E 290755N
Distribution: GNU/Linux Slackware 8.1, Redhat 8.0, LFS 4.0
Posts: 1,004

Rep: Reputation: 46
What are the development tools you're trying to install?

You install an rpm like this:

rpm -i <packagename>
 
Old 11-09-2002, 05:47 PM   #3
AldebaranDanu
LQ Newbie
 
Registered: Nov 2002
Distribution: Red Hat 8.0
Posts: 15

Original Poster
Rep: Reputation: 0
The development tools.

Like GCC, make, stuff like that. So that I can compile source that I download so I can use more programs.

In my Add/Remove Packages list, they are all under a heading called Development Tools.
 
Old 12-05-2002, 12:24 AM   #4
granitepoint
LQ Newbie
 
Registered: Dec 2002
Posts: 4

Rep: Reputation: 0
I got the same problem. Cannot install any of the development tools with the package manager in RH8 - Did you ever find a resolution for this?
 
Old 12-05-2002, 05:24 AM   #5
Bert
Senior Member
 
Registered: Jul 2001
Location: 406292E 290755N
Distribution: GNU/Linux Slackware 8.1, Redhat 8.0, LFS 4.0
Posts: 1,004

Rep: Reputation: 46
RPMs are convenient, but blind. They don't even realise when there are other versions of themselves installed. A good method I've found is to reinstall the original version, or to remove it and reinstall it:

rpm -U --force <package>

seems to work much of the time.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems installing Development Packages StarDragon Fedora 5 05-30-2005 10:15 PM
When installing new stuff in suse 9.1, do you uninstall old stuff first? randon Suse/Novell 1 12-25-2004 05:37 PM
problems installing redhat 9; usb problems (I think) nhelseth Linux - Newbie 2 04-27-2004 05:17 PM
Problems installing RedHat Database 2.1 on Redhat Linux 9 bkimelman Linux - Software 0 10-18-2003 02:32 PM
Problems installing X Development packages Nylex Linux - Software 2 07-08-2003 11:17 AM


All times are GMT -5. The time now is 10:58 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration