LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-16-2005, 12:24 PM   #1
NightKids
Member
 
Registered: Jan 2004
Distribution: Ubuntu Dapper
Posts: 48

Rep: Reputation: 15
installing cdemu


the install says i need the source of the current running kernel by typing:

Code:
you need the source of your current running kernel.
/lib/modules/$(shell uname -r)/build/include needs to point at it.
but i get

Code:
/lib/modules/2.6.8.1-12mdksmp/build/include
bash: /lib/modules/2.6.8.1-12mdksmp/build/include: No such file or directory
i think i already go the kernel source becuz i tried to install a video card driver and sound card driver once and it needed kernel sources
 
Old 06-16-2005, 12:59 PM   #2
perfect_circle
Senior Member
 
Registered: Oct 2004
Location: Athens, Greece
Distribution: Slackware, arch
Posts: 1,783

Rep: Reputation: 52
You just need to create a soft link named build in the /lib/modules/<kernel-version> pointing to the kernel sourse directory. In my case:
Code:
skalkoto@darkstar:/lib/modules/2.4.31$ ls -l build
lrwxrwxrwx  1 root root 21 2005-06-11 19:37 build -> /usr/src/linux-2.4.31/
skalkoto@darkstar:/lib/modules/2.4.31$
so go to /lib/modules/<kernel_version>
and type
Code:
ln -s /usr/src/linux-<kernelversion> build
if your kernel source is located in the default path.
 
Old 06-16-2005, 02:12 PM   #3
NightKids
Member
 
Registered: Jan 2004
Distribution: Ubuntu Dapper
Posts: 48

Original Poster
Rep: Reputation: 15
ok i did that, and then tried to reinstall cdemu, after make and make install, it says to do 'modprobe cdemu'
and i got:
Code:
FATAL: Error inserting cdemu (/lib/modules/2.6.8.1-12mdksmp/misc/cdemu.ko): Invalid module format
so if i try to mount with 'cdemu 0 file.cue' it says:
Code:
[Errno 6] No such device or address: '/dev/cdemu/0'
and if i try with mount-iso-image-0.9, right-clicking the file, go to actions, then Manage CUE/BIN, then mount, it says:
Code:
ERROR: Could not mount "/home/icet/Desktop/Mount-ISO (file.cue)"! Check your system settings.
 
Old 06-19-2005, 10:12 AM   #4
NightKids
Member
 
Registered: Jan 2004
Distribution: Ubuntu Dapper
Posts: 48

Original Poster
Rep: Reputation: 15
would anyone know how to make it work please?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
kernel woes...installing cdemu StrangeBiscuit Linux - Software 3 05-16-2005 11:05 PM
cdemu how to use megadeth Linux - Software 1 05-02-2005 07:53 AM
question about installing CDemu minm Linux - Software 5 10-21-2004 06:57 AM
Need help installing CDemu. The install claims im not root. bastupungen Linux - Software 4 08-02-2004 12:33 PM
Trouble installing CDEMU Maselter Linux - Software 0 02-22-2004 10:35 PM


All times are GMT -5. The time now is 05:33 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration