LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 07-15-2007, 08:45 PM   #1
Crash90
LQ Newbie
 
Registered: Jul 2007
Posts: 28

Rep: Reputation: 15
Installing Broadcom 440x Driver


After fighting windows for several years, I have finally decided to switch over to Linux. I have run into a problem w/ the broadcom 440x driver for my ethernet card. As happens to everyone else, Linux does not detect my card, therefore I have to install the driver.

After reading for a few hours, I finally found the linux driver for this card. Since I am running a dual boot system, I d/l'd the file to my desktop and then burned the file onto a cd.

I am running into problems trying to use the tar command on the tar file.

I have already CD'd to the file on the cd (/mnt/cdrom/linux)

then when using the tar command, it thinks for about 15 seconds, then telss me that NONE of the the files exist w/in the tarball. (tar xvzf bcm4400-3.0.8.tar.gz)

I know they exist because I have used file roller to look inside the file.


Could it be possible that the file is marked read only and this will not let me untar the file? I have tried to pull the file into my /home/pete but Linux says it is a read only file.

UPDATE: Verified via windoz that the linux folder is READ ONLY, tried to unset the read but was denied access.



Also, I am VERY VERY new to Linux. I purchased FEDORA w/ the SAMS learn Linux in 24 hrs book, so please put it in dummy terms for now.

Last edited by Crash90; 07-15-2007 at 08:47 PM.
 
Old 07-15-2007, 10:00 PM   #2
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian Squeeze
Posts: 5,788

Rep: Reputation: 311Reputation: 311Reputation: 311Reputation: 311
First, I disagree with your opinion that *everyone else* has the same problem. I've tried several distros, all of which detected my ethernet card.

Second, you probably have the broadcom module already installed. It goes by the name b44.ko (the .ko indicates it's a kernel module).

From a command-line terminal, run '/sbin/modinfo b44'. If you get info about the b44 module, you have it installed. Then load it with the command 'modprobe b44' to insert the module into the running kernel, and probe the hardware.

The two commands listed above should be run without quotes.
 
Old 07-16-2007, 01:54 AM   #3
Crash90
LQ Newbie
 
Registered: Jul 2007
Posts: 28

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by bigrigdriver
First, I disagree with your opinion that *everyone else* has the same problem. I've tried several distros, all of which detected my ethernet card.
Little over zealous in my wording! I tend to get a little dramatic when something stumps me!


Quote:
Originally Posted by bigrigdriver
Second, you probably have the broadcom module already installed. It goes by the name b44.ko (the .ko indicates it's a kernel module).

From a command-line terminal, run '/sbin/modinfo b44'. If you get info about the b44 module, you have it installed.
SUCCESS! It is installed! Then why does the network setup tool no list it as a possible card? It lists plenty of cards, just not the broadcom.


Quote:
Originally Posted by bigrigdriver
Then load it with the command 'modprobe b44' to insert the module into the running kernel, and probe the hardware.
No success. Right after running the /sbin command, I used the modprobe b44 and linux returned an error saying there is no such command. Obviously, I am a linux noob do I need to put something before modprobe b44?

Thanks so much for the help! I am so excited to get linux fully functional!!!!


UPDATE: After poking around the internet, I discovered that you must put /sbin before using the modprobe command. Strange, either way it was fun to solve that little mystery!

HOWEVER, Linux returned the following error after running the modprobe command:

/lib/modules/2.4.22-1.2115.nptl/kernel/drivers/net/b44.o init_module NO SUCH DEVICE

If I read correctly, Linux cannot find my ethernet card?

Obviously this is the card I use, as I am using it to access the internet on windoz (and I have used belarc advisor to verify this is the correct card a Broadcom 440 10/100)

Last edited by Crash90; 07-16-2007 at 02:30 AM.
 
Old 07-16-2007, 04:21 AM   #4
Zmyrgel
Senior Member
 
Registered: Dec 2005
Location: Finland
Distribution: Slackware, CentOS, RHEL, OpenBSD
Posts: 1,006

Rep: Reputation: 36
You did run the commands as root, right?

Code:
modprobe b44
ifconfig eth0 up
dhcpcd eth0
Above should get your card running if it uses dhcp.
 
Old 07-16-2007, 04:54 AM   #5
b0uncer
Guru
 
Registered: Aug 2003
Distribution: CentOS, OS X
Posts: 5,131

Rep: Reputation: Disabled
Code:
su -
That gives you root permissions (have the '-' at the end, to get PATH variables correct --> no need to enter /sbin before the commands) unless root account is locked (in some distributions it is, instead they use 'sudo' to keep the system slightly more secure). After that run the commands described in the above post. The 'su' command asks for root account password, so give it. If you don't know what it is, never heard about 'root account' or are using Ubuntu/something else that doesn't have root active by default, instead run
Code:
sudo su -
and give your own account's password (not root). Or just run each command with 'sudo ' before the actual command.

If you're told that dhcpcd is an unknown command, try 'dhclient' instead (without quotes). Some distributions use dhcpcd, others dhclient.
 
Old 07-16-2007, 11:23 AM   #6
Crash90
LQ Newbie
 
Registered: Jul 2007
Posts: 28

Original Poster
Rep: Reputation: 15
First off thanks for all the responses! It is refreshing to see such a helpful community!


Here are the results when I ran each command. Each command was run from root!


/sbin/eth0 up

eth0 unknown interface: no such device

/sbin/dheclient up

configuration for up not found
configuration for etho0 not found
bind socket to interface: no such device

Ran it again and this time Fedora returned

DHCDDISCOVEER at 255.255.255.255 on Port 67 Interval 3
DHCDDISCOVEER at 255.255.255.255 on Port 67 Interval 6
DHCDDISCOVEER at 255.255.255.255 on Port 67 Interval 14
DHCDDISCOVEER at 255.255.255.255 on Port 67 Interval 16
DHCDDISCOVEER at 255.255.255.255 on Port 67 Interval 13
DHCDDISCOVEER at 255.255.255.255 on Port 67 Interval 9
No DHCP OFFERS RECEIVED


/sbin/modprobe b44

Look in my above post for the error returned

/sbin/ifconfig

Shoot I forgot to copy this down.

EDIT: Ran this and copied the return:

Inet addr: 127.0.0.1 Mask: 255.0.0.0
UP LOOPBACK RUNNING
MT: 16436
RX Packet: 2254 Errors:0 Drop:0 Ovverun: 0
TX Packet: 2254 Errors:0 Drop Ovverun: 0
Collisions: 0

Rx bytes: 2mb Tx Bytes: 2mb

Last edited by Crash90; 07-16-2007 at 11:41 AM.
 
Old 07-16-2007, 01:09 PM   #7
pappy_mcfae
Member
 
Registered: Feb 2007
Location: Dallas
Distribution: Gentoo x86 & x86_64
Posts: 190

Rep: Reputation: 30
Post

Quote:
Originally Posted by Crash90

/lib/modules/2.4.22-1.2115.nptl/kernel/drivers/net/b44.o init_module NO SUCH DEVICE

If I read correctly, Linux cannot find my ethernet card?

Obviously this is the card I use, as I am using it to access the internet on windoz (and I have used belarc advisor to verify this is the correct card a Broadcom 440 10/100)
My suggestion is to compile a 2.6.x version kernel. I would recommend version 2.6.17.13, as it has a huge amount of net drivers and other goodies that your 2.4.x kernel probably doesn't have. You can find ALL versions of the Linux kernel source at http://www.kernel.org/. To find out what kernel version you are using, type "uname -r".

If you are running a 2.4.x version, you can rest assured you are not getting everything running properly, especially if your machine, or the installed devices are newer than two years old.

Don't be afraid of compiling a new kernel. As long as you take your time, read the many available how-to's on the net, as well as the README that comes with your kernel package, you should be fine.

Hope that works for you.

Blessed be!
Pappy
 
Old 07-16-2007, 01:49 PM   #8
Crash90
LQ Newbie
 
Registered: Jul 2007
Posts: 28

Original Poster
Rep: Reputation: 15
Well here goes nothing....


I don't need to have any kind of C++ compiler installed to do this correct? That is what I understand from reading a few how to's
 
Old 07-16-2007, 02:57 PM   #9
Crash90
LQ Newbie
 
Registered: Jul 2007
Posts: 28

Original Poster
Rep: Reputation: 15
Ok, it is obvious that I am completely incompetent at Linux. It seems that even the simplest of tasks for Linux baffle me. I am trying to compile the new Kernel (2.6.17.13)

I have read a few how to's and the read me.

I currently have the tar file in /home/pete directory.

I can succesfully unpack the tar file w/

tar -xzvf linux-2.6.17.13.tar.gz

However, following the instructions of the README, using the command

cd /usr/src/linux-2.6.17.13

gets me:

no such file or directory

I have tried even copying the command itself

cd /usr/src/linux-2.6.n

same result.

What am I doing wrong? Is it extracting somewhere else?
 
Old 07-17-2007, 01:12 AM   #10
pappy_mcfae
Member
 
Registered: Feb 2007
Location: Dallas
Distribution: Gentoo x86 & x86_64
Posts: 190

Rep: Reputation: 30
Smile

Quote:
Originally Posted by Crash90
Ok, it is obvious that I am completely incompetent at Linux. It seems that even the simplest of tasks for Linux baffle me. I am trying to compile the new Kernel (2.6.17.13)
First off, my friend, you do yourself harm by self-deprecation. You have Linux installed and working (to some degree). That's a lot better than some people can achieve. Sometimes it's because of crappy hardware, sometimes it's because of inability to understand the intricate workings of the IBM PC-based computer. If your distro is working to any degree, consider yourself ahead of the curve.

EXPANDING THE .TAR.GZ ARCHIVE...

As the old saying goes, work smarter, not harder. While I would never say anything to shy anyone away from learning how to type in Linux commands, there are times when all that typing is a pain, and accomplishes nothing.

I am assuming you have some version of the X-Windows GUI installed on your system. If this is the case, then use the GUI to make your job easier. Here's a step-by-step that might be helpful.

1) Copy the .tar.gz archive to your /usr/src directory.
2) Right click on the filename, and select "Extract here". This will expand the archive into the /usr/src directory, the traditional directory for kernel source storage (at least with Slackware). This works under KDE, Gnome, and XFCE as well. I haven't tried it under Blackbox, FluxBox, FVWM, TWM, or any of the "lighter" GUI's. I have no reason to doubt this will work under those as well.
3) create your target directory. I personally use /home/kernel as my kernel work directory on all my machines.
4) Configure the kernel. You can do this with menuconfig, xconfig, or gconfig (the last two run under the GUI).
Example (how I do it)
a)make O=/home/kernel xconfig. This configures the kernel.
b)make O=/home/kernel. This actually compiles (makes) the kernel and its associated modules.
c)make O=/home/kernel modules. This step makes sure that all possible modules are set up.
d)make O=/home/kernel modules_install. This installs the modules.
e)make O=/home/kernel headers_install. This installs the kernel headers. These may be needed later.

That's pretty much it for compiling the kernel and its associated modules (if any). To answer a question you asked in another response, yes, you will need a compiler installed. If you don't have at least a C compiler installed, you need to install one or you will be completely unable to compile the kernel.

Get the most recent version of gcc in order to make sure you don't have a piece of object code or a module that gets damaged because your compiler is a little out of date. I just compiled a new 2.6.22.1 (the source is less than a week old) for my Toshiba laptop using gcc-3.4.6-i486-1; standard issue for Slackware 11.0. That kernel is working like a charm, and supports a Broadcom bcm43xx based PCMCIA wireless adapter.

I don't know what distro you are using, but unless you are using a training wheels distro (such as Ark, Ubuntu, or Vector), kernel compilation is a fairly easy thing to get accomplished. If you are using a training wheels distro, might I suggest you go with a more fully developed distro such as Slackware.

Don't lose heart. Even if you crater things, it's only a computer operating system. I have installed everything from MS-DOS and Windows 3.0 to OS/2 Warp, to just about every type of Linux distro that exists. It's time consuming, but other than that, it's not the end of the world if things don't work right the first time. As a matter of fact, from my experience, it's par for the course.

I hope this helps.

Blessed be!
Pappy
 
Old 07-17-2007, 01:33 AM   #11
Crash90
LQ Newbie
 
Registered: Jul 2007
Posts: 28

Original Poster
Rep: Reputation: 15
I am using Fedora Core 1, so no training wheels here.

Where exactly is /usr/src? Is that my /home/pete

Guess we will see what my good buddy google says!

EDIT: Looks like I will ahve to reinstall Linux. I have no C++ compiler since I installed it w/o one.

I guess I could just d/l one. Any reccomendations?

Last edited by Crash90; 07-17-2007 at 01:34 AM.
 
Old 07-17-2007, 08:47 AM   #12
Jony Ram
LQ Newbie
 
Registered: Apr 2007
Posts: 1

Rep: Reputation: 0
In linux command what is the use of grep command
 
Old 07-17-2007, 07:09 PM   #13
Crash90
LQ Newbie
 
Registered: Jul 2007
Posts: 28

Original Poster
Rep: Reputation: 15
Oh Linux you are so crafty!

I am trying to install the gcc C++ compiler. I hae succesfully extracted the file. However, I encounter an error when trying to configure.

Running:

/home/peter/gcc/gcc-4.2.0/ configure \
--enable-shared --enable-threads=posix --disable checking

Linux returns:

No acceptable cc found in $PATH

Now I looked at the /build file and it has a configure file in it. If tell linux to do the configure from that file, it tells me there is no such file. What, I can see it right there Linux!

I will figure this out!!!

once again, I need your help!

Last edited by Crash90; 07-17-2007 at 07:28 PM.
 
Old 07-17-2007, 10:43 PM   #14
johneb47
LQ Newbie
 
Registered: Aug 2003
Location: Kingswood NSW Australia
Distribution: Slackware, ArchLinux
Posts: 19

Rep: Reputation: 1
Crash90,
STOP!
Take a deep breath, calm down.
open a terminal and try gcc -v
if response is "command not found" download and install gcc from your fedora repository
download and install the development packages as well
login into root.
cd /usr/src
tar -xzvf linux-2.6.xxxx.tar.gz (if file ends with tar.bz2 use tar -xjvf)
cd linux-2.6.xxxx and follow the readme.
 
Old 07-17-2007, 11:50 PM   #15
pappy_mcfae
Member
 
Registered: Feb 2007
Location: Dallas
Distribution: Gentoo x86 & x86_64
Posts: 190

Rep: Reputation: 30
Post

Quote:
Originally Posted by Crash90
I am using Fedora Core 1, so no training wheels here.
Therein lies a part of the problem. I did tests on various Linux distributions and published the results at OpEdNews. The review I did on Fedora is available at this URL.
As you will see when you read that particular review, I am less than impressed with Fedora. I upset a few people with my opinions about that distro, but I call's 'em as I see's 'em.

Fedora isn't what I would call a good distribution. According to one person who commented on that particular article, Fedora exists as a beta test test bed for Red Hat, the pay-for-it version of Linux. The version I tested was Fedora core 5, and if it sucked (which it did, in my humble opinion), I can only imagine how bad core 1 is.

Might I suggest you think about going for a more friendly and functional distro such as Slackware? Slackware isn't beta test. It's the real deal. I am using version 11 on three machines. I have yet to kill it completely, and I have spent much time trying. It's not perfect, but given the choice of the Linux distros I tried, it remains the friendliest (as far as non-training wheel distro's go) and most stable. The version I am using now has been up and running since I bought this laptop at the end of march.

Quote:
Where exactly is /usr/src? Is that my /home/pete
No. The /usr/src directory is just another directory in your directory tree. Start your file manager. You will see the basic directory tree. As long as your tree is sorted alphabetically, the /usr directory will be down there at the bottom of the tree. If you open the /usr directory, one of its subdirectories will be /src.

Quote:
Guess we will see what my good buddy google says!

EDIT: Looks like I will ahve to reinstall Linux. I have no C++ compiler since I installed it w/o one.

I guess I could just d/l one. Any reccomendations?
Use gcc. you can find the latest and greatest version of gcc at this URL. Frankly, if I were you, I'd seriously think about looking into a more friendly distro.

The one you chose should reflect what you do with your machine. If you use it as a word processing monster, you would be a lot better going with Ubuntu or one of its various variants (Kubuntu or Xubuntu). If you are doing more, you might want to consider Vector Linux. If you really want to use a distro that will let you do anything you wish in the world of Linux, then I heartily suggest Slackware.

Whatever you decide, do yourself a favor and take the time to read my Linux articles at OpEdNews.com. They may answer your questions about matching a Linux distribution to how you use your computer.

What ever you decide, I hope it all goes well for you. Linux is a great alternative to the Microsoft information "monopoly". There are enough Linux distributions on the internet that you should be able to find a distro that will work for you.

Best of luck!

Blessed be!
Pappy
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Broadcom 440x driver Installation problem in Redhat 9 katekhaye Linux - Hardware 6 11-24-2006 01:07 AM
Installing Broadcom 440x Driver pc1962 Linux - Hardware 3 11-25-2005 08:29 PM
Broadcom 440x driver problem with red hat 9 jwildey Linux - Networking 1 10-10-2005 07:08 AM
Installing Broadcom 440x driver midk Red Hat 2 06-26-2004 03:04 PM
broadcom 440x with 2.4.24 kernel redRemi Linux - Networking 4 05-09-2004 02:29 PM


All times are GMT -5. The time now is 01:24 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration