LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-04-2016, 07:57 AM   #1
Toshan121
LQ Newbie
 
Registered: May 2016
Posts: 2

Rep: Reputation: Disabled
Installing Automake without root previlege


Hello,
I am trying to install a Automake into a cluster where i am not the admin. AUtomake is dependent on autoconf, and i need to install both. However, i don't know how to configure automake so that it can recognize that I installed autoconf into a folder where i have permission to write.

Can someone help please?

Kind regards,
Toshan
 
Old 05-04-2016, 11:02 AM   #2
weibullguy
ReliaFree Maintainer
 
Registered: Aug 2004
Location: Kalamazoo, Michigan
Distribution: Slackware-current, Cross Linux from Scratch, Gentoo
Posts: 2,812
Blog Entries: 1

Rep: Reputation: 259Reputation: 259Reputation: 259
Before you execute the Automake configure script, ensure your PATH has the location of your personal installation of Autoconf. Automake will use the first autoconf it finds in your PATH variable that meets the version requirements.

For example, I installed Autoconf in the prefix /home/andrew/.local. Thus, the version of autoconf I want Automake to find is in /home/andrew/.local/bin. I append this location to my PATH variable
Code:
PATH="/home/andrew/.local/bin:$PATH"
Now when I execute the Automake configure script, it finds this autoconf first and uses it rather than the system one installed in /usr/bin.

You can see that the version of the system autoconf is 2.69:
Code:
andrew@aragorn ~/builds/scratch/autotools/automake-1.15
 It is 11:06:42 on Wed May 04
 [gvim config.log] --> /usr/bin/autoconf --version
autoconf (GNU Autoconf) 2.69
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+/Autoconf: GNU GPL version 3 or later
<http://gnu.org/licenses/gpl.html>, <http://gnu.org/licenses/exceptions.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.
Whereas, the version of autoconf I installed just for me is 2.65:
Code:
andrew@aragorn ~/builds/scratch/autotools/automake-1.15
 It is 11:07:31 on Wed May 04
 [/usr/bin/autoconf --version] --> ~/.local/bin/autoconf --version
autoconf (GNU Autoconf) 2.65
Copyright (C) 2009 Free Software Foundation, Inc.
License GPLv3+/Autoconf: GNU GPL version 3 or later
<http://gnu.org/licenses/gpl.html>, <http://gnu.org/licenses/exceptions.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.
Checking Automake's config.log, we can see it picked up the locally installed autoconf:
Code:
configure:2934: checking whether autoconf is installed
configure:2939: autoconf --version
autoconf (GNU Autoconf) 2.65
Copyright (C) 2009 Free Software Foundation, Inc.
License GPLv3+/Autoconf: GNU GPL version 3 or later
<http://gnu.org/licenses/gpl.html>, <http://gnu.org/licenses/exceptions.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.
Because /home/andrew/.local/bin comes before /usr/bin in my PATH variable:
Code:
 andrew@aragorn ~/builds/scratch/autotools/automake-1.15
 It is 11:08:04 on Wed May 04
 [~/.local/bin/autoconf --version] --> echo $PATH
/home/andrew/.local/bin:/usr/local/bin:/usr/bin:/bin:/usr/games:/usr/share/cuda/bin:/opt/idea/bin:/usr/lib64/java/bin:/usr/lib64/java/jre/bin:/usr/lib64/openjdk/bin:/usr/lib64/openjdk/jre/bin:/usr/lib64/qt/bin:/usr/lib64/qt5/bin:/usr/local/bin:/opt/sage:/usr/share/texmf/bin:/usr/lib64/qt/bin:/home/andrew/.local/lib64/perl5/bin:/usr/lib64/java/bin:/usr/lib64/java:jre/bin
 
1 members found this post helpful.
Old 05-05-2016, 02:45 AM   #3
Toshan121
LQ Newbie
 
Registered: May 2016
Posts: 2

Original Poster
Rep: Reputation: Disabled
thank you very much. I have already tried this method but it did not work. At the configure stage, it says permission denied. Even when I am trying to install into my directory.
 
Old 05-05-2016, 10:11 AM   #4
sundialsvcs
LQ Guru
 
Registered: Feb 2004
Location: SE Tennessee, USA
Distribution: Gentoo, LFS
Posts: 7,151

Rep: Reputation: 2203Reputation: 2203Reputation: 2203Reputation: 2203Reputation: 2203Reputation: 2203Reputation: 2203Reputation: 2203Reputation: 2203Reputation: 2203Reputation: 2203
Try it again. The output should tell you exactly where the un-writeable files were located.

"autoconf / automake" are both "ordinary developer tools," designed to automate the process of creating Makefiles. Although they are used in configuring the Linux kernel and many subsystems, they're not in any way specific to the kernel, and therefore they are not privileged.

You're probably (accidentally) setting things up so that the first config that is encountered is one that's used for system maintenance purposes. Weibullguy's instructions are detailed and accurate.
 
Old 05-07-2016, 03:34 PM   #5
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 2,321
Blog Entries: 1

Rep: Reputation: 447Reputation: 447Reputation: 447Reputation: 447Reputation: 447
If you're building them from sources.

$ ./configure --help | less

Normally theres a --installdir and other options to put it where you can write. And change your $PATH to look there first. +/- some --'s and *$PATH* stuff. In debian there's stow to help manage things like this. Plus you can build debian packages without actually being root. With ar and tar to extract it in a place you can write with $PATH and $LD_LIBRARY_PATH and stuff to use it where ever it exists. Whatever works for you though.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to grant root previlege to other users? wtb1974 Linux - Newbie 4 03-19-2006 01:20 AM
I want to grant 'shutdown' previlege to a non-root user to do directly from console jagadee76 Linux - General 6 12-29-2004 04:16 AM
Scribus installation problem, sez I need automake 1.6 when automake 1.9 is istalled Rockgod2099 Linux - Software 13 11-14-2004 07:37 PM
installing automake Metal Martian Linux - Newbie 13 04-09-2004 02:11 AM
installing E, fnlib, and automake probs Sprocket87 Linux - Software 0 05-14-2003 08:49 PM


All times are GMT -5. The time now is 08:14 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration