LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-06-2004, 02:09 AM   #1
AglaSyS
LQ Newbie
 
Registered: Aug 2004
Posts: 25

Rep: Reputation: 15
Installing an Onboard sound card under Slack10


I've been trying a lot to install my OnBoard sound card (Analog Devices AD 1981 Codec Chip, Software Sound, Sound Blaster Pro). ALSACONF recognizes it as an Intel l ICH4/M 82801DB/M (rev 03). I try to install it, and alsaconf says everything is OK, installed, configured, and that i should restart my PC. So I run alsamixer to test it, and it simply tells me "No mixer elems found" . What can I do to run my Video card?

Link to www.intel.com .

PS: If I said anything senseless/stupid, it's cuz i'm half asleep
 
Old 09-06-2004, 02:29 AM   #2
TomaCzar
Member
 
Registered: Dec 2003
Location: Roc City (Rochester-NY)
Distribution: Slacker 4 Life
Posts: 125

Rep: Reputation: 15
Would that it were me, I would start off with an lspci to see exactly what my system recognizes the card as, then I would move on to checking my kernel. If you've compiled your own check which drivers you've chosen to make sure they're the right ones, if you're using the 2.4.26 kernel do an lsmod to make sure that all the proper modules are loaded. There's a separate module to create /dev/mixer, if that's not around then your probably don't have it loaded.

I've tried to run alsaconf when something was wrong and it has done nothing for me. When I've done what I needed to do to get everything working alsaconf was never needed. Just my personal experience.
 
Old 09-06-2004, 12:24 PM   #3
AglaSyS
LQ Newbie
 
Registered: Aug 2004
Posts: 25

Original Poster
Rep: Reputation: 15
I've had Linux for a day and a half... No, I didn't compile my own kernel. Which ones would be the correct modules? Which one creates /dev/mixer?

Oh yeah, I tryied playing a CD with XMMS in analog mode. When I switched to digital mode, it froze as soon as I pressed play (the play button got stuck in)
 
Old 09-06-2004, 11:20 PM   #4
TomaCzar
Member
 
Registered: Dec 2003
Location: Roc City (Rochester-NY)
Distribution: Slacker 4 Life
Posts: 125

Rep: Reputation: 15
Give me the output of these two commands:

Code:
lspci 
lsmod
Make sure to run them as root. Then I might have a better idea where to step next.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound issue slack10.1 and intel onboard card pedro.velho Slackware 17 04-29-2005 04:55 PM
slack10 and Terratec Aureon 5.1 Fun sound card anchunlei Slackware 1 08-18-2004 07:59 AM
keep onboard sound card enabled when a second sound card has been added ViralHex Linux - Hardware 0 06-08-2004 02:06 PM
Diabling onboard sound card and enabling pci slot sound card abhatia Linux - Hardware 4 01-12-2004 03:10 AM
Installing sound drivers on onboard card Air_Man Linux - Software 7 08-30-2002 11:54 PM


All times are GMT -5. The time now is 08:22 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration