LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-08-2004, 05:22 PM   #1
santasballz
Member
 
Registered: Jan 2004
Posts: 227

Rep: Reputation: 30
installing a driver for mandrake...


from the following:
http://www.jennings.homelinux.net/atmel_92.html

well, like the thing said, first type in
iwconfig
but when i did that, it says command not recognized... i've had problems like this before and i have to install a package or something to make it work, but which package am i suppose to install?

also on tut, it says to
Insert into /etc/hotplug/blacklist :-
well i typed in
/etc/hotplug/blacklist :-
in terminal, but then it says bash: permission denied...
how do i fix this?
 
Old 02-08-2004, 05:37 PM   #2
santasballz
Member
 
Registered: Jan 2004
Posts: 227

Original Poster
Rep: Reputation: 30
also, when i dl the driver and try to compile it using the make command, i get this huge ass list of errors, i dun know what they mean... anyone have any idea? here is the list:



gcc -MD -O2 -Wall -Wstrict-prototypes -pipe -fno-strict-aliasing -fno-common -Wno-sign-compare -Wno-unused -D__KERNEL__ -DMODULE -DEXPORT_SYMTAB -DDRIVER_VERSION=\"v0.11\" -I/lib/modules/2.4.22-10mdk/build/include -c at76c503.c
In file included from /usr/include/linux/prefetch.h:13,
from /usr/include/linux/list.h:6,
from /usr/include/linux/wait.h:14,
from /usr/include/linux/fs.h:11,
from /usr/include/linux/capability.h:17,
from /usr/include/linux/binfmts.h:5,
from /usr/include/linux/sched.h:8,
from at76c503.c:79:
/usr/include/asm/processor.h:55: error: `CONFIG_X86_L1_CACHE_SHIFT' undeclared here (not in a function)
/usr/include/asm/processor.h:55: error: requested alignment is not a constant
In file included from /usr/include/linux/mm.h:12,
from /usr/include/linux/poll.h:10,
from at76c503.c:82:
/usr/include/linux/mmzone.h:44: error: `CONFIG_X86_L1_CACHE_SHIFT' undeclared here (not in a function)
/usr/include/linux/mmzone.h:44: error: requested alignment is not a constant
In file included from /usr/include/linux/module.h:20,
from at76c503.c:86:
/usr/include/linux/modversions.h:1:2: #error "======================================================="
/usr/include/linux/modversions.h:2:2: #error "You should not include /usr/include/{linux,asm}/ header"
/usr/include/linux/modversions.h:3:2: #error "files directly for the compilation of kernel modules."
/usr/include/linux/modversions.h:4:2: #error ""
/usr/include/linux/modversions.h:5:2: #error "glibc now uses kernel header files from a well-defined"
/usr/include/linux/modversions.h:6:2: #error "working kernel version (as recommended by Linus Torvalds)"
/usr/include/linux/modversions.h:7:2: #error "These files are glibc internal and may not match the"
/usr/include/linux/modversions.h:8:2: #error "currently running kernel. They should only be"
/usr/include/linux/modversions.h:9:2: #error "included via other system header files - user space"
/usr/include/linux/modversions.h:10:2: #error "programs should not directly include <linux/*.h> or"
/usr/include/linux/modversions.h:11:2: #error "<asm/*.h> as well."
/usr/include/linux/modversions.h:12:2: #error ""
/usr/include/linux/modversions.h:13:2: #error "To build kernel modules please do the following:"
/usr/include/linux/modversions.h:14:2: #error ""
/usr/include/linux/modversions.h:15:2: #error " o Have the kernel sources installed"
/usr/include/linux/modversions.h:16:2: #error ""
/usr/include/linux/modversions.h:17:2: #error " o Make sure that the symbolic link"
/usr/include/linux/modversions.h:18:2: #error " /lib/modules/`uname -r`/build exists and points to"
/usr/include/linux/modversions.h:19:2: #error " the matching kernel source directory"
/usr/include/linux/modversions.h:20:2: #error ""
/usr/include/linux/modversions.h:21:2: #error " o Now copy /boot/vmlinuz.version.h to"
/usr/include/linux/modversions.h:22:2: #error " /lib/modules/`uname -r`/build/include/linux/version.h"
/usr/include/linux/modversions.h:23:2: #error ""
/usr/include/linux/modversions.h:24:2: #error " o When compiling, make sure to use the following"
/usr/include/linux/modversions.h:25:2: #error " compiler option to use the correct include files:"
/usr/include/linux/modversions.h:26:2: #error ""
/usr/include/linux/modversions.h:27:2: #error " -I/lib/modules/`uname -r`/build/include"
/usr/include/linux/modversions.h:28:2: #error ""
/usr/include/linux/modversions.h:29:2: #error " instead of"
/usr/include/linux/modversions.h:30:2: #error ""
/usr/include/linux/modversions.h:31:2: #error " -I/usr/include/linux"
/usr/include/linux/modversions.h:32:2: #error ""
/usr/include/linux/modversions.h:33:2: #error " Please adjust the Makefile accordingly."
/usr/include/linux/modversions.h:34:2: #error "======================================================="
In file included from /usr/include/linux/module.h:297,
from at76c503.c:86:
/usr/include/linux/version.h:2:2: #error "======================================================="
/usr/include/linux/version.h:3:2: #error "You should not include /usr/include/{linux,asm}/ header"
/usr/include/linux/version.h:4:2: #error "files directly for the compilation of kernel modules."
/usr/include/linux/version.h:5:2: #error ""
/usr/include/linux/version.h:6:2: #error "glibc now uses kernel header files from a well-defined"
/usr/include/linux/version.h:7:2: #error "working kernel version (as recommended by Linus Torvalds)"
/usr/include/linux/version.h:8:2: #error "These files are glibc internal and may not match the"
/usr/include/linux/version.h:9:2: #error "currently running kernel. They should only be"
/usr/include/linux/version.h:10:2: #error "included via other system header files - user space"
/usr/include/linux/version.h:11:2: #error "programs should not directly include <linux/*.h> or"
/usr/include/linux/version.h:12:2: #error "<asm/*.h> as well."
/usr/include/linux/version.h:13:2: #error ""
/usr/include/linux/version.h:14:2: #error "To build kernel modules please do the following:"
/usr/include/linux/version.h:15:2: #error ""
/usr/include/linux/version.h:16:2: #error " o Have the kernel sources installed"
/usr/include/linux/version.h:17:2: #error ""
/usr/include/linux/version.h:18:2: #error " o Make sure that the symbolic link"
/usr/include/linux/version.h:19:2: #error " /lib/modules/`uname -r`/build exists and points to"
/usr/include/linux/version.h:20:2: #error " the matching kernel source directory"
/usr/include/linux/version.h:21:2: #error ""
/usr/include/linux/version.h:22:2: #error " o Now copy /boot/vmlinuz.version.h to"
/usr/include/linux/version.h:23:2: #error " /lib/modules/`uname -r`/build/include/linux/version.h"
/usr/include/linux/version.h:24:2: #error ""
/usr/include/linux/version.h:25:2: #error " o When compiling, make sure to use the following"
/usr/include/linux/version.h:26:2: #error " compiler option to use the correct include files:"
/usr/include/linux/version.h:27:2: #error ""
/usr/include/linux/version.h:28:2: #error " -I/lib/modules/`uname -r`/build/include"
/usr/include/linux/version.h:29:2: #error ""
/usr/include/linux/version.h:30:2: #error " instead of"
/usr/include/linux/version.h:31:2: #error ""
/usr/include/linux/version.h:32:2: #error " -I/usr/include/linux"
/usr/include/linux/version.h:33:2: #error ""
/usr/include/linux/version.h:34:2: #error " Please adjust the Makefile accordingly."
/usr/include/linux/version.h:35:2: #error "======================================================="
In file included from at76c503.c:86:
/usr/include/linux/module.h:299: error: syntax error before "UTS_RELEASE"
In file included from /usr/include/linux/usb.h:136,
from at76c503.c:91:
/usr/include/linux/version.h:2:2: #error "======================================================="
/usr/include/linux/version.h:3:2: #error "You should not include /usr/include/{linux,asm}/ header"
/usr/include/linux/version.h:4:2: #error "files directly for the compilation of kernel modules."
/usr/include/linux/version.h:5:2: #error ""
/usr/include/linux/version.h:6:2: #error "glibc now uses kernel header files from a well-defined"
/usr/include/linux/version.h:7:2: #error "working kernel version (as recommended by Linus Torvalds)"
/usr/include/linux/version.h:8:2: #error "These files are glibc internal and may not match the"
/usr/include/linux/version.h:9:2: #error "currently running kernel. They should only be"
/usr/include/linux/version.h:10:2: #error "included via other system header files - user space"
/usr/include/linux/version.h:11:2: #error "programs should not directly include <linux/*.h> or"
/usr/include/linux/version.h:12:2: #error "<asm/*.h> as well."
/usr/include/linux/version.h:13:2: #error ""
/usr/include/linux/version.h:14:2: #error "To build kernel modules please do the following:"
/usr/include/linux/version.h:15:2: #error ""
/usr/include/linux/version.h:16:2: #error " o Have the kernel sources installed"
/usr/include/linux/version.h:17:2: #error ""
/usr/include/linux/version.h:18:2: #error " o Make sure that the symbolic link"
/usr/include/linux/version.h:19:2: #error " /lib/modules/`uname -r`/build exists and points to"
/usr/include/linux/version.h:20:2: #error " the matching kernel source directory"
/usr/include/linux/version.h:21:2: #error ""
/usr/include/linux/version.h:22:2: #error " o Now copy /boot/vmlinuz.version.h to"
/usr/include/linux/version.h:23:2: #error " /lib/modules/`uname -r`/build/include/linux/version.h"
/usr/include/linux/version.h:24:2: #error ""
/usr/include/linux/version.h:25:2: #error " o When compiling, make sure to use the following"
/usr/include/linux/version.h:26:2: #error " compiler option to use the correct include files:"
/usr/include/linux/version.h:27:2: #error ""
/usr/include/linux/version.h:28:2: #error " -I/lib/modules/`uname -r`/build/include"
/usr/include/linux/version.h:29:2: #error ""
/usr/include/linux/version.h:30:2: #error " instead of"
/usr/include/linux/version.h:31:2: #error ""
/usr/include/linux/version.h:32:2: #error " -I/usr/include/linux"
/usr/include/linux/version.h:33:2: #error ""
/usr/include/linux/version.h:34:2: #error " Please adjust the Makefile accordingly."
/usr/include/linux/version.h:35:2: #error "======================================================="
In file included from /usr/include/asm/hardirq.h:6,
from /usr/include/linux/interrupt.h:46,
from /usr/include/linux/usb.h:139,
from at76c503.c:91:
/usr/include/linux/irq.h:65: error: `CONFIG_X86_L1_CACHE_SHIFT' undeclared here (not in a function)
/usr/include/linux/irq.h:65: error: requested alignment is not a constant
In file included from /usr/include/linux/interrupt.h:46,
from /usr/include/linux/usb.h:139,
from at76c503.c:91:
/usr/include/asm/hardirq.h:16: error: `CONFIG_X86_L1_CACHE_SHIFT' undeclared here (not in a function)
/usr/include/asm/hardirq.h:16: error: requested alignment is not a constant
In file included from /usr/include/linux/usb.h:139,
from at76c503.c:91:
/usr/include/linux/interrupt.h:129: error: `CONFIG_X86_L1_CACHE_SHIFT' undeclared here (not in a function)
/usr/include/linux/interrupt.h:129: error: requested alignment is not a constant
In file included from at76c503.c:92:
/usr/include/linux/netdevice.h:165: error: `CONFIG_X86_L1_CACHE_SHIFT' undeclared here (not in a function)
/usr/include/linux/netdevice.h:165: error: requested alignment is not a constant
In file included from at76c503.c:92:
/usr/include/linux/netdevice.h:517: error: `CONFIG_X86_L1_CACHE_SHIFT' undeclared here (not in a function)
/usr/include/linux/netdevice.h:517: error: requested alignment is not a constant
at76c503.c:3695:41: missing binary operator before token "("
at76c503.c:4685: error: syntax error before "config_must_be_included_before_module"
at76c503.c:4685: warning: type defaults to `int' in declaration of `config_must_be_included_before_module'
at76c503.c:4685: warning: data definition has no type or storage class
at76c503.c:4686: error: syntax error before "config_must_be_included_before_module"
at76c503.c:4686: warning: type defaults to `int' in declaration of `config_must_be_included_before_module'
at76c503.c:4686: warning: data definition has no type or storage class
at76c503.c:4687: error: syntax error before "config_must_be_included_before_module"
at76c503.c:4687: warning: type defaults to `int' in declaration of `config_must_be_included_before_module'
at76c503.c:4687: warning: data definition has no type or storage class
at76c503.c:4688: error: syntax error before "config_must_be_included_before_module"
at76c503.c:4688: warning: type defaults to `int' in declaration of `config_must_be_included_before_module'
at76c503.c:4688: warning: data definition has no type or storage class
at76c503.c:4689: error: syntax error before "config_must_be_included_before_module"
at76c503.c:4689: warning: type defaults to `int' in declaration of `config_must_be_included_before_module'
at76c503.c:4689: warning: data definition has no type or storage class
at76c503.c:4690: error: syntax error before "config_must_be_included_before_module"
at76c503.c:4690: warning: type defaults to `int' in declaration of `config_must_be_included_before_module'
at76c503.c:4690: warning: data definition has no type or storage class



help would be appreciated.
 
Old 02-08-2004, 07:08 PM   #3
santasballz
Member
 
Registered: Jan 2004
Posts: 227

Original Poster
Rep: Reputation: 30
looks like the long list on errors is quite intimidating
 
Old 02-08-2004, 07:16 PM   #4
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Debian Testing
Posts: 19,192
Blog Entries: 4

Rep: Reputation: 470Reputation: 470Reputation: 470Reputation: 470Reputation: 470
Quote:
from the install instructions
if you type 'iwconfig' in a root terminal
You need to open a terminal and type su then hit enter, then enter the root password and hit enter. Then type iwconfig

Quote:
install instructions again
(iwconfig is in the 'wireless-tools' RPM package. You may need to install it)
Go to www.rpmfind.net to download this package for your distro. Install it (as root again) by typing rpm -ivh the package name.rpm.

Quote:
install instructions
All you have to do is edit the file /etc/hotplug/blacklist and insert the names of the atmelwlandriver. The hotplug system will then ignore those drivers and will install only the at76c503a driver.

Insert into /etc/hotplug/blacklist :-
usbvnet_rfmd
usbvnet_r505_2958
Go to /etc/hotplug, there is a file called "blacklist". Open your root terminal and type in kedit or whatever your text editor is. Open the blacklist file with the text editor. Edit it and save it.

DO NOT use what I have written instead of the full instructions, my words are just to pad out the instructions and help you over the stumbling blocks.
 
Old 02-08-2004, 08:24 PM   #5
santasballz
Member
 
Registered: Jan 2004
Posts: 227

Original Poster
Rep: Reputation: 30
thank you. after installatiing the package, surely enough iwconfig worked. but i have yet to figure out the second part
 
Old 02-08-2004, 08:26 PM   #6
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Debian Testing
Posts: 19,192
Blog Entries: 4

Rep: Reputation: 470Reputation: 470Reputation: 470Reputation: 470Reputation: 470
What second part? I thought it was all working?
 
Old 02-08-2004, 09:02 PM   #7
santasballz
Member
 
Registered: Jan 2004
Posts: 227

Original Poster
Rep: Reputation: 30
i meant this part


Insert into /etc/hotplug/blacklist :-
usbvnet_rfmd
usbvnet_r505_2958
 
Old 02-08-2004, 09:05 PM   #8
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Debian Testing
Posts: 19,192
Blog Entries: 4

Rep: Reputation: 470Reputation: 470Reputation: 470Reputation: 470Reputation: 470
Open the file and type in those lines. Then save the file. Don't forget to do it as root.
 
Old 02-08-2004, 09:05 PM   #9
quatsch
LQ Addict
 
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 48
you have to be root to edit /etc/hotplug/blacklist. "insert" means that you need to add those lines to the file. Just open a text editor of your choice as root and edit the file.
 
Old 02-08-2004, 09:12 PM   #10
santasballz
Member
 
Registered: Jan 2004
Posts: 227

Original Poster
Rep: Reputation: 30
instruction says:

The drakconnect GUI will still not recognise the existance of the USB wireless, so it is necessary to set up the Mandrake network configuration files by hand. To configure the wireless card create a file /etc/sysconfig/network-scripts/ifcfg-wlan0

how do i do that?


ps. thx for helpoing me with the edit part, i got it working

Last edited by santasballz; 02-08-2004 at 09:15 PM.
 
Old 02-08-2004, 11:02 PM   #11
santasballz
Member
 
Registered: Jan 2004
Posts: 227

Original Poster
Rep: Reputation: 30
another problem. when i try to insert usbvnet_rfmd and usbvnet_r5052958
i type them in, and save the file, but in the terminal window, an error says:
Mutex destroy failure: device or resource busy.

what's wrong? how do i fix this?
 
Old 02-08-2004, 11:12 PM   #12
quatsch
LQ Addict
 
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 48
Iwouldn't worry about the mutex detroy error so long as the changes have been made in the file.

As for the other thing, you can create a file with the command
touch <filename>
and a directory with
mkdir <directory name>

So, it you don't have a directory /etc/network-scripts, create it with
mkdir /etc/network-scripts
then you can create the ifcfg-wlan0 by first changing into the directory /etc/network-scripts, and then
touch ifcfg-wlan0

you'll have to be root to do all this. Also, you might have to change permissions on ifcfg-wlan0 to give read-write-execute access to root and/or normal users.
 
Old 02-08-2004, 11:21 PM   #13
santasballz
Member
 
Registered: Jan 2004
Posts: 227

Original Poster
Rep: Reputation: 30
ok, thx, i'll give it a try
 
Old 02-08-2004, 11:38 PM   #14
santasballz
Member
 
Registered: Jan 2004
Posts: 227

Original Poster
Rep: Reputation: 30
well i followed pretty much everything the tutorial says, but when i boot up i c the following:

bring up interface eth0 [failed]
bring up interface wlan0 [done]

wlan is up and eth0 is down? whats going on? on the tutorial it said to modify the ifcfy-wlan0 according to this:


DEVICE=wlan0
BOOTPROTO=static
IPADDR=192.168.1.43
NETMASK=255.255.255.0
NETWORK=192.168.1.0
BROADCAST=192.168.1.255
ONBOOT=yes
KEY=s:mykey
WIRELESS_RATE=11M
WIRELESS_MODE=Managed
WIRELESS_ESSID=8848DBjennings
MII_NOT_SUPPORTED=yes


the author uses the same adaptor as me so iam assuming that most stay the same, except for ipadddr, netmask, network, broadcast and wireless essid
my question is, how do i find out my IPADDR, NETMASK, NETWORK, BROADCAST and WIRELESS_ESSID?
 
Old 02-09-2004, 06:35 PM   #15
santasballz
Member
 
Registered: Jan 2004
Posts: 227

Original Poster
Rep: Reputation: 30
anyone got any ideas?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
installing driver GUNN01 Linux - Newbie 1 12-27-2004 08:18 PM
Need Help installing nvidia driver for mandrake 10.1 community sbboy Mandriva 6 11-04-2004 07:09 AM
Installing and configuring ipw2100 driver in Mandrake 10.0 jaime1978 Linux - Laptop and Netbook 0 06-13-2004 07:38 AM
please help with installing the hostap-driver-o.1.3 driver for wireless card chrisseattle Linux - Wireless Networking 1 03-26-2004 01:46 PM
installing modem driver on mandrake 9.2 rganesh Mandriva 1 12-06-2003 12:43 PM


All times are GMT -5. The time now is 12:39 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration