LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Installed Ubuntu: won't print, won't connect to Net! (http://www.linuxquestions.org/questions/linux-newbie-8/installed-ubuntu-wont-print-wont-connect-to-net-510982/)

Alan Salisbury 12-16-2006 03:19 AM

Installed Ubuntu: won't print, won't connect to Net!
 
Greener than me - doesn't exist! Trying for the first time to change over to Linux, and installed Ubuntu 6.10 which looks good. But it doesn't recognise the printer, calling it by another name. And it won't connect to the net - says it can't find the server. Obviously, since I'm posting this, I'm using THE OTHER SYSTEM to do it!! As I don't know my way around, I need someone to point me in the right direction. Thanks.

AwesomeMachine 12-16-2006 04:55 AM

We'll need to know what networking hardware you are using, and connection type (i.e. adsl, cable, dialup). For the printer, if you type:

localhost:631

in a web browser it will connect to cups. Enter the root username:

root

and the root password, which only you know. Go from there. If you need to know where your .ppd files are, do:

as root:

updatedb<space>--prunepaths='/dev, /sys, /proc, /tmp, /usr/tmp, /var/tmp'

and wait until the prompt comes back. Then do:

locate .ppd | less

tredegar 12-16-2006 06:09 AM

Good advice, AwesomeMachine, except that (k)ubuntu doesn't allow you to access cups like that (it fails at the root password).
If Alan is running KDE he should go to K->System Settings-> Printers, and add his printer. He'll need to give the administrator's password, which is his password to do this.
If he is running gnome, there'll be a similar menu entry somewhere.
Same for configuring the internet connection: K->System Settings-> Network Settings.

shorty943 12-16-2006 06:31 AM

I recently had a similar problem with Ubuntu 5.10 and a Canon Pixma ip1000 printer. The only drivers I could find were RPM's. After finding and downloading Alien and a whole pile of cups driver stuff, I got stuck when trying to transfer from my laptop to my friends machine because of network glitches. Tried to transfer via USB key, Ubuntu would not recognise my USB key. Next was to install Mandriva, AMD K9 and Mandriva 2006 don't get on, or maybe it was the MSI K9 m/b, still not sure yet.
As a last desperate resort, I ended up installing THAT OS so as to get my friend at least on the net and printing etc. After starting with 4.05(ubuntu), it is my opinion Ubuntu is not quite ready for the masses just yet. Getting better, but not quite ripe.
regards shorty943.

bigjohn 12-16-2006 07:35 AM

Well having recently installed Ubuntu 6.10 it depends (I'm guessing) how the originator of the thread is connecting A) to the net and B) to the printer.

I have a modem/router device, connected via ethernet. I also use a static IP address for my system and from my ISP, so I had to manually go into the networking section and manually configure both "eth0" for the network card and add the DNS servers for my ISP.

I also have to do similar for my printer(s), both of which are connected via ethernet. So it usually means starting the kde print manager from the menu, then hitting the "administrator mode" button at the bottom of the screen, then running the wizard but making sure that I tell the wizard that it's "network printer (TCP)" that I want to use. Then just add the IP addresses, with port 9100.

As for drivers, well my laser printer is a postscript printer anyway, so I just tell it to use postscript (generic) driver and thats that sorted, my inkjet printer (an HP Photosmart 8400 series) is only about 3 months old. it doesn't have it's own driver from the list that kdeprintmanager throws up, so I just use the 8400 series driver and it's sorted.

Some printers are better supported (i.e. HP and Epson) than others (Canon and Lexmark). So you may well have to dig around for a driver (if at all!).

If the driver is only, apparently in .rpm format, then as long as the user has enabled all of the standard repositories in the sources.list (try the command of sudo vim /etc/apt/sources.list going down the list (with the arrow keys) and removing the # from in front of all the actual repository addresses. Then finish off with hitting the Esc button and then typing :wq - thats colon and letters w and q - then just start synaptic from the menu put in the password and hit the reload button at the top of the synaptic window - when it's finished "doing it's thing" you should be able to see a package called RPM for installing .rpm packages).

HTH

regards

John

Alan Salisbury 12-18-2006 12:19 PM

Thanks, everyone!
 
Thank you all for replying - so pleased to know I am not left out there on my own!
First printer problem may be - mine's a Lexmark...
Will try the solutions - I am based on gnome not KDE
As for the Net, may be a modem problem - I have a dial up connection, not ADSL. Present modem is a soft, so maybe will never work with Linux? Did try another, which said it would do for Linux as well as the Dreaded Other - and it promptly caused the entire Other to refuse to boot and I spent a happy morning reinstalling it entirely, after taking out the offending modem (and returning it to the shop!)

Anyone able to recommend a modem that will work? The market seems full of soft modems.

Incidentally, I was recommended Ubuntu by a colleague, who said it was the easiest; I had already installed Fedora Core 5, and it refused to boot, never mind dual boot. At least, Ubuntu does the dual boot job, which at least gets me back on the Net!


All times are GMT -5. The time now is 05:23 AM.