LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 08-06-2008, 02:52 PM   #1
fishbones
LQ Newbie
 
Registered: Jan 2008
Posts: 18

Rep: Reputation: 0
Installed NVIDIA graphics Driver, One Problem


Well, I've installed the NVIDIA graphics driver, and now my games work well. Only problem is my desktop is smaller than my monitor, it sits in about an inch or two. Any help? It did this by default.
 
Old 08-06-2008, 03:50 PM   #2
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,147

Rep: Reputation: 330Reputation: 330Reputation: 330Reputation: 330
Most monitors have a "setup" function accessed from buttons on the monitor. Most recent monitors have an "autoconfigure" option that adjusts the monitor to respond to the single being sent to it, that usually works well. If your monitor is one of those, try that setting.

In any case, you should find options to adjust the screen display size.

You might also want to check the frequency settings in the /etc/X11/xorg.conf file and compare those with the monitor's specifications. (Some monitors do not respond correctly when the nVidia configuration tool sends an ESID request to them, and, sometimes, the default setting are not optimal.)
 
Old 08-06-2008, 04:07 PM   #3
fishbones
LQ Newbie
 
Registered: Jan 2008
Posts: 18

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by PTrenholme View Post
Most monitors have a "setup" function accessed from buttons on the monitor. Most recent monitors have an "autoconfigure" option that adjusts the monitor to respond to the single being sent to it, that usually works well. If your monitor is one of those, try that setting.

In any case, you should find options to adjust the screen display size.

You might also want to check the frequency settings in the /etc/X11/xorg.conf file and compare those with the monitor's specifications. (Some monitors do not respond correctly when the nVidia configuration tool sends an ESID request to them, and, sometimes, the default setting are not optimal.)
Everything is good now, except my graphics card's performance. Going to see if I can install DirectX 9.0c.
 
Old 08-06-2008, 04:12 PM   #4
jay73
Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
Linux doesn't use DirectX...
 
Old 08-06-2008, 10:53 PM   #5
fishbones
LQ Newbie
 
Registered: Jan 2008
Posts: 18

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by jay73 View Post
Linux doesn't use DirectX...
Does it use DRI?
 
Old 08-06-2008, 11:31 PM   #6
jay73
Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
Yes, but it uses OpenGL instead of DirectX.
 
Old 08-08-2008, 12:42 PM   #7
fishbones
LQ Newbie
 
Registered: Jan 2008
Posts: 18

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by jay73 View Post
Yes, but it uses OpenGL instead of DirectX.
So what should I install from OpenGL's Unix/Linux projects?
 
Old 08-08-2008, 01:22 PM   #8
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,231
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
install the mesa-utils package and then use glxinfo to check if direct rendering is enabled.

Quote:
user@it-etch:~$ glxinfo | grep direct

direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
OpenGL renderer string: Mesa GLX Indirect
Obviously with the nVidia or ATI drivers installed that should return a Yes....


you can also look at the output of xpdyinfo

Last edited by farslayer; 08-08-2008 at 01:32 PM.
 
Old 08-08-2008, 06:46 PM   #9
fishbones
LQ Newbie
 
Registered: Jan 2008
Posts: 18

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by farslayer View Post
install the mesa-utils package and then use glxinfo to check if direct rendering is enabled.



Obviously with the nVidia or ATI drivers installed that should return a Yes....


you can also look at the output of xpdyinfo
Direct rendering is enabled, but the graphics still don't match with Windows. I installed the NVidia graphics drivers, yet the terrain is low-quality in World of Warcraft (can't see pathways, block-like rendering on terrain effects in which the textures form squares over the hills).

Thats why I asked about OpenGL, because graphics card drivers usually match up with a graphics software like DirectX (or OpenGL).

When I went to the OpenGL website, I found many libraries to download, but thats why I asked which ones.
 
Old 08-08-2008, 07:33 PM   #10
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,231
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
if you have installed the nvidia drivers then OpenGL should already be enabled on your system
Code:
default@debianetch:~$ glxinfo | grep OpenGL
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce 6800/AGP/SSE2
OpenGL version string: 2.0.2 NVIDIA 87.76
OpenGL extensions:
I would ask what color depth are you running at ? 16bit, 24bit ?

Is your xorg.conf file correct ?
http://us.download.nvidia.com/XFree8...hapter-06.html
Code:
In the Module section of the file, Remove the following lines:

    Load "dri"
    Load "GLCore"

In the Module section of the file, add the line (if it does not already exist):

    Load "glx"

If the X config file does not have a Module section, you can safely skip the 
last step if the X server installed on your system is an X.Org X server or an
 XFree86 X release version 4.4.0 or greater. If you are using an older 
XFree86 X server, add the following to your X config file:

Section "Module"
    Load "extmod"
    Load "dbe"
    Load "type1"
    Load "freetype"
    Load "glx"
EndSection
are the settings in WOW correct ?
 
Old 08-08-2008, 07:47 PM   #11
fishbones
LQ Newbie
 
Registered: Jan 2008
Posts: 18

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by farslayer View Post
if you have installed the nvidia drivers then OpenGL should already be enabled on your system
Code:
default@debianetch:~$ glxinfo | grep OpenGL
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce 6800/AGP/SSE2
OpenGL version string: 2.0.2 NVIDIA 87.76
OpenGL extensions:
I would ask what color depth are you running at ? 16bit, 24bit ?

Is your xorg.conf file correct ?
http://us.download.nvidia.com/XFree8...hapter-06.html
Code:
In the Module section of the file, Remove the following lines:

    Load "dri"
    Load "GLCore"

In the Module section of the file, add the line (if it does not already exist):

    Load "glx"

If the X config file does not have a Module section, you can safely skip the 
last step if the X server installed on your system is an X.Org X server or an
 XFree86 X release version 4.4.0 or greater. If you are using an older 
XFree86 X server, add the following to your X config file:

Section "Module"
    Load "extmod"
    Load "dbe"
    Load "type1"
    Load "freetype"
    Load "glx"
EndSection
are the settings in WOW correct ?
Checked and fixed the X server, still have the "block" problem.

Screenshot URL: http://i34.tinypic.com/2u6l6cz.jpg
 
Old 08-08-2008, 08:31 PM   #12
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,231
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
So you are running WOW under Wine in Linux correct ?

have you searched for "WOW Wine graphics" ?

http://www.wowwiki.com/Linux/Wine

http://www.fsckin.com/2007/12/20/how...ux-using-wine/

did you make the config.wtf file changes for graphics referred to in these docs ?
 
Old 08-08-2008, 09:50 PM   #13
fishbones
LQ Newbie
 
Registered: Jan 2008
Posts: 18

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by farslayer View Post
So you are running WOW under Wine in Linux correct ?

have you searched for "WOW Wine graphics" ?

http://www.wowwiki.com/Linux/Wine

http://www.fsckin.com/2007/12/20/how...ux-using-wine/

did you make the config.wtf file changes for graphics referred to in these docs ?
WoW runs beautifully now, thanks =)
 
  


Reply

Tags
nvidia, opengl, slackware, warcraft, world, wow


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nvidia Graphics Driver Problem and Solution kevinbenko Linux - Hardware 2 05-09-2008 11:35 AM
FC7 installation / Nvidia display problem - ?installed wrong driver? redfinger Linux - Newbie 3 07-02-2007 04:40 PM
Nvidia graphics driver problem Immortal_h0nk255 Linux - Hardware 2 01-14-2007 02:14 AM
Problem with nvidia graphics driver and glx HereticPriest Linux - Newbie 9 10-17-2006 12:03 PM
is my graphics driver installed? ripmaster Linux - Software 1 06-19-2006 12:09 AM


All times are GMT -5. The time now is 11:42 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration