LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 03-15-2008, 10:30 PM   #1
savagehobo
LQ Newbie
 
Registered: Feb 2008
Posts: 6

Rep: Reputation: 0
Installed newest NVIDIA driver (for Ge 7300) and my screen resolution is wrong


I recently re-installed F8 on my Dell Inspiron 6400 Laptop (Intel Core Due 2.0 GHz,2 GB Ram, NVIDIA Ge 7300 256 MB Video Card) After installing all the updates and rebooting I tried to install the NVIDIA drivers. I tried using the previous driver but it didn't like the new kernel. So I downloaded the new driver... I didn't think it installed properly but it apparently had as the "NVIDIA" logo showed up at boot and I can run compiz and all the 3D stuff. The problem is that my resolution (normally 1680x1050) isn't displaying properly. I have to option using the NVIDIA X server settings to use 1689x1050 at 60 Hz but when I select it my resolution looks more like 1024x768. When I first login the resolution looks correct. But something happens and everything get "bigger" making it look like lower resolution. Any solutions?
 
Old 03-15-2008, 11:26 PM   #2
lleb
Senior Member
 
Registered: Dec 2005
Location: Florida
Distribution: CentOS/Fedora
Posts: 2,454

Rep: Reputation: 440Reputation: 440Reputation: 440Reputation: 440Reputation: 440
post your xorg.conf file

it will be located in the following directory:

/etc/X11/xorg.conf

you can just cat it and copy paste it here.
 
Old 03-15-2008, 11:43 PM   #3
savagehobo
LQ Newbie
 
Registered: Feb 2008
Posts: 6

Original Poster
Rep: Reputation: 0
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder3) Thu Feb 14 18:20:37 PST 2008
Ok Here is my xorg.conf


# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Synaptics" "CorePointer"
EndSection

Section "Files"
ModulePath "/usr/lib/xorg/modules/extensions/nvidia"
ModulePath "/usr/lib/xorg/modules"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us+inet"
EndSection

Section "InputDevice"
Identifier "Synaptics"
Driver "synaptics"
Option "Device" "/dev/input/mice"
Option "Protocol" "auto-dev"
Option "Emulate3Buttons" "yes"
EndSection

Section "Monitor"
Identifier "Monitor0"
ModelName "LCD Panel 1680x1050"
HorizSync 31.5 - 65.5
VertRefresh 56.0 - 65.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection
 
Old 03-16-2008, 01:20 AM   #4
wildar
Member
 
Registered: Jan 2007
Distribution: Mandriva 2008, Mandrake 2005, Ubuntu 8.04.1
Posts: 239

Rep: Reputation: 30
Looks to me your xorg.conf is missing a 'Modes' line.
Your current section looks like this:
Code:
Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection
Try inserting Modes "1680x1050" like this:
Code:
Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1680x1050"
EndSubSection
EndSection
 
Old 03-16-2008, 01:36 AM   #5
savagehobo
LQ Newbie
 
Registered: Feb 2008
Posts: 6

Original Poster
Rep: Reputation: 0
Ok... I gave that a try, but there was no change, I made sure to restart X, and even did a restart but it's still the same. When I first login just as things are starting to load it looks normal, but it switches to the lower resolution soon after. Also it seems like the tops of windows open off screen, Luckily when I run compiz it fixes the windows so they don't open off screen.
 
Old 03-18-2008, 11:25 PM   #6
savagehobo
LQ Newbie
 
Registered: Feb 2008
Posts: 6

Original Poster
Rep: Reputation: 0
I spoke to my local "Guru" and he looked at (after laughing for a while) and said that my screen is actually displaying at 1680x1050... however my font size had been changed. Somewhere between installing the NVIDIA drivers and setting up Compiz Fusion the font size went from 8pt to 12pt thus making everything unnecessarily large. Once I changed the font size to 8pt everything looked normal again. Thanks for the responses...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Blank screen with new drivers and nVidia GeForce GO 7300 alk77 Linux - Laptop and Netbook 1 12-09-2007 11:17 AM
nvidia driver chooses wrong native resolution groundstate Linux - Hardware 3 06-10-2007 08:15 PM
Monitor resolution problem + nVidia 7300 LE graphics cars ayesha kalra Linux - Hardware 1 05-26-2007 10:01 PM
screen disappear after wrong VGA Driver installed iqbalsajid Fedora - Installation 2 03-18-2006 03:13 AM
small screen size when using newest nvidia driver BigCdaAnswer3 Linux - Hardware 13 01-30-2005 12:57 PM


All times are GMT -5. The time now is 02:51 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration