LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-09-2011, 04:37 PM   #1
sigint-ninja
Member
 
Registered: Feb 2011
Location: Republic Of Ireland
Distribution: Debian,Centos,Slackware
Posts: 451

Rep: Reputation: 29
Smile Installed linux...but no sound now


hi guys,

after many attempts at duel booting slackware 13 and xp pro i got it right. but i did it a very long way by reinstalling and trying different options.
how do you edit the lilo? also,is lilo not used much anymore...should i use grub? also i set the lilo on the MBR...is this a bad idea?

so now i have it duel booting perfectly. but i have no sound and network. is this a driver issue? where is device manager in linux? i looked around but couldnt see anything obvious.

lastly...is there a help file for slackware i can read? where is this?

thanks for reading...
sn
 
Old 02-09-2011, 05:46 PM   #2
icqraid
LQ Newbie
 
Registered: Jan 2011
Location: Oregon USA
Distribution: Slackware13.1 Ubuntu10.10
Posts: 25

Rep: Reputation: 0
I am going to take a shot in the dark here so try running this as root in the terminal
alsaconf follow the instructions

If you still don't get sound then tell us the output of lspci | grep audio

and lsmod |grep snd

Also you can use the LinuxQuestions to search (Or google) Try: Slackware no sound or: slackware no network.
There is lots of help out there.
Lilo is fine, I use it and like it. Search for it on the network for information

Welcome

Last edited by icqraid; 02-09-2011 at 05:49 PM.
 
Old 02-09-2011, 06:02 PM   #3
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 12,542
Blog Entries: 23

Rep: Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943
Hi,

Welcome to LQ & Slackware!

Quote:
Originally Posted by sigint-ninja View Post
hi guys,

after many attempts at duel booting slackware 13 and xp pro i got it right. but i did it a very long way by reinstalling and trying different options.
how do you edit the lilo? also,is lilo not used much anymore...should i use grub? also i set the lilo on the MBR...is this a bad idea?
I like to use 'vi' to edit '/etc/lilo.conf'. That is the norm when you want a dual boot and use 'lilo' as the bootloader.
Code:
~#vi lilo.conf                       #edit lilo.conf
~#lilo -v -t -b /dev/your_device     # substitute your sda or hda device this will only test  
~#lilo -v -b /dev/your_device        #this will write MBR to your_device
You should now be able to re-boot your system.
I do suggest that you use the 'man command' to understand each of the above commands.

Quote:
Originally Posted by sigint-ninja View Post
so now i have it duel booting perfectly. but i have no sound and network. is this a driver issue? where is device manager in linux? i looked around but couldnt see anything obvious.
As 'root' you can setup 'alsamixer' setting then once you 'esc' then do 'alsactl store' to save the configuration. Of course this is if your sound card is recognized.

As for the network, Configuring your network in Slackware is Alien_Bob's excellent article on the way network cards are configured in Slackware. You will find loads of internal reference links for Ethernet & Wireless.
Quote:
Originally Posted by sigint-ninja View Post
lastly...is there a help file for slackware i can read? where is this?

thanks for reading...
sn
Just a few links to aid you to gaining some understanding;

SlackwareŽ Essentials
SlackwareŽ Basics
Linux Documentation Project
Rute Tutorial & Exposition
Linux Command Guide
Bash Beginners Guide
Bash Reference Manual
Advanced Bash-Scripting Guide
Linux Newbie Admin Guide
LinuxSelfHelp
Utimate Linux Newbie Guide

The above links and others can be found at 'Slackware-Links'. More than just SlackwareŽ links!

EDIT: I suggest that you look at using the Slackware forum in the future for Slackware specific queries.

Last edited by onebuck; 02-09-2011 at 06:08 PM. Reason: add reference to Slackware forum
 
Old 02-09-2011, 06:09 PM   #4
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 12,542
Blog Entries: 23

Rep: Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943
Please use a descriptive title for your thread excluding words like 'urgent' or 'help'. Using a proper title makes it easier for members to help you. This thread has been reported for title modification. Please do not add replies that address the thread title.
 
Old 02-09-2011, 06:35 PM   #5
BoraxMan
Member
 
Registered: Apr 2010
Posts: 85

Rep: Reputation: 8
Quote:
Originally Posted by sigint-ninja View Post
hi guys,

after many attempts at duel booting slackware 13 and xp pro i got it right. but i did it a very long way by reinstalling and trying different options.
how do you edit the lilo? also,is lilo not used much anymore...should i use grub? also i set the lilo on the MBR...is this a bad idea?
Its generally a good idea to install it on the MBR. The only catch is that if you reinstall windows, it will clobber the MBR and you'll probably have to reinstall LILO or GRUB. So make sure you've got a boot disk or boot CD.


Lilo is easier to set up and install, but grub is more powerful. Remember, every time you change lilo's configuration, you have to re-write lilo to the MBR.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
No sound from laptop after Linux installed Bimp5 Linux - Laptop and Netbook 6 03-04-2009 04:26 PM
heard sound in acroread installed on windows not on linux? abd_bela Debian 1 03-02-2006 08:55 PM
I installed Linux (first time)!! Now for the sound problem... Raskall Slackware 15 01-17-2003 12:21 PM


All times are GMT -5. The time now is 12:29 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration