LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-17-2011, 11:37 AM   #1
2007fld
Member
 
Registered: Mar 2007
Distribution: FD4,6
Posts: 52

Rep: Reputation: 15
installed Fedora Core, but computer won't reboot


I have a laptop, installed with window XP. I just installed Fedora Core, re-formatted all parition on the system, and installed default packages. The installation was successful. But after I took out the installation CD and reboot the system, chose Fedora core (the only banner), the screen just become green, and nothing else from there.

The only thing I am not 100% sure is, during the installation, my monitor was probed as unrecognized. I have tried both 'go with default' and specify one "LCD 1024x...", but either way, after the installation, system won't reboot.

What could be possbily wrong?
 
Old 02-17-2011, 12:23 PM   #2
wpeckham
Senior Member
 
Registered: Apr 2010
Location: Continental USA
Distribution: Debian, Ubuntu, Fedora, RedHat, DSL, Puppy, CentOS, Knoppix, Mint-DE, Sparky, Vsido, tinycore, Q4OS
Posts: 1,793

Rep: Reputation: 618Reputation: 618Reputation: 618Reputation: 618Reputation: 618Reputation: 618
laptop

There are a couple of possibles here.

1. it could just be that your video is not properly driven. Try a liveCD and see what driver it uses. VGA or VESA are the most general.

2. some driver may be loading (or not) that totally hangs the system. Unlikely, and easy to rule out. Load up and when you get to the flat screen hit CTRL-ALT-F1. You should get a curses/ascii terminal (no gui) and a prompt to login. If you do, and can log in, your system is not hung and you only have a display issue. (CTRL-ALT-F7 should get you back to gui, such as it is.)

I am betting it is just the display issue, and if you can detect/use the correct monitor driver you will be doing the happy dance.
 
Old 02-17-2011, 12:57 PM   #3
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,186

Rep: Reputation: 346Reputation: 346Reputation: 346Reputation: 346
You note that the GRUB menu is displayed. When it appears, press the "e" key to edit the entry, and add a " 3" at the end of the kernel line. (Edit instructions are at the bottom of the screen.) Then press "b' to boot from the (temporarily) modified boot stanza.

That should boot you into a "no GUI" system. (If it doesn't do that, your Fedora installation has failed and needs to be redone.)

You should now see a Login prompt where you can enter "root" and, in the next line, your root password to log in as your system administrator.

Once logged in, enter the command dmesg | grep -i error to see if any boot error messages where reported. If there were any such messages, try to resolve them.

Then run the command grep -B3 -A5 '(E)' /var/log/Xorg.0.log to see if the last attempt to start the X-server produced and error messages. (The -B3 -A5 instructs the grep command to print the 3 lines before, and 5 lines after, any error lines in the Xorg log file.) That should tell you why the display isn't working. If it's not clear from there what you should do, post the error message(s) here for assistance. (Since you won't be able to cut and paste the messages, try to write then on paper before posting. Unless your short-term memory is a lot better than mine.)

(By the way, newer Fedora releases - since Fedora 12 - no longer use the ctrl-alt-f7 mentioned by wpeckham, and, in fact, the default X-server settings completely disable all ctrl-alt switching. That default can be changed, but that a different topic.)
 
Old 02-18-2011, 10:26 AM   #4
wpeckham
Senior Member
 
Registered: Apr 2010
Location: Continental USA
Distribution: Debian, Ubuntu, Fedora, RedHat, DSL, Puppy, CentOS, Knoppix, Mint-DE, Sparky, Vsido, tinycore, Q4OS
Posts: 1,793

Rep: Reputation: 618Reputation: 618Reputation: 618Reputation: 618Reputation: 618Reputation: 618
OOPS

Thank you for the correction, and I apologize. I have not used Fedora since Fedora 11 and did not realize they had done that.

It somewhat rules out my use of fedora for the future, I use that a LOT.
 
Old 02-18-2011, 03:53 PM   #5
2007fld
Member
 
Registered: Mar 2007
Distribution: FD4,6
Posts: 52

Original Poster
Rep: Reputation: 15
Thanks!

Following your instructions, I did log in as root.

dmesg | grep -i error shows no errors. There is no file Xorg.0.log under /var/log

I just noticed that if I choose install with graphics, the whole screen becomes green again.

So it is related to the display issue.

I just tried "dell 1280x1024 laptop display panel" for monitor type. Still, after installation, reboot, whole screen is green.

How do I know exactly my monitor type? My laptop is Dell Latitue 100L.
 
Old 02-19-2011, 12:39 PM   #6
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,186

Rep: Reputation: 346Reputation: 346Reputation: 346Reputation: 346
No log file? Are you sure? (ls /var/log/ to check.) If there's really no Xorg.0.log file, that implies that you've never started the X-server on tty0.

So, do the "boot into Init level 3" thing again, and, instead pf logging in as "root," log in as your normal, non-privileged, user (if you've set up one), and run the startx script. That will attempt to start the X-server for the non-privileged user, and, if it fails, write some useful error messages on the terminal screen. (If the messages scroll off the screen, try startx | less so you can review the whole output.)

I suspect that your problem is that your video card is not being properly detected, and the incorrect driver is being loaded. If this is the case, you can log in as "root" and use the Xorg -configure to create an xorg.conf file in /root. Then edit that file so the driver in the "Device" section for your video card is correct, move it to /etc/X11/xorg.conf, and try the startx (after switching to a non-privileged user account) again. (Note that you may have an older version of the video card that requires an "obsolete" driver version, and the auto-detection may only be detection the brand, not the version.)

Oh, if you want to enable the use of the ctrl-alt-... switching, add a file like this:
Code:
$ sudo cat /etc/X11/xorg.conf.d/01-allow_zap.conf 
Section "ServerFlags"
  Option    "DontZap" "off"
  Option    "DontVTSwitch" "off"
EndSection
to the /etc/X11/xorg.conf.d/ directory. (See man xorg.conf for details.) Since the defaults were changed with version 4 of the X-server, any distribution that uses the newer release will behave like Fedora unless the distribution designers change the X-server "preferred" defaults.

<edit>
By the way, the reason I suggest running the startx script as a non-privileged user is to reduce the possibility that you'd make an open Internet connection as a privileged user which constitutes an avoidable security risk.
</edit>

Last edited by PTrenholme; 02-19-2011 at 12:45 PM.
 
Old 02-20-2011, 01:05 AM   #7
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,986

Rep: Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447
the current fedora 14 should auto detect the hardware in the laptop

NOW if you DID install one of the very OLD "core" version
fedora dropped the name "core" way back in fedora 6

fedora core 6 was the LAST to use the 'core' in the name
then fedora 6 and older might not recognize new hardware
 
Old 02-20-2011, 09:51 AM   #8
wpeckham
Senior Member
 
Registered: Apr 2010
Location: Continental USA
Distribution: Debian, Ubuntu, Fedora, RedHat, DSL, Puppy, CentOS, Knoppix, Mint-DE, Sparky, Vsido, tinycore, Q4OS
Posts: 1,793

Rep: Reputation: 618Reputation: 618Reputation: 618Reputation: 618Reputation: 618Reputation: 618
Problem

To refine, there have been some excellent suggestions. The problem has been narrowed down to a xorg video issue, not a boot issue. (Much thanks to PTrenholme!)

The suggestion that new versions of Fedora identify video hardware better is not well supported by experience or statistics, though I would tend to believe that newer Xorg install identify NEWER VIDEO HARDWARE better.

I know of many examples of older video hardware that worked fine on older versions, but does NOT work as well using the new drivers. In such cases there is always a way to back down to the older driver and get it to work, but it does take research and manual intervention.

I would learn all you can about what kind of video controller and monitor you have, the monitor characteristics (supported frequencies/modes etc), and drivers known to work with that controller. If all else fails you should be able to drop back to the basic VGA driver, although that may limit you to 600x800 resolution (the original basic VGA resolution options were quite limited).

Last edited by wpeckham; 02-20-2011 at 09:52 AM.
 
Old 02-20-2011, 12:28 PM   #9
DavidMcCann
Senior Member
 
Registered: Jul 2006
Location: London
Distribution: CentOS, Salix
Posts: 4,264

Rep: Reputation: 1246Reputation: 1246Reputation: 1246Reputation: 1246Reputation: 1246Reputation: 1246Reputation: 1246Reputation: 1246Reputation: 1246
Quote:
Originally Posted by PTrenholme View Post
By the way, newer Fedora releases - since Fedora 12 - no longer use the ctrl-alt-f7 mentioned by wpeckham, and, in fact, the default X-server settings completely disable all ctrl-alt switching. That default can be changed, but that a different topic.
Oh no they don't! The change is that the GUI has been moved to Ctrl-Alt-F1 instead of Ctrl-Alt-F7, and for a console log-in you need Ctrl-Alt-F2. I'm using F14 and I've just checked.
 
Old 02-20-2011, 12:51 PM   #10
Kenny_Strawn
Senior Member
 
Registered: Feb 2010
Location: /usa/ca/orange_county/lake_forest
Distribution: ArchBang, Google Android 2.1 + Motoblur (on Motortola Flipside), Google Chrome OS (on Cr-48)
Posts: 1,791
Blog Entries: 62

Rep: Reputation: 56
Quote:
Originally Posted by John VV View Post
the current fedora 14 should auto detect the hardware in the laptop

NOW if you DID install one of the very OLD "core" version
fedora dropped the name "core" way back in fedora 6

fedora core 6 was the LAST to use the 'core' in the name
then fedora 6 and older might not recognize new hardware
Agreed. Fedora Core refers to a list of Fedora releases that is 9 or more versions out of date. The OP *needs* to try a newer release.
 
Old 02-20-2011, 12:58 PM   #11
Kenny_Strawn
Senior Member
 
Registered: Feb 2010
Location: /usa/ca/orange_county/lake_forest
Distribution: ArchBang, Google Android 2.1 + Motoblur (on Motortola Flipside), Google Chrome OS (on Cr-48)
Posts: 1,791
Blog Entries: 62

Rep: Reputation: 56
And for the real list:

http://en.wikipedia.org/wiki/Fedora_Core#Releases

You'll see that Fedora Core stops at 6, and Fedora goes all the way to 14 (or, to be 9 versions out of date, I counted the Fedora 15 development release).

Last edited by Kenny_Strawn; 02-20-2011 at 01:01 PM.
 
Old 02-21-2011, 06:49 AM   #12
wpeckham
Senior Member
 
Registered: Apr 2010
Location: Continental USA
Distribution: Debian, Ubuntu, Fedora, RedHat, DSL, Puppy, CentOS, Knoppix, Mint-DE, Sparky, Vsido, tinycore, Q4OS
Posts: 1,793

Rep: Reputation: 618Reputation: 618Reputation: 618Reputation: 618Reputation: 618Reputation: 618
Xorg issue

So 2007fld.
What version of Fedora have you installed?
Have you tested with a recent live-cd?

What is your status now?
 
Old 02-21-2011, 01:27 PM   #13
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,186

Rep: Reputation: 346Reputation: 346Reputation: 346Reputation: 346
FYI, I jut upgraded my wife's system from F12 to F14, and I had to use the "basic video" installation mode because the Intel driver, used by default since her box has a Intel 915 video chipset on its mother board.

Because I'd installed using the "basic video" setting, the GRUB boot kernel lines were created with the nomodeset option on the line. So, when I tried to run startx with the Intel driver, I got the "No modeset kernel extensions" error, and no X-server. Changing the nomodeset to i915.modeset=1 fixed the problem, except that the initrd image loads its driver with the nomodeset option, so the screen is black while the system boots. (I could fix that by doing a mkinitrd omitting the video driver nonsense, but, for now, a couple minutes of "black screen" is no hardship. I can always run cat /var/log/boot.log if I suspect there was some problem during the boot.)

If you suspect that your problem is caused by a similar problem, run the command lspci -k | grep -A3 VGA to identify your hardware, and add the <hardware>.modeset=1 line to the kernel line in your /boot/grub/grub.conf file, where <hardware> is, of course, replace by the correct hardware name. (I haven't tried this, but just removing the nomodeset option might suffice.)

Last edited by PTrenholme; 02-21-2011 at 01:29 PM. Reason: Typo
 
Old 02-22-2011, 09:49 AM   #14
2007fld
Member
 
Registered: Mar 2007
Distribution: FD4,6
Posts: 52

Original Poster
Rep: Reputation: 15
It's working now.

I just downloaded FC13 image and burned it into a CD, and reinstalled. Everthing works great now.

The version I used before was too old, from a book I bought a while ago.

Thanks again!
This is resolved. I'll mark it as resovled

Last edited by 2007fld; 02-22-2011 at 09:50 AM.
 
Old 02-22-2011, 06:51 PM   #15
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,986

Rep: Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447
Quote:
I just downloaded FC13
fedora 13 ? why
fedora 14 is the current .
fedora 13 will hit END OF LIFE in 4 months .
So in 4 months there will NEVER be any more support for Fedora13 .
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Reboot Lunix fedora core 3 qarqeaan Linux - Newbie 2 03-04-2009 05:33 AM
Fedora Core 5 Computer Providing A Windows Xp Computer With Internet FedoraNewbie Linux - Networking 6 10-29-2006 12:24 AM
Rhythmbox on Fedora Core 3 causes reboot! SolidSnakeX28 Linux - Software 1 05-28-2005 09:47 PM
Fedora Core 3 shutdown and reboot max_232 Linux - Laptop and Netbook 3 03-29-2005 09:35 AM
Fedora (1) installed with no problems but hangs when reboot laptop sunjay Linux - Newbie 1 06-28-2004 06:13 PM


All times are GMT -5. The time now is 03:49 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration