LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 10-13-2005, 07:33 PM   #1
kiljoix
LQ Newbie
 
Registered: Oct 2005
Posts: 3

Rep: Reputation: 0
installed Fedora core 3 and now windows XP can't boot


I have just installed Fedora Core 3 on my Dell 8250 on an additional 250GB hard drive (hd1) and it seems that not only does Linux not recognize the pre-existing Windows XP OS (on hd0) in the start up mode where you should be able to toggle up and down to pick which OS to boot, but if I disable the Linux hard drive in the BIOS and boot from the windows hard drive alone I get only a black screen with GRUB in white letters in the top left corner. During the installation I was careful to exclude the windows hard drive from the install yet I suppose some part of the boot loader was added on to it anyhow. When I view the hard drives and partitions in Linux, however, the windows hard drive appears unaltered with a primary FAT32 partition (that's DELL utilities) and the remaining ntfs partition for XP.

I suppose that I need to either configure Linux to give me the Windows XP boot option or uninstall and try again. My only concern is that I am not left with one empty hard drive and one that will still only give me a black screen that says GRUB.

thanks for your help.
 
Old 10-13-2005, 07:39 PM   #2
chemdawg
Member
 
Registered: Jan 2005
Distribution: Mandriva
Posts: 206

Rep: Reputation: 30
Gee, that sounds like a blessing to me!

If you use KDE, go to the control center, or configure, or whatever FC3 has to manage boot. Then, look to see if windows is listed there. If it isn't you can add it. Just be sure to specify the partition. It should be something like /dev/hda0 or the like. After that, you just reboot and you should be able to toggle to windows at the boot screen.
 
Old 10-13-2005, 11:52 PM   #3
kiljoix
LQ Newbie
 
Registered: Oct 2005
Posts: 3

Original Poster
Rep: Reputation: 0
I looked all through the control center in KDE but didn't see anything that would allow me to configure my boot options, I also have gnome if you know any way to configure the boot with it.
 
Old 10-15-2005, 07:17 AM   #4
init100
LQ Newbie
 
Registered: Oct 2005
Location: Europe
Distribution: Fedora Core 4
Posts: 20

Rep: Reputation: 0
Re: installed Fedora core 3 and now windows XP can't boot

Quote:
I have just installed Fedora Core 3 on my Dell 8250 on an additional 250GB hard drive (hd1) and it seems that not only does Linux not recognize the pre-existing Windows XP OS (on hd0) in the start up mode where you should be able to toggle up and down to pick which OS to boot, but if I disable the Linux hard drive in the BIOS and boot from the windows hard drive alone I get only a black screen with GRUB in white letters in the top left corner.
I have exactly the same setup on the computer I write this from, although I run FC4. I had a lot of problems getting both to boot, but solved the problem after some digging around. The problem might be that Windows cannot boot from the second harddrive. You must trick Windows into believing that it is still on the first drive. This is my entry for Windows XP in /boot/grub/grub.conf:

Code:
title Windows XP
	rootnoverify (hd1,0)
	map (hd0) (hd1)
	map (hd1) (hd0)
	chainloader +1
Hope that this helps.
 
Old 10-15-2005, 07:46 AM   #5
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 12,505

Rep: Reputation: 1079Reputation: 1079Reputation: 1079Reputation: 1079Reputation: 1079Reputation: 1079Reputation: 1079Reputation: 1079
No, it seems Windows is indeed on the primary drive.
Quote:
. During the installation I was careful to exclude the windows hard drive from the install
If you de-selected the tick-box for Windows during the install, *you* told FC3 not to include it in the boot menu - at least, that's how I recall Redhat used to work. Add the following to the end of menu.lst, rather than that posted by init100
Code:
title Windows XP
	rootnoverify (hd0,1)
	chainloader +1
 
Old 10-15-2005, 07:57 AM   #6
pippo
Member
 
Registered: Aug 2005
Distribution: Gentoo
Posts: 38

Rep: Reputation: 15
I am not sure I have understood correctly. So you have a disk with windows and you installed linux on another hard drive while 'ignoring' the windows disk.

Here is a guess. The MBR was written at the beginning of the windows disk but the file grub.conf (which is read at startup) is on the linux drive. You can't boot windows probably because grub.conf is not correct. If disable the linux disk, grub tries to start according to what it found in the mbr but it can't because he want to read the grub.conf which is on the other disk.

If you give us details about you config (fstab and grub.conf), we can tell you what to put in grub.conf. The simplest thing is just to edit the file.
 
Old 10-15-2005, 11:53 AM   #7
init100
LQ Newbie
 
Registered: Oct 2005
Location: Europe
Distribution: Fedora Core 4
Posts: 20

Rep: Reputation: 0
If you enable both disks, what happens? Do you get a Grub menu? If not, do you get a Grub prompt? If not, what do you get? This will help us know where to begin.

If you get a menu, but you can only boot Linux, then there is probably an entry missing for Windows in grub.conf. Then you can add an an entry like the one that syg00 mentioned. Did you know that you can manually enter the commands to boot you computer at the Grub prompt? This means that before you add an entry to grub.conf, you can boot your computer and manually type in the lines in the grub.conf entry you want to try. If you get a menu, just type 'c' (without the quotes) to get to the Grub command prompt. From the Grub prompt, you can try:

Code:
rootnoverify (hd0,1)
chainloader +1
boot
and see if it works. This should boot you into Windows. If this does not work, try (again at the Grub prompt):

Code:
rootnoverify (hd0,1)
map (hd0) (hd1)
map (hd1) (hd0)
chainloader +1
boot

Last edited by init100; 10-15-2005 at 11:54 AM.
 
Old 10-24-2005, 06:42 PM   #8
kiljoix
LQ Newbie
 
Registered: Oct 2005
Posts: 3

Original Poster
Rep: Reputation: 0
Well it worked as far as adding Windows XP to the boot list and initilizing the boot but XP itself is having issues. Apparently it can't find autochk which causes a fatal error.
Not too worried about it but thanks for the help, now at least I understand more about GRUB.

patrick
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
dual boot windows xp fedora core dtra Linux - General 8 11-18-2005 10:10 PM
Using Windows XP to boot Fedora Core 1 cucolin@ Linux - Newbie 2 03-22-2005 02:30 AM
installed fedora core 1 and can't boot greg_wein Linux - Newbie 7 11-09-2004 11:49 PM
Help! I've installed Fedora Core2, now I can't boot into Windows! gashead Linux - Newbie 5 10-16-2004 03:38 PM
installed fedora 2...and now windows won't boot! Skawaii Linux - Newbie 4 10-02-2004 10:31 AM


All times are GMT -5. The time now is 02:42 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration