LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-31-2003, 07:26 AM   #1
qwijibow
LQ Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Rep: Reputation: 47
installed a new Windows manager, how to use it ?


Hi, ive installed a new windows manager AmiWM
(amiga clone ) those were the good old days!

anyway, ive configured, compiled, and installed it.

how do i setup X to use this WM ???

thanX
 
Old 08-31-2003, 09:06 AM   #2
jalal
Member
 
Registered: Aug 2003
Location: .bh
Distribution: Gentoo
Posts: 188

Rep: Reputation: 30
edit your $HOME/.xinitrc, and change the line starting with "exec" to the path of the new WM

e.g.

exec /usr/bin/amiwm

if it doesn't exist, you can just create it.
 
Old 08-31-2003, 09:33 AM   #3
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 58
That works if you use the console login and startx (my recommended method).

Of course, if you use a gui login, you have to use it's config file rather then .xinitrc. That file should be <dot x something> in your user home directory.
 
Old 08-31-2003, 10:28 AM   #4
qwijibow
LQ Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Original Poster
Rep: Reputation: 47
in my ~/ i have a .Xauthority .Xclients and a .Xclients-default.

but they all look quite xomplicated, and have no idea how to configure them.

i use redhat 9, and a graphical login.

as for the .xinitrc there are if's else's else if's all over the place, not sure where of how to add in the amiwm command

but that for the reply's so far.
 
Old 08-31-2003, 10:34 AM   #5
qwijibow
LQ Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Original Poster
Rep: Reputation: 47
i hashed out my .Xclients file, and added the last line.
this had NO effect, loggin off then back in still loaded KDE.



#!/bin/bash

# Created by Red Hat Desktop Switcher

#if [ -e "$HOME/.Xclients-$HOSTNAME$DISPLAY" ]; then
# exec $HOME/.Xclients-$HOSTNAME$DISPLAY
#else
# exec $HOME/.Xclients-default
#fi

exec amiwm
 
Old 08-31-2003, 10:39 AM   #6
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 58
In that case, to get where you want to go, you will either have to find the file that your gui login manager (probably gdm) uses and edit that file, or switch to console login and customize your .xinitrc file.
Code:
# Duron 950 box "uilleann" user fancy .xinitrc file
# Start the stuff I want to run when I startx

# The artwiz-fonts sometimes conflict with your locale settings. To get
# them to work you may have to put the following at the beginning of your
# .xinitrc file
# export LC=C
# export LC_ALL=C
# Esetroot ~/backgrounds/linux.png &
# Start	gkrellm	and put	it in the slit
gkrellm -w &
# This will run a screensaver as your background
# /usr/X11R6/lib/xscreensaver/hopalong -root &
# Start	the screensaver	daemon
xscreensaver &
# Finally, I start my window manager
exec fluxbox
# exec kde
# exec gnome-session

Last edited by fancypiper; 08-31-2003 at 10:43 AM.
 
Old 08-31-2003, 10:48 AM   #7
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 58
Perhaps this will help
Runlevels and XFree86
 
Old 08-31-2003, 10:54 AM   #8
qwijibow
LQ Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Original Poster
Rep: Reputation: 47
well thanx, i defaulted to runllevel 3, and started the gui via startx.

only to find that the WM half works, and makes x report many many invalid windows that that and the other errors

ohh well, but thatX, now i know how its done, ill go find som more WM's
 
Old 08-31-2003, 11:01 AM   #9
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 58
You may have to when you run something besides gnome/kde as most lightweight stuff requres some hand configuration. Have you explored any documentation on that WM?

As you see, I prefer fluxbox and I am familiar with some of it's features, but I had to read a lot...

Last edited by fancypiper; 08-31-2003 at 11:08 AM.
 
Old 08-31-2003, 11:27 AM   #10
BigBadPenguin
Member
 
Registered: Jun 2003
Location: Warwick (.ac.uk)
Distribution: Arch, Slackware 9.0, (knoppix standing by)
Posts: 256

Rep: Reputation: 30
gdm uses /etc/gdm/Sessions to work out what window managers to show (if you are using GDM). As far as i know you have to use this, not a file in the home directory (yep, just checked at GDM site) You need to do two things. Add an entry to Xsession to run your window manager, then make a new file in Sessions to add an entry to the GDM menu.
I: go down to the bit in Xsession that looks something like this:
enlightenment)
exec enlightenment
;;
twm)
xclock -geometry 50x50-1+1 &
xterm -geometry 80x50+494+51 &
xterm -geometry 80x20+494-0 &
xterm -geometry 80x66+0+0 -name login &
xsetroot -solid SteelBlue
exec twm
;;
openbox)
exec openbox
;;
waimea)
exec waimea
and put under your last entry :
amiwm)
exec amiwm
;;
(this assumes the command for AmiWM is amiwm, if it isn't, just change the word after exec.)

II:
Put this in a file called AmiWM or what ever you want the menu entry to look like:

#!/bin/bash -login

/etc/gdm/Sessions/Xsession amiwm
You can add other stuff in here too, if you want it to run when the WM runs, just don't forget to tell them to run in the background by putting & after each command. If that sounds confusing, here's my Waimea file for reference.

#!/bin/bash -login
#screensaver
xscreensaver &
/home/ed/bin/startBackgrounds &
/etc/gdm/Sessions/Xsession waimea

Now, with any luck that's all. Just restart GDM (either by doing 'skill gdm-binary', then 'gdm' or 'init 3' then 'init 5') and hopefully you'll now have the option in GDM to boot in to amiwm.

EDIT: damn, THREE whole posts while i type? That has to be a record. Hope this isn't redundant now.

Last edited by BigBadPenguin; 08-31-2003 at 11:29 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
RPM package manager says package needs to be installed. But I already installed it! nick623 Linux - Software 2 05-24-2005 02:15 AM
Just installed debian with a desktop manager, don't want xdm starting. Royle Linux - Newbie 2 01-09-2005 06:46 AM
Changing desktop manager loses ATI driver installed? krazibon3 Linux - Newbie 2 08-25-2004 10:41 PM
Installed XFree86 4.3 - now only have xterm. Where's the window manager? BrianK Linux - General 5 12-12-2003 01:38 PM
GNOME print manager not finding installed printer wfpoole Red Hat 12 10-31-2003 07:53 PM


All times are GMT -5. The time now is 05:50 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration