LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-02-2003, 11:13 PM   #1
CT Pennell
LQ Newbie
 
Registered: Feb 2003
Distribution: Yoper
Posts: 4

Rep: Reputation: 0
Installation question...


I'm using Yoper and i like it ALOT. Its using KDE. One main question. I'm trying to install AIM and it says i need like 20 glib files and so i downloaded them but now i need to know where in the world to extract them. I am super Newb so please help me out. Thank you.

Last edited by CT Pennell; 02-03-2003 at 12:28 AM.
 
Old 02-03-2003, 06:09 AM   #2
mhearn
LQ Guru
 
Registered: Nov 2002
Location: Durham, England
Distribution: Fedora Core 4
Posts: 1,565

Rep: Reputation: 47
When you say "AIM" what program exactly are you referring to? Gaim? The aol official client (avoid it!)?

Also, you need to be more specific about what files it needs. Dependancy hell is a common issue on Linux, esp with newbies, but we can't help if you don't tell us exactly what goes wrong.
 
Old 02-03-2003, 01:28 PM   #3
CT Pennell
LQ Newbie
 
Registered: Feb 2003
Distribution: Yoper
Posts: 4

Original Poster
Rep: Reputation: 0
When I say AIM i mean AOL instant messenger. It needs these files:
"error: Failed dependencies:
ld-linux.so.2 is needed by aim-1.1.112-1
libX11.so.6 is needed by aim-1.1.112-1
libXext.so.6 is needed by aim-1.1.112-1
libXi.so.6 is needed by aim-1.1.112-1
libc.so.6 is needed by aim-1.1.112-1
libdl.so.2 is needed by aim-1.1.112-1
libgdk-1.2.so.0 is needed by aim-1.1.112-1
libglib-1.2.so.0 is needed by aim-1.1.112-1
libgmodule-1.2.so.0 is needed by aim-1.1.112-1
libgtk-1.2.so.0 is needed by aim-1.1.112-1
libm.so.6 is needed by aim-1.1.112-1
libpthread.so.0 is needed by aim-1.1.112-1
libstdc++-libc6.1-1.so.2 is needed by aim-1.1.112-1
libICE.so.6 is needed by aim-1.1.112-1
libSM.so.6 is needed by aim-1.1.112-1
libXmu.so.6 is needed by aim-1.1.112-1
libXt.so.6 is needed by aim-1.1.112-1
libm.so.6(GLIBC_2.1) is needed by aim-1.1.112-1
libc.so.6(GLIBC_2.0) is needed by aim-1.1.112-1
libpthread.so.0(GLIBC_2.0) is needed by aim-1.1.112-1
libc.so.6(GLIBC_2.1) is needed by aim-1.1.112-1
libdl.so.2(GLIBC_2.1) is needed by aim-1.1.112-1
libdl.so.2(GLIBC_2.0) is needed by aim-1.1.112-1
libpthread.so.0(GLIBC_2.1) is needed by aim-1.1.112-1"

All of these files are in glibc-2.3.1.tar.gz and glib-2.2.0.tar.gz and gtk+-2.2.0.tar.gz or should be (thats what the AIM website says.). I have these files but i dont know where I would need to unzip these files or what do i do? Thank you, CT

Last edited by CT Pennell; 02-03-2003 at 01:45 PM.
 
Old 02-03-2003, 03:24 PM   #4
Tih8710
Member
 
Registered: Jan 2003
Location: Finland
Distribution: ElementaryOS Freya as main, every other ubuntu-based as testing
Posts: 124

Rep: Reputation: 15
Hi!

If those files have binaries, then I *assume* that they have also the right directory structure included, which means that you *can*? unTAR them into /. (Don't count on this..)

On the other hand, I believe that they include only the sources, and in that case, untar them where ever you want, and from that dir read README.xxxxxx for more instructions. (i.e running configure, make, make install etc..)
 
Old 02-03-2003, 04:39 PM   #5
mhearn
LQ Guru
 
Registered: Nov 2002
Location: Durham, England
Distribution: Fedora Core 4
Posts: 1,565

Rep: Reputation: 47
Whaaa? Yoper should provide _all_ of those. What packaging system do they use again? You shouldn't need to install any of those files, I can nearly guarantee they are all present.
 
Old 02-03-2003, 08:50 PM   #6
CT Pennell
LQ Newbie
 
Registered: Feb 2003
Distribution: Yoper
Posts: 4

Original Poster
Rep: Reputation: 0
what do you mean by packaging system?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Installation Question k1ll3r_x Slackware - Installation 3 10-01-2004 07:33 PM
Installation question satimis Debian 1 09-11-2004 08:03 PM
Installation Question DaveThePuzzled Linux - Newbie 8 05-23-2004 03:44 AM
installation question today53 Linux - Newbie 3 10-13-2003 12:32 AM
Installation Question Iconit Linux - Newbie 2 07-29-2003 03:46 AM


All times are GMT -5. The time now is 05:31 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration