LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-10-2013, 04:02 AM   #1
Sharath Ravi
Member
 
Registered: Jun 2012
Posts: 37

Rep: Reputation: Disabled
Installation of rails 3.1 package


Hi,

Trying to install rails 3.1 package on Centos server i am getting this error

When trying to run this command

#gem install rails 3.1
ERROR: Loading command: install (LoadError)
cannot load such file -- zlib
ERROR: While executing gem ... (NameError)
uninitialized constant Gem::Commands::InstallCommand

zlib is already installed

zlib-1.2.3-7.el5.i386 already installed and latest version

I have installed ruby 1.9.3p0 (2011-10-30) [i686-linux]

Can some1 help me out on this issue

thanks in advance

Last edited by Sharath Ravi; 04-10-2013 at 04:27 AM.
 
Old 04-10-2013, 10:01 AM   #2
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 18,343

Rep: Reputation: 3909Reputation: 3909Reputation: 3909Reputation: 3909Reputation: 3909Reputation: 3909Reputation: 3909Reputation: 3909Reputation: 3909Reputation: 3909Reputation: 3909
Quote:
Originally Posted by Sharath Ravi View Post
Hi,
Trying to install rails 3.1 package on Centos server i am getting this error. When trying to run this command

#gem install rails 3.1
ERROR: Loading command: install (LoadError)
cannot load such file -- zlib
ERROR: While executing gem ... (NameError)
uninitialized constant Gem::Commands::InstallCommand

zlib is already installed
zlib-1.2.3-7.el5.i386 already installed and latest version

I have installed ruby 1.9.3p0 (2011-10-30) [i686-linux]
Can some1 help me out on this issue
Spell out your words, please. And did you try to look this error up?? zlib is already installed, but it's probably looking for the zlib-DEVEL package. Try "yum search zlib*", and install the zlib development package. Also, why are you specifically trying to install rails 3.1, rather than just typing in "gem install rails"???

And what version of CentOS are you using?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Rails::API strips the fat off Ruby on Rails LXer Syndicated Linux News 0 11-23-2012 10:50 PM
getting rails console to work on Ubuntu 11.04 with RVM and rails 3.0.9 murankar Linux - Software 0 07-17-2011 03:28 PM
emacs rails installation Qu3ry Programming 4 11-01-2009 11:52 AM
[SOLVED] [Ruby on Rails] backticks don't work under rails. bartonski Programming 1 09-08-2009 05:19 PM
LXer: Real world Rails: Caching in Rails LXer Syndicated Linux News 0 05-19-2007 10:16 PM


All times are GMT -5. The time now is 05:36 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration