LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-17-2015, 06:06 PM   #16
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016 CentOS6.9 CentOS7.3 + 50+ other Linux OS, for test only.
Posts: 16,658

Rep: Reputation: 3281Reputation: 3281Reputation: 3281Reputation: 3281Reputation: 3281Reputation: 3281Reputation: 3281Reputation: 3281Reputation: 3281Reputation: 3281Reputation: 3281
compat-gcc34 / compat-g++34 for Ubuntu 10.04, 10.10 - i686


Re #15.

Compiler packages compat-gcc34 / compat-g++34 for Ubuntu 10.04, 10.10 .
Packages : compat-g++34_3.4.6-ubuntu10_i386.deb
.. depends on : compat-gcc34_3.4.6-ubuntu10_i386.deb

compat-gcc34 https://drive.google.com/file/d/0B7S...ew?usp=sharing
compat-g++34 https://drive.google.com/file/d/0B7S...ew?usp=sharing


My test with { Ubuntu 10.04 - 32bits , ns229 + nist-mob } :
$ export CC=gcc34 CXX=g++34 && ./install : OK.

-

Last edited by knudfl; 04-17-2015 at 06:13 PM.
 
Old 04-19-2015, 01:43 AM   #17
najat
Member
 
Registered: Apr 2015
Posts: 58
Blog Entries: 1

Original Poster
Rep: Reputation: Disabled
I'm using ubuntu 10.04-i386.I could'nt install the packages
 
Old 04-19-2015, 02:34 AM   #18
najat
Member
 
Registered: Apr 2015
Posts: 58
Blog Entries: 1

Original Poster
Rep: Reputation: Disabled
When i execute now the command: patch -p0<pmip6-for-ns-2.29-nist.patch :
I have this erroratching file ns-2.29/ucbt-0.9.8.2a/ns-2.29/packet.h
Hunk #1 succeeded at 209 with fuzz 2 (offset 8 lines).
Hunk #2 FAILED at 328.
1 out of 2 hunks FAILED -- saving rejects to file ns-2.29/ucbt-0.9.8.2a/ns-2.29/packet.h.rej
what can i do ?
 
Old 04-19-2015, 03:17 AM   #19
najat
Member
 
Registered: Apr 2015
Posts: 58
Blog Entries: 1

Original Poster
Rep: Reputation: Disabled
When i execute now the command: patch -p0<pmip6-for-ns-2.29-nist.patch :
I have this error: patching file ns-2.29/ucbt-0.9.8.2a/ns-2.29/packet.h
Hunk #1 succeeded at 209 with fuzz 2 (offset 8 lines).
Hunk #2 FAILED at 328.
1 out of 2 hunks FAILED -- saving rejects to file ns-2.29/ucbt-0.9.8.2a/ns-2.29/packet.h.rej
what can i do ?
 
Old 04-19-2015, 03:37 AM   #20
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016 CentOS6.9 CentOS7.3 + 50+ other Linux OS, for test only.
Posts: 16,658

Rep: Reputation: 3281Reputation: 3281Reputation: 3281Reputation: 3281Reputation: 3281Reputation: 3281Reputation: 3281Reputation: 3281Reputation: 3281Reputation: 3281Reputation: 3281
Re #17.
Quote:
I'm using ubuntu 10.04 - i386. I could'nt install the packages
Try again :
$ cd Downloads/ ( Or wherever you keep the compat-g** packages.)
$ ls compat-g* ( To be sure the packages are present.)
$ dpkg -i compat-gcc34_3.4.6-ubuntu10_i386.deb compat-g++34_3.4.6-ubuntu10_i386.deb

... You will have to install the packages : No compat-g++34 : No nist-mob !


-
 
Old 04-19-2015, 04:47 AM   #21
najat
Member
 
Registered: Apr 2015
Posts: 58
Blog Entries: 1

Original Poster
Rep: Reputation: Disabled
the packages installation was comlpleted.But i want to install the patch i got this error :ns-2.29/ucbt-0.9.8.2a/ns-2.29/packet.h
Hunk #1 succeeded at 209 with fuzz 2 (offset 8 lines).
Hunk #2 FAILED at 328.
1 out of 2 hunks FAILED -- saving rejects to file ns-2.29/ucbt-0.9.8.2a/ns-2.29/packet.h.rej
When i want to execute the command :export CC=gcc34 CXX=g++34 && ./install
g++34 -c -DUSE_802_21 -DTCP_DELAY_BIND_ALL -DNO_TK -DTCLCL_CLASSINSTVAR -DNDEBUG -DLINUX_TCP_HEADER -DUSE_SHM -DHAVE_LIBTCLCL -DHAVE_TCLCL_H -DHAVE_LIBOTCL1_11 -DHAVE_OTCL_H -DHAVE_LIBTK8_4 -DHAVE_TK_H -DHAVE_LIBTCL8_4 -DHAVE_TCL_H -DHAVE_CONFIG_H -DNS_DIFFUSION -DSMAC_NO_SYNC -DCPP_NAMESPACE=std -DUSE_SINGLE_ADDRESS_SPACE -Drng_test -I. -I/home/najat/ns-allinone-2.29/tclcl-1.17 -I/home/najat/ns-allinone-2.29/otcl-1.11 -I/home/najat/ns-allinone-2.29/include -I/home/najat/ns-allinone-2.29/include -I/usr/include/pcap -I./tcp -I./sctp -I./common -I./link -I./queue -I./adc -I./apps -I./mac -I./mobile -I./trace -I./routing -I./tools -I./classifier -I./mcast -I./diffusion3/lib/main -I./diffusion3/lib -I./diffusion3/lib/nr -I./diffusion3/ns -I./diffusion3/filter_core -I./asim/ -I./qs -I./diffserv -I./satellite -I./bluetooth -I./hsntg -I./hsntg/802_21 -I./wimax -I./interference -I./myevalvid -I./wpan -o common/scheduler.o common/scheduler.cc
In file included from common/scheduler.cc:48:
common/packet.h:209: error: redefinition of `PT_PBU'
common/packet.h:205: error: `PT_PBU' previously defined here
common/packet.h:210: error: redefinition of `PT_PBACK'
common/packet.h:206: error: `PT_PBACK' previously defined here
common/packet.h:213: error: redefinition of `PT_PBU'
common/packet.h:205: error: `PT_PBU' previously defined here
common/packet.h:214: error: redefinition of `PT_PBACK'
common/packet.h:206: error: `PT_PBACK' previously defined here
common/packet.h:217: error: redefinition of `PT_PBU'
common/packet.h:205: error: `PT_PBU' previously defined here
common/packet.h:218: error: redefinition of `PT_PBACK'
common/packet.h:206: error: `PT_PBACK' previously defined here
make: *** [common/s
 
Old 04-19-2015, 05:19 AM   #22
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016 CentOS6.9 CentOS7.3 + 50+ other Linux OS, for test only.
Posts: 16,658

Rep: Reputation: 3281Reputation: 3281Reputation: 3281Reputation: 3281Reputation: 3281Reputation: 3281Reputation: 3281Reputation: 3281Reputation: 3281Reputation: 3281Reputation: 3281
Re #21.
Quote:
Hunk #2 FAILED at 328.
Yes, we know that already from posts #18, #19 : Do not repeat questions/posts !
Anyway no reason to answer before you managed to handle a package install.


Quote:
When I execute now the command: patch -p0<pmip6-for-ns-2.29-nist.patch
Next : You will have to copy/paste commands. Do not type anything.
Please delete "ns-allinone-2.29/" : A wrecked ns2 cannot be reused.
Then start from scratch with ns-allinone-2.29.3.tar.gz,
unpacked to a new folder in /home/<name>/. ( Not the Desktop/ ! )
And the ns-allinone-2.29 must be update 3 :
http://vorboss.dl.sourceforge.net/pr...-2.29.3.tar.gz

"patch -p0<pmip6-for-ns-2.29-nist.patch" is wrong. Two missing <space>`s. See post #2.
And make sure that the patch is applied in ns-allinone-2.29/, not ns-2.29/.
Please use the 'pwd' command to check that your location is correct.


-
 
Old 04-19-2015, 09:34 AM   #23
najat
Member
 
Registered: Apr 2015
Posts: 58
Blog Entries: 1

Original Poster
Rep: Reputation: Disabled
thanks the installation was successful
 
Old 11-20-2016, 10:41 PM   #24
andy pheony
LQ Newbie
 
Registered: Nov 2016
Posts: 3

Rep: Reputation: Disabled
PMIPv6 error in installing

HI

I am trying to install PMIPv6. how should i do? There is no support for 10.04 and centos 6.5

Plz help me
 
  


Reply

Tags
compat-g++34, nist-mob, ns2, pmip6


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Install ns2.29 on Ubunto 11.04(NIST Mobility Patch) fahimeh_ak Programming 38 03-24-2015 06:45 AM
Please help me with NIST Net installation netbaby Linux - Software 0 09-24-2011 12:51 PM
About NIST Net installation netbaby Linux - Networking 3 09-21-2011 08:23 AM
NIST Net Installation on Fedora gebronmc Fedora 6 04-21-2010 02:09 PM


All times are GMT -5. The time now is 04:20 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration