LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-09-2011, 11:05 AM   #1
NabiVakili
LQ Newbie
 
Registered: Feb 2011
Posts: 13

Rep: Reputation: 6
Question installation of NS2 (otcl make failed)


I'm trying to install NS2.27
I have to use this version, so I started the installation.
There were some errors, I fixed them one by one.
but there is an error that I can't pass it. I really tired of searching the Net for errors...

the installation process stops here :
Code:
gcc-4.3 -o otclsh  -g -O2 -I. -I/home/nabi/Desktop/ns-allinone-2.27/include -I/home/nabi/Desktop/ns-allinone-2.27/include -I/include  otclAppInit.c \
    -L. -lotcl -L/home/nabi/Desktop/ns-allinone-2.27/lib -ltk8.4 -L/home/nabi/Desktop/ns-allinone-2.27/lib -ltcl8.4 -lXext -lX11  -lnsl -ldl -lm
/tmp/cc8MtFKZ.o: In function `Tcl_AppInit':
/home/nabi/Desktop/ns-allinone-2.27/otcl-1.8/otclAppInit.c:237: undefined reference to `Otcl_Init'
collect2: ld returned 1 exit status
make: *** [otclsh] Error 1
otcl-1.8 make failed! Exiting ...
would you mind help me plz?
Thanks
 
Old 04-09-2011, 03:07 PM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154
Welcome to LQ.

Installing ns-allinone-2.27 on Ubuntu, post #3 here
http://www.linuxquestions.org/questi...9-10-a-782356/

More info http://www.linuxquestions.org/questi...2-27-a-785379/

And LQ Search : Tag = ns227
LQ Search : Keyword = ns-allinone
etc.
 
Old 04-10-2011, 02:00 PM   #3
NabiVakili
LQ Newbie
 
Registered: Feb 2011
Posts: 13

Original Poster
Rep: Reputation: 6
Question ns make failed!

Thanks for your post,
I read those posts and started the installation of NS 2.27
I fixed many errors, now I have this error
Code:
trace/cmu-trace.o: file not recognized: File format not recognized
collect2: ld returned 1 exit status
make: *** [ns] Error 1
Ns make failed!
I removed the object file and started the installation again,
but this error occurred for another object file.

I removed all of object files and started the installation.
but I have this error:
Code:
trace/cmu-trace.cc:1627: error: jump to case label
trace/cmu-trace.cc:1598: error:   crosses initialization of `AODV_msg*aodv_msg'
make: *** [trace/cmu-trace.o] Error 1
Ns make failed!
I want to fix this error and start the installation again,
but I want to start the installation for NS only, not from beginning and for all of packages,
because all of other packages has been installed successfully and I want to install the NS2 only
How can I do that?
 
Old 04-10-2011, 02:42 PM   #4
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154
When you follow the instructions in the mentioned post #3,
there are no errors.
( Except Ubuntu 10.10 64bits, an issue in one of the separate tools
in ns-2.27/indep-utils : Edit a Makefile to CPP = g++-3.3 ).

Quote:
I fixed many errors
Which errors ? Nothing should have to be fixed.

Which compiler do you see in the text, when you run install ?
g++ ? Or g++-3.3 ?

..

Last edited by knudfl; 04-10-2011 at 02:44 PM.
 
Old 04-11-2011, 03:45 AM   #5
NabiVakili
LQ Newbie
 
Registered: Feb 2011
Posts: 13

Original Poster
Rep: Reputation: 6
I found that there was some changes in the codes of NS2,
because this package (NS2) isn't the NS2.27 all in one.
It's allinone + some extensions provided by Qinghua Wang : http://apachepersonal.miun.se/~qinwan/resources.htm

finally I installed this NS2 successfully!

Thanks for your help
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ns2 - some validation tests failed shojaru Linux - Newbie 72 10-25-2012 03:41 PM
[SOLVED] Validation failed in NS2.34 in ubuntu 10.04 remix PAVAI Linux - Newbie 13 07-30-2012 06:47 AM
NS2 installation problem: no rule to make target 'VERSION' , needed by gen/version.c bilabongster Linux - Newbie 23 12-07-2011 12:54 PM
tk8.4.11 make failed---a problem about ns2 install !!! blueskyhff Linux - Software 1 07-03-2007 03:26 AM
problem with re-make in ns2.26 newbie06 Red Hat 1 12-18-2006 07:42 PM


All times are GMT -5. The time now is 08:24 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration