LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-02-2013, 11:26 AM   #1
sonatasin
LQ Newbie
 
Registered: Mar 2013
Posts: 11

Rep: Reputation: Disabled
Unhappy installation of ns-allinone 2.34


hellow, i m trying to install ns-allinone 2.34 in ubuntu 10.04 i have followed all the steps but when i tape "./install" i have this error:
Warning: tclStubInit.c may be out of date.
Developers may want to run "make genstubs" to regenerate.
This warning can be safely ignored, do not report as a bug!
Installing libtcl8.4.a to /home/rain/ns-allinone-2.34/lib/
cp: cannot create regular file `/home/rain/ns-allinone-2.34/lib/#inst.8390#': Permission denied
rm: cannot remove `/home/rain/ns-allinone-2.34/lib/libtcl8.4.a': Permission denied
mv: cannot stat `/home/rain/ns-allinone-2.34/lib/#inst.8390#': No such file or directory
ranlib: could not create temporary file whilst writing archive: No more archived files
make: *** [install-binaries] Error 1
tcl8.4.18 installation failed.
Tcl is not part of the ns project. Please see www.Scriptics.com
to see if they have a fix for your platform.
pleaaaaaaaaaaaase help me
 
Old 03-02-2013, 11:31 AM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154
Quote:
Permission denied
Happens when a command was used with 'sudo'.
No sudo is required for any ns2 command.
May be you used : sudo tar xvf ns-allinone-2.34.tar.gz ?

Better delete "ns-allinone-2.34/", and start from scratch.

-
 
1 members found this post helpful.
Old 03-02-2013, 05:39 PM   #3
sonatasin
LQ Newbie
 
Registered: Mar 2013
Posts: 11

Original Poster
Rep: Reputation: Disabled
i deleted ns-allinone-2.34 and restart all over but when i tape "ns" the result is : command not found
what can i do ?? i am realy hopeless
 
Old 03-02-2013, 05:40 PM   #4
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,825

Rep: Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408
? Are you in the correct folder ?
 
Old 03-02-2013, 05:45 PM   #5
sonatasin
LQ Newbie
 
Registered: Mar 2013
Posts: 11

Original Poster
Rep: Reputation: Disabled
yes i am
 
Old 03-03-2013, 03:56 AM   #6
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154
You haven't really specified all your commands.
So you could have an error somewhere.

Standard procedure for ns-allinone-2.34 and Ubuntu 10.04 :
sudo apt-get install \
g++ g++-4.1 autoconf automake make patch libtool libxmu-dev xgraph

cd ns-allinone-2.34/ && export CC=gcc-4.1 CXX=g++-4.1 && ./install

Testing 'ns' : cd ns-allinone-2.34/ns-2.34/ ; ls ns*
.. If the executable 'ns' is present, please type ./ns
.. And if it's OK, you can install 'ns' :
sudo make install
( 'make install' will copy 'ns' to /usr/local/bin/ : A system PATH.)

-
 
1 members found this post helpful.
Old 03-03-2013, 07:19 AM   #7
sonatasin
LQ Newbie
 
Registered: Mar 2013
Posts: 11

Original Poster
Rep: Reputation: Disabled
it worked !!! thx thx thx thx thx thx thx thx thx thx thx thx thx thx thx thx u realy save me
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Configuring of AP in ns-allinone-2.34 Thanujas Linux - Newbie 3 05-24-2012 07:17 AM
Installation problem of ns allinone 2.29 on Ubuntu 9.10 labee Linux - Software 3 05-05-2011 10:13 AM
ns-allinone-2.34 shaifulaziz Linux - Newbie 3 03-24-2011 04:37 PM
installation of ns-allinone-2.33 on fedora 11 xwz Linux - Software 12 09-03-2009 09:02 AM
Installation problem -cmu-extendedns-1.2.2 in ns-allinone-2.31 Anithagec Linux - Networking 0 09-25-2008 07:00 AM


All times are GMT -5. The time now is 01:07 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration