LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Installation help with a Thinkpad 560X (http://www.linuxquestions.org/questions/linux-newbie-8/installation-help-with-a-thinkpad-560x-21064/)

jholbrook 05-15-2002 08:33 PM

Installation help with a Thinkpad 560X
 
Here's the thing - I actually installed RedHat 7.2 without any problems. I made the two boot disks (one system and one PCMCIA driver disk), and I had no problems installing the OS from my USB cd-rom.

What is strange is that after it rebooted, it seems like none of the drivers are loaded to use my network card, external floppy, or USB cd-rom. Linux seems to run okay, but it's like all the external devices don't exist.

I guess I just need to do something so that the right drivers will be loaded when I start the system, but I don't know how to do that. I would be very grateful for any suggestions. If you need any additional information to be able to answer my question, please let me know. Thanks very much.


--Jon

jglen490 05-16-2002 01:50 PM

Did you use the "expert" install option? It's the one that walks you through every step. It should have asked you about USB devices and PCMCIA slots and such.

As for the network card and the external floppy. Is the network card internal, or installed in a PCMCIA slot? Is the the external floppy on a USB port or a proprietary connector?

jholbrook 05-16-2002 02:02 PM

No, I don't even remember seeing an "expert" option, so I will definitely try reinstalling it and watch for that option.

As for the hardware, the network card is a PCMCIA combo 56k modem and 10/100 ethernet. Either 3Com or Xircom...I don't recall. The floppy drive is a proprietary IBM thing, not USB. The cd-rom is a generic 12x IDE drive that I put into a case from an HP external CD burner after the HP drive died.

Can you tell me what I'm looking for during the installation? Will it ask me something like "what drivers should be loaded at start-up" or something like that?


Thanks very much.

jglen490 05-17-2002 07:13 AM

The 3COM combo PCMCIA card may work out of the box, but it depends on the exact model. A Xircom combo card usually works. Try to find the exact model number and go to the Winmodems are not modems page . About half way down the page there's a link to a table of modems. Click there and do a search on your combo card's model number. In the left column of the table is an indicator as to whether it's a Winmodem :( , tested and works with Linux :) , or unknown :o . There is also some real good info on that page about how some Winmodems can be made to work with Linux -- for those manufacturer's that cooperate with the Linux community.

As for your floppy drive, I have a ThinkPad (TP365CD) with an external connection that just works! Does yours not work on installation, or does it not work after installation? After install, can you post your /etc/fstab file here? That may show the source of the problem.

For your CD-Rom, what type of connection does it have with the laptop? Is it a parallel connection, USB, PCMCIA?

Actually, during setup, I think as it probes the hardware (serial ports, USB, etc.), it should ask display/ask for confirmation the harware it finds. Again, that may be in the "expert" type install process. I'm really more familiar with Mandrake that RedHat, but they still have certain similarities, although the details may be a little different.

jholbrook 05-17-2002 11:12 AM

I'm sorry - I should have mentioned that I installed RedHat 7.2 on a different laptop a couple months ago, using this same card, and didn't have any problems. Worked right out of the box, as they say. So whatever the problem is, I think it's the same issue with all 3 devices (PCMCIA ethernet, IBM external floppy, and USB cd-rom). Because I was able to see them and use them during installation, but then got nothing after I rebooted, I assume there is a package of drivers that was on the floppy disks but did not get included in the installation itself.

Over the weekend, I will try to set it all back up as an "expert." Please check back again on Monday for an update. And thank you very much for your time and assistance. People like you are the reason that people like me are switching to Linux.

--Jon

jglen490 05-17-2002 12:17 PM

You're welcome!!

Sometimes you bite the bear, sometimes the bear bites you!! When I installed Mandrake 8.0 sometime back on my laptop, it was a different experience than on a desktop system. So hardware and how it all interacts does make a difference.

Hang in there, have patience, and have fun with it :D !! I love Linux on my laptop.

jholbrook 05-21-2002 08:15 PM

My new theory is that I need to update the BIOS on the laptop so that it will "see" some things when it starts up. I was planning on making this a dual-boot system, and I learned that I can't load Windows 2000 without the upgrade. Perhaps Linux has a similar problem, where the Thinkpad is not properly registering certain devices at start-up....

Unfortunately, the BIOS upgrade program won't run until I get a new battery. I guess IBM is afraid that if the power goes out and there is no battery, it will ruin the laptop. I say it should be my decision to risk it (there's no battery on my DESKTOP, right?), but oh well.

So until that arrives in the mail, I'm stuck. If you are still tracking this, then thanks very much for your help and if anything else comes up I will update the post. Have a good week.

--Jon

jglen490 05-22-2002 07:15 AM

O.K. A BIOS update never hurts on these older systems. It did a lot of good for my TP365XD. Come back if you have more questions :) .


All times are GMT -5. The time now is 05:22 AM.