LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-25-2009, 11:11 AM   #1
AeonX
LQ Newbie
 
Registered: Jul 2009
Posts: 21

Rep: Reputation: 0
Unhappy Installation


Do I need to put the files in a specific folder before installing it from the terminal?It keeps telling me that the file is not in the directory
 
Old 12-25-2009, 11:14 AM   #2
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
What are you trying to do? (e.g.: Installing what from the terminal?)

If you are installing software, there are often install scripts that must be run in the directory where other key files are.

Please also tell us what version of Linux you are using.
 
Old 12-25-2009, 11:17 AM   #3
AeonX
LQ Newbie
 
Registered: Jul 2009
Posts: 21

Original Poster
Rep: Reputation: 0
i am using ubuntu 9.04!
And it happens every time i try to install a .bin file or a tar file
 
Old 12-25-2009, 11:42 AM   #4
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 6,870

Rep: Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248
Quote:
It keeps telling me that the file is not in the directory
Is the file in the directory referred to? Are you in the directory the file refers to in the terminal? Are you doing this in a terminal? What is the "IT" you are referring to that is telling you things?

As requested above, specific information would be helpful. If it happens every time, you should be able to remember one program that failed in this manner.
 
Old 12-25-2009, 11:55 AM   #5
AeonX
LQ Newbie
 
Registered: Jul 2009
Posts: 21

Original Poster
Rep: Reputation: 0
ok, i'm trying to install jre-6u17-linux-i586-rpm.bin and the file is on the desktop.

can you tell me what the commands that i should type to install it?
 
Old 12-25-2009, 12:16 PM   #6
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,275

Rep: Reputation: 370Reputation: 370Reputation: 370Reputation: 370
Your probably need to change to the desktop directory, e.g.:

Code:
cd ~/Desktop
then run the file to install it:

Code:
chmod +x jre-6u17-linux-i586-rpm.bin
./jre-6u17-linux-i586-rpm.bin
However, there are a couple problems. I don't think Ubuntu supports RPM well so you should have gotten the regular .bin and not the rpm.bin. Secondly, at least with Ubuntu 9.10. The JRE is in the repositories so you can just install it with apt-get/aptitude/synaptic which is the preferred method. I am not sure if this is the case with 9.04, but you may want to browse through Synaptic and see, and consider upgrading to 9.10 while you're at it.
 
Old 12-25-2009, 12:16 PM   #7
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
First, isn't jre available using the package manager? (Always install SW using the package manager if possible.)

Second, if you get jre for Ubuntu, you don't want RPM (I don't remember all the options)

Finally, there are many kinds of installers, but there are some common principles:

1. If there is an extension like .tar, .gz, .bz2, etc. then you have to extract first.

2. A file ending in .bin is typically expected to be executed, but you often have to set the permissions first. Example--for your case:
Code:
sudo chmod +x jre*
3. Instructions are typically available where you got the file, or in something like a README file.

Going back to one of your original questions: Commands are sometimes run in directories that are not listed in the PATH variable. This means that the full path must be given. Suppose, for example, you have that file in /home/username/downloads. That directory would not normally be in PATH, so if you simply type the file name, the system does not know where to look. You can:
a. cd to the directory and enter " ./filename"

b. enter /home/username/downloads/filename
 
Old 12-25-2009, 12:23 PM   #8
anand.arumug
Member
 
Registered: Oct 2009
Location: Dayton, Ohio
Distribution: ubuntu, centos
Posts: 68
Blog Entries: 2

Rep: Reputation: 16
Quote:
Originally Posted by AeonX View Post
ok, i'm trying to install jre-6u17-linux-i586-rpm.bin and the file is on the desktop.

can you tell me what the commands that i should type to install it?
Open a terminal window and type the following if you want to install just the Java Runtime Environment:

Code:
sudo apt-get install sun-java6-jre
If you want to install the JDK as well then type the following:

Code:
sudo apt-get install sun-java6-jdk
You might also want to do this after installing Sun Java:

Running Java under Ubuntu

Hope this helps...

Last edited by anand.arumug; 12-25-2009 at 12:27 PM. Reason: added a
 
Old 12-25-2009, 01:40 PM   #9
AeonX
LQ Newbie
 
Registered: Jul 2009
Posts: 21

Original Poster
Rep: Reputation: 0
cd ~/Desktop "~" do i need to type this or "~" replace it with the file name?
my keyboard isn't doing these special characters

sorry for this stupid question
 
Old 12-25-2009, 03:27 PM   #10
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,275

Rep: Reputation: 370Reputation: 370Reputation: 370Reputation: 370
Tilda is the literal tilds character, which is shift+` (top left of the US English keyboard). Did you read the rest of my post and the other posts in this thread? There are better and easier ways of doing what you want to do than installingthat bin file.
 
Old 12-25-2009, 04:59 PM   #11
anand.arumug
Member
 
Registered: Oct 2009
Location: Dayton, Ohio
Distribution: ubuntu, centos
Posts: 68
Blog Entries: 2

Rep: Reputation: 16
Quote:
Originally Posted by AeonX View Post
cd ~/Desktop "~" do i need to type this or "~" replace it with the file name?
my keyboard isn't doing these special characters

sorry for this stupid question
The tilda character is a short notation for your home directory which is /home/<your-user-name>. Desktop is a subdirectory underneath that. Instead of typing the path of the home directory you can use the '~'. If you are not able to type ~ then simply type cd <press-enter> and that should take you to your home directory.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
PXE installation problem - can only select A series packages for installation Nylex Slackware 4 08-19-2010 03:15 PM
Dom U Installation Problems on RHEL5+ Xen (installation exits abnormally) dmpatra Red Hat 1 07-24-2007 06:46 PM
Redhat/Linux Installation Support??? Is It Red hat installation problem??? wanux Red Hat 1 08-01-2006 11:32 PM


All times are GMT -5. The time now is 10:37 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration