LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 06-29-2005, 03:40 PM   #1
maxz
LQ Newbie
 
Registered: Jun 2005
Location: s.africa
Distribution: FC3
Posts: 3

Rep: Reputation: 0
Install Plplot


I struggeled to install PLPLOT
Finally got it to install (having stripped it down to the skeleton in the configure option )
However when i install the package that depends upon it , (GDL) it cannot find PLPLOT.
GDL asks for the PLPLOT DIRECTORY.
When i install PLPLOT to a directory using the prexix=............, the installation does not proceed as it then looks for a lot of other libraries.

? Is there a comand to run after installing a library ?
?How do i install a library to a user defined directory.
Thanks
Max
 
Old 07-01-2005, 01:26 AM   #2
akudewan
Member
 
Registered: Apr 2004
Location: India
Distribution: Ubuntu
Posts: 364

Rep: Reputation: 30
After installing new libraries, run "ldconfig" as root.
Since you are using Fedora, try using rpm packages.

Also, do "./configure --help" before compiling GDL, and check out the options. You'll most probably find the option to specify the directory of plplot
 
Old 07-01-2005, 01:29 AM   #3
akudewan
Member
 
Registered: Apr 2004
Location: India
Distribution: Ubuntu
Posts: 364

Rep: Reputation: 30
More info: You can find rpm packages at http://rpmseek.com/
Also, sometimes you may need the "devel" package of a dependency. So maybe you need plplot-devel or plplot-dev or something. Try to find out which one you need.
 
Old 07-02-2005, 03:32 PM   #4
maxz
LQ Newbie
 
Registered: Jun 2005
Location: s.africa
Distribution: FC3
Posts: 3

Original Poster
Rep: Reputation: 0
I get :
[root@localhost maxwell]# ldconfig
bash: ldconfig: command not found
[root@localhost maxwell]#
 
Old 07-03-2005, 06:53 AM   #5
akudewan
Member
 
Registered: Apr 2004
Location: India
Distribution: Ubuntu
Posts: 364

Rep: Reputation: 30
It must not be in your default path. Try
Code:
 /sbin/ldconfig
Or "locate ldconfig" to find it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to find my drivers 'xwin.so' of plplot? aendey Programming 0 11-30-2005 09:14 PM
make install does not install daemons (clamd snortd). Is this a feature of tarball? Emmanuel_uk Linux - Newbie 3 11-15-2005 01:29 AM
plplot.h can not be found with "plplot-5.5.3-7.fc4.i386.rpm" installed aendey Programming 5 11-01-2005 08:06 PM
Install Plplot maxz Linux - Software 0 06-27-2005 05:31 PM
How do I re-install an operatingsystem? Corrupted install. Yast wont load. URGENT.thx CrewXp Suse/Novell 5 05-09-2005 12:07 AM


All times are GMT -5. The time now is 01:51 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration