LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   install ns2.34 on ubuntu 10.10 (http://www.linuxquestions.org/questions/linux-newbie-8/install-ns2-34-on-ubuntu-10-10-a-4175433816/)

mohadeseh_mohammadi 10-24-2012 05:36 AM

install ns2.34 on ubuntu 10.10
 
hello
i am facing some problem during installation of NS2.34 on ubuntu10.10 where during building of OTCL i got an error i.e X include does not found exiting installation..
I have this:
checking for X11 header files
can't find X includes
otcl-1.13 configuration failed! Exiting ...
Please check http://www.isi.edu/nsnam/ns/ns-problems.html
for common problems and bug fixes.
then I write :
sudo yum install libX11-devel
but i have this error:
Setting up Install Process
No package libX11-devel available.
Nothing to do

please help me.i am in force to solve this problem

knudfl 10-24-2012 09:00 AM

Welcome to LQ.

No 'yum' in Ubuntu. ( 'yum' : That's Fedora, CentOS, Scientific, RHEL.)

Ubuntu :
sudo apt-get install \
g++ g++-4.1 make automake autoconf libxmu-dev libtool patch xgraph


.

rosehosting.com 10-24-2012 09:17 AM

You should be able to install ns2.34 using the following commands:

sudo apt-get update

sudo apt-get install ns nam xgraph

knudfl 10-24-2012 09:30 AM

# 3

No package by name 'ns'.

Ubuntu 10.10 : The package 'ns2' will provide ns-2.35~RC6-1
File list http://packages.ubuntu.com/oneiric/i386/ns2/filelist


.

rosehosting.com 10-24-2012 09:49 AM

Yes, that is correct, you need to use 'ns2' instead 'ns':

sudo apt-get install ns2 nam xgraph

Also, check the list of repositories defined in your /etc/apt/sources.list file.


All times are GMT -5. The time now is 02:17 AM.