LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
LinkBack Search this Thread
Old 07-02-2011, 12:53 AM   #1
ashu2188
LQ Newbie
 
Registered: Jun 2011
Posts: 18

Rep: Reputation: Disabled
Unhappy Install NIS on ubuntu


Hi guys..

I am trying to instalol NIS and when i just simply install it
i get this erorr

Starting NIS services * binding to YP server... * .... * .... * .... * .... * .... * .... * .... * .... * .... * .... [fail]
I tried to find the solution but didn't find any proper one.
Still facing the issue,
Can anybody help with this?
 
Old 07-02-2011, 02:05 AM   #2
frieza
Senior Member
 
Registered: Feb 2002
Location: harvard, il
Distribution: Ubuntu 11.4,DD-WRT micro plus ssh,lfs-6.6,Fedora 15,Fedora 16
Posts: 3,010

Rep: Reputation: 352Reputation: 352Reputation: 352Reputation: 352
it's been a while since i've used NIS so i don't remember the specifics, however you have to install and configure ypserv on the machine that is going to be used as the NIS server, then you can run and configure the NIS clients.
 
Old 07-02-2011, 02:05 AM   #3
Shahnawaz Uqaili
Member
 
Registered: May 2011
Location: Karachi, Sindh Pakistan
Distribution: RHEL, CentOS, Debian/Ubuntu, Microsoft Windows
Posts: 46

Rep: Reputation: Disabled
Hello ashu2188 and welcome to LQ,

After the YP binding fails you need to edit /etc/default/nis and set NISSERVER.

Once you have done this, run /usr/lib/yp/ypinit -m

Once this is complete you can run /etc/init.d/nis start with no errors.

Hope this works for you.

Kind Regards

Shahnawaz Uqaili
 
Old 07-03-2011, 02:13 AM   #4
ashu2188
LQ Newbie
 
Registered: Jun 2011
Posts: 18

Original Poster
Rep: Reputation: Disabled
Unhappy

It didn't help buddy..!

Still facing the same problem...
 
Old 07-03-2011, 02:15 AM   #5
ashu2188
LQ Newbie
 
Registered: Jun 2011
Posts: 18

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Shahnawaz Uqaili View Post
Hello ashu2188 and welcome to LQ,

After the YP binding fails you need to edit /etc/default/nis and set NISSERVER.

Once you have done this, run /usr/lib/yp/ypinit -m

Once this is complete you can run /etc/init.d/nis start with no errors.

Hope this works for you.

Kind Regards

Shahnawaz Uqaili


can you just help me with installing yupserv on unbuntu (Backtrack5)?
when i issue apt-get install ypserv
it says it didn't find the package. I guess if i can install ypserve , the issue can be solved.
 
Old 07-03-2011, 07:57 PM   #6
chrism01
Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.5
Posts: 16,086

Rep: Reputation: 1993Reputation: 1993Reputation: 1993Reputation: 1993Reputation: 1993Reputation: 1993Reputation: 1993Reputation: 1993Reputation: 1993Reputation: 1993Reputation: 1993
I'll pass on the Ubuntu specific part, but this is a good guide to NIS, may help you check/debug stuff http://www.linuxhomenetworking.com/w...onfiguring_NIS
Incidentally, NIS is unencrypted; are you sure this is a good idea? You may want to consider LDAP instead, which has an encryption option http://www.linuxhomenetworking.com/w...DAP_and_RADIUS
 
Old 11-09-2012, 05:54 PM   #7
corby
LQ Newbie
 
Registered: Nov 2012
Posts: 1

Rep: Reputation: Disabled
Turns out NIS installation on apt-get systems is rather bugged.
What it misses is the configuration of the /etc/yp.conf file.

Add the following line to the bottom of your /etc/yp.conf file.

domain <your domain> server <your NIS server>


Then rerun the nis service and it should be ok.
 
  


Reply

Tags
nis, ubuntu


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to login to NIS client machine(Ubuntu) using NIS login user name crazymoonboy Linux - Server 7 11-27-2009 02:29 AM
NIS failed for one user on one NIS client - strange problem resolved catbird Linux - Networking 1 10-05-2009 11:00 AM
ubuntu nis server 124vikas.dange@gmail.com Linux - Newbie 2 08-27-2009 06:32 PM
NIS: NIS running but users not able to log in with NIS credentials outerspace Linux - Server 3 10-17-2007 08:51 AM
how to configure NIS Client on ubuntu ksjaiarunkumar LinuxQuestions.org Member Intro 1 01-12-2006 03:55 AM


All times are GMT -5. The time now is 05:18 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration