LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 10-16-2003, 11:17 PM   #1
saffron
LQ Newbie
 
Registered: Oct 2003
Posts: 4

Rep: Reputation: 0
Unhappy Install LILO from Slack Bootable CD ? How ?


My english is bad ... sorry ...

How i make install LILO in MBR with SlackWare 9.0 bootable CD ?

I make error and delete my LILO from MBR (
 
Old 10-16-2003, 11:21 PM   #2
rakriege
Member
 
Registered: Oct 2003
Location: San Deigo, CA
Distribution: FC3, Win2k Server, XP Pro & 2003 Server
Posts: 198

Rep: Reputation: 30
/sbin/mkfs -t ext1 /dev/hda1

then

/sbin/fsck -t ext2 /dev/hda1
 
Old 10-16-2003, 11:34 PM   #3
saffron
LQ Newbie
 
Registered: Oct 2003
Posts: 4

Original Poster
Rep: Reputation: 0
but...

i dont have file mkfs ?!
i have mkfs.ext2 , mkfs.jfs , mkfs.xfs
in /sbin
 
Old 10-16-2003, 11:54 PM   #4
rakriege
Member
 
Registered: Oct 2003
Location: San Deigo, CA
Distribution: FC3, Win2k Server, XP Pro & 2003 Server
Posts: 198

Rep: Reputation: 30
hmmmmmmmm...

you basically need to rebuild your file system, thoses commands should have worked?

i would say try the others but MKFS is "DANGER WIL ROBINSON DANGER" it could erase your entire HDD.... try ext2 or the other ones you listed

but no guarantees
 
Old 10-17-2003, 12:35 AM   #5
lord_Belial
LQ Newbie
 
Registered: Oct 2003
Location: Bogotá, Colombia
Distribution: Slackware 9.1
Posts: 5

Rep: Reputation: 0
Boot your system with the Slackware Booteable CD

when the boot : appears type these extra parameters

boot: bare.i root=/dev/hda[2 noinitrd ro

where bare.i is the kernel to boot your system, /dev/hda2 is where your linux partition is installed (I am assuming this values) You'll have to put the correct ones according your installation

Next, login as root

mkdir /temp
mount /dev/hda2 /temp
cd /temp
liloconfig

with liloconfig you will be able to reinstall LILO

cd /
umount /temp
rmdir /temp
reboot

That's all
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Boot/Install Problem with LILO on Slack 10.1 Nalor Slackware - Installation 8 03-23-2005 01:25 AM
Ok fresh slack install and screwed up lilo... silverbullet Slackware 5 11-26-2004 01:34 PM
Lilo not coming up after Slack 9.0 install justinian1978 Slackware 5 05-30-2004 11:56 AM
LILO install error (only happens in Slack) SocialParasite Slackware 6 02-24-2004 05:26 PM
Experiences with making bootable slack install cds fskmh Slackware 0 09-04-2003 05:36 AM


All times are GMT -5. The time now is 11:14 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration