LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-22-2003, 04:07 AM   #1
scarecrow
LQ Newbie
 
Registered: Sep 2003
Posts: 7

Rep: Reputation: 0
Unhappy install headache (video graphics issue)


I installed RedHat 9 on a system that:
- has WinMe on one drive dualbooting with Win2K on a second drive (not a problem)
- has a ATI all-in-wonder Radeon PCI card in PCI slot (overriding onboard chip) (again, not a problem).

- It installed ok (no problems noticed until reboot), but one thing: it said I had an ATI Radeon 7200 and "unprobed" monitor, so i picked "ATI All-in-wonder Radeon AGP" (since it seemed a closer match than 7200 which isnt even the same chip as my card) from the list and left the "unprobed" monitor since nothing else seemed better, after all the X server that runs in the setup process (if that really is whats running) seemed okay thus far. I also punched ion the actual sync rates taken from my monitor's specs sheet.

Upon reboot it does everything OK and then the screen goes BLANK (i cant kill the X server here with ctrl-alt-backsp, just nothing happens so maybe its frozen)

Already tried:

- assuming th eproblem was that the driver/resolution/refresh config is out-of-range or unsupported for my monitor, so i must go back and set the graphics card to the Radeon 7200 (since the install screen's X server seemed okay with it). I tried completely reinstalling (reformatting too) from scratch but just using the default settings (radeon 7200, unprobed). but still same problem, the monitor just goes blank...

- tried to boot into the "linux rescue" and couldnt get to anything other than a shell that, using "ls" command, would only show the partitions and some other files but wouldnt let me change directories to run the "xf86config" or "xfree86setup" or get to /etc/X11/ to edit the XF86Config file.

- tried the linux startup disk but cant seem to get to a shell to do the same as i wanted to do like above.

- tried plugged into a better monitor hoping that could "catch" the odd refresh spec. no go.

- tried "upgrading" using the CD to try to get back to the video setup screen, but it just doesnt let you there it assumes everythings okay and wont let you get to taht paret again.

To sum it up:

1) is there a way to boot into a simple shell to make changes to the XF86Config file? (i already tried going into interactive startup and if i say "no" to most stuff at the end the screen still goes blank (as if its booting into X) i guess the "startx" statement isnt part of the bootup sequence?)

2) is there a way to not have it boot into the graphical X desktop by default? (i know Mandrake lets you choose that in the setup but Redhat 9 doesnt seem to let you)

3) does the install os use an xserver? (it seems to ask the same stuff that x86config gui app does) i assume that just leaving these setings as it set them (default radeon 7200) would work and i coudl at least get what the install os can get on its own, but no...

Last edited by scarecrow; 11-22-2003 at 04:05 PM.
 
Old 11-22-2003, 04:55 AM   #2
hazza
Member
 
Registered: Nov 2003
Location: Australia
Distribution: Mandrake, SUSE, Fedora
Posts: 122

Rep: Reputation: 15
You can boot RH9 without starting X by selecting the boot loader entry and pressing "a", so you can edit the arguments, and then place a "3" after one space. Then you should be able to login as root and run redhat-config-xfree86 or xf86config.

Also, if you booted from the RH9 CD-ROM to rescue mode, and you chose to mount your RH9 partitions, then you could try to do "chroot /mnt/sysimage" to get into your system.
 
Old 11-22-2003, 03:45 PM   #3
scarecrow
LQ Newbie
 
Registered: Sep 2003
Posts: 7

Original Poster
Rep: Reputation: 0
Thanks,
I typed in "<space>3" to create: grup append> ro root=LABEL=/ 3
then it reboots and im in the shell with no X server autostart. THANKS!

I never made any sort of login (all i did was create a root password) so i cant log in since theres no account (it just blurts "incorrect login") after blitting around i finally tried something that works:
Login name= "root" and then it lets me in with my root password (this noob is just now figuring this out, i guess thats what is meant by logging in as "root" - i always thought that was "su").

Im trying to use the "find" command to find "XF86Config" or "xfree86Config" or "xfree86config" or "XFConfig" or whatever thoses apps names are that let you create an "XF86Config-4" file. but it cant seem to find anything useful. i sent back to / and tried to search with:
"find -name XF86Config" and it finds the XF86Config text file in:
/etc/X11/XF86Config
and also:
/usr/X11R6/lib/X11/XF86Config
what is this one in the usr directory for, should i be editing this file too, or not, or instead of the other one?

anyway, i cant find the XF86Config utility (i was going to try to specify a differnt card, and since im not sure what to change in the XF86Config file itself since i dont know if changing the "Driver" or "boardname" settings in the "Videocard0" section since i dont know if these represent entries in some text file somewhere and they would have to be exact and case-sensitive and i'd just end up guessing what they are called. so i need either to access those referneces to see what to put in the "Videocard0" section, or use the UI (which i cant locate) to do it.

Last edited by scarecrow; 11-22-2003 at 05:00 PM.
 
Old 11-22-2003, 06:55 PM   #4
hazza
Member
 
Registered: Nov 2003
Location: Australia
Distribution: Mandrake, SUSE, Fedora
Posts: 122

Rep: Reputation: 15
The file /usr/X11R6/lib/X11/XF86Config on my RH9 system is a symbolic link to /etc/X11/XF86Config. You can check if the XFree86 configuration tools are install with:

$ rpm -q redhat-config-xfree86
redhat-config-xfree86-0.7.3-2

If you don't have redhat-config-xfree86 you can find it on CD2. It needs pyxf86config which is on CD1. It does not appear now that RH9 has xf86config. If you can't get redhat-config-xfree86 working then you will have to edit /etc/X11/XF86Config manually. The first thing you can do is delete all of the lines starting with "ModeLine". You will find them inside the monitor section:

Section "Monitor"
Identifier "Monitor0"
...
EndSection

You may as well remove the comments associated with each "ModeLine" line. The next step is to change the "HorizSync" and "VertRefresh" entries in the monitor section to valid values. The horizontal and vertical frequency ranges for my monitor are listed in the manual. So for my monitor the monitor section looks like:

Section "Monitor"
Identifier "Monitor0"
VendorName "Mitsubish Electric Australia"
ModelName "Diamond View 1770G"
HorizSync 30.0 - 72.0
VertRefresh 50.0 - 120.0
Option "dpms"
EndSection

Next you will have to modify the device section to specify your video card. Change it to look something like this:

Section "Device"
Identifier "Videocard0"
Driver "radeon"
VendorName "ATI"
BoardName "ATI Radeon 7200"
EndSection

The final section to edit is the screen section. Change it to look something likes this:

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 16
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Try these changes first to see if they work.
 
Old 11-26-2003, 04:15 PM   #5
scarecrow
LQ Newbie
 
Registered: Sep 2003
Posts: 7

Original Poster
Rep: Reputation: 0
Thanks for following up,

my "redhat-config-xfree86-0.7.3-2" blinks out, it would seem this same problem is occurring. If thats X's fault, and its only a monitor out-of-range iussue, then I should be able to do a ctrl-alt-backspace to kill X, but that doesnt work, perhaps X has hanged? or im mistaken...

I tried tweaking it manually as you described. same problem.

I'm wondering if those declarations in quotes have anything to do with some actual value that is refenrenced, and must be exact as to what to put in those quotes? Since i have an ATI All-in-Wonder PCI card, there's alot of things I could call it such as "All in Wonder ATI", "my cruddy ATI card" or worse. Do I have to be specific down to the hyphens and caps? or is it merely some arbitrary string for my own reference? if i must be exact, where can i get that info?

Anyway, i got frustrated and just reformatted and installed with Mandrake 9.2 and as long as i select the XFree 4.3 but _Without 3D Acceleration_ it works fine (3D acceleration appears to be the cause of the problem). Mandrake includes a great utility called XFdrake that lets you select all this stuff and test it. I saved my XF86Config-4 file so i could refer to it when i try to set up redhat again. so i tried that, i only changed certain entries so i wouldnt much up things since rh9 has some different naming conventions than mandrrake in its Xfree86 setup scheme. anyway i tried enough variations to find out that it just isnt working and so RH9 must be enabling 3D harware acceleration by default and i cant find any way in RH9 to select the non-3D accelerated XFree (there doesnt seem to be any 3D acceleration declaration in the XF86Config file, so this must be accomplished elsewhere).

I really want to have RH9 on this machine (i already have mandrake on my other box). If could disable 3D acceleration or use the non-3d version of XFree, it look like it should work. however, i dont know how to do that. i guess it would have to be done manually.

Last edited by scarecrow; 11-26-2003 at 04:21 PM.
 
Old 11-27-2003, 12:14 AM   #6
hazza
Member
 
Registered: Nov 2003
Location: Australia
Distribution: Mandrake, SUSE, Fedora
Posts: 122

Rep: Reputation: 15
You could look at the XFree86 log files to try and get an idea on what is happening under RH9 that is different on MDK9.2. The files to look at would be /var/log/XFree86*. There might be a hint on the last log line when X hangs under RH9 as to what module it's loading. Maybe you could post a diff of the XF86Config file under RH9 and MDK9.2 so others could better see what is different. I'm wondering if it's a PCI/AGP issue as well.
 
Old 01-01-2004, 10:46 PM   #7
scarecrow
LQ Newbie
 
Registered: Sep 2003
Posts: 7

Original Poster
Rep: Reputation: 0
Regarding the log file, the last line of it read:
(II) Initializing built-in extension RANDR

the line:
(II) Reloading /usr/X11R6/lib/modules/drivers/radeon.drv
(II) RAEON(0): [drm] created "radeon" driver at busid "PCI:0:4:0"

I did somehow manage to get it working with the following steps:

(1) edit "XF86Config" file and commented out (#) the line under the "Module" section that enables the 3D acceleration:
# Load "glx"
I found this out by installing mandrake and comparing the config file that worked with redhat's config file. This way, i was able to modify the config file and get "redhat-config-xfree86" to launch without the screen going blank.

(2) launch the "redhat-config-xfree86" utility

(3) I specified all sorts of customizations,
(a) tried several drivers that seemed appropriate "both the generic "Radeon" and the "ATI Radeon All-in-wonder AGP" and the one that the probe returns "Radeon 7200" they all work for some reason.
(b) i also set the monitor values to their "official" supported values [AppleVision 1710 30-80 Khz (horiz) 40-120 Hz (vert)] and now i get bettter refresh rates (1152x864 @ 84 Hz).

hmmm... everything seems to work in the utility regardless of whether i have the "Enable 3D acceleration" box checked or not.
Even if 3D acceleration is supposedly turned ON in this utility, my "XF86Config" file still has the comment-out "#" that i put in the "load glx" line, so im not sure how the util is enabling/disabling the 3D acceleration, perhaps the util is assuming it is on even though it has been set to off by my external hand-editing beforehand.

Anyway, run startx and Gnome comes up just fine. somehow it works and thats good enough for now, but i still feel like some sort of voodoo occurred. i dont really buy the "glx" line was the source of all my problems, but perhaps it was, its kind of strange how just trying this permanently fixed it -so that even if i reinstate the supposedly bad 3D acceleration it still works, whereas it seemed that it didnt work until i tried turning it off. turning it off seems to have modified something other than the config file itself, otherwise i would expect to be able to reproduce the original problem by backtracking my steps... mysterious, maybe ill never know...
 
Old 01-05-2004, 05:22 PM   #8
looper
Member
 
Registered: Apr 2003
Posts: 68

Rep: Reputation: 15
Did you try running Xconfigurator ?

Just type Xconfigurator on the command line as root
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Install headache pompeyjohn Linux - General 11 11-03-2005 08:00 AM
Slackware 10.0 install giving me a headache GeneralChaos Slackware - Installation 17 07-02-2005 08:53 PM
Graphics Cards - Issue Kane2002 Linux - Hardware 29 01-20-2005 12:58 PM
Getting Headache Install of Slack 9.1 777JR Slackware 1 11-29-2003 09:02 PM
Sorry, yet another graphics (nvidia issue) Mestax Linux - Newbie 13 11-07-2003 09:24 PM


All times are GMT -5. The time now is 06:55 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration